[Advice Needed] Modded BIOS for i3 8100 on Gigabyte H110M-H

Hi experts and friends,

I’ve been reading this forum for years, but didn’t quite jump into the real act, until today…
I have a Gigabyte H110M-H motherboard currently running a G4400 skylake CPU and 2x4GB 2400Mhz DDR4 sticks.

I wished to upgrade the CPU long ago, but came across the Coffeetime utility and had planned to go forward when I get a good deal on 8/9th gen CPU that doesn’t require any pinmods. I’m getting an used i3 8100 at a good price and 7 days return policy now, so thought, why not try it this time…

To make one thing clear, I don’t have access to a chip programmer, spare chip or raspberry pi and do not intend to buy any of those. I am not comfortable with pinmods, so only B0 i3 8100 was chosen.

Yesterday, I did the following:

  1. Downloaded the latest F24 BIOS from GigaByte. (Currently using this stock ROM on system).
  2. Using @BIOS tool, dumped current ROM and saved as (bios.bin)
  3. Fired up coffetime and did adjustments as found on the guides here and saved it as (mod.bin)
  4. Tried to flash using Q-Flash (renamed mod.bin to H110MH.F24), getting invalid file error. (expected it)
  5. Looked up official F24 Zip file and it has efiflash.exe (I don’t know its version yet).

[ Download LINK ] for the 3 files to have a look at and to compare the ROMs.

Q1. Have I proceeded in the correct way and made correct settings so that my PC would boot up with both current skylake G4400 and coffeelake 8100 I’m buying?

Q2. Should I use modded EFIFlash.exe from DOS boot? Which version? 0.62/65/?

Q3. Any switches to use while flashing? (I often read /z/y/x/c…)

Thanks in advance…

you could use modded efiflash for it, or intel fpt.

parameters for efiflash /X /R

you can add /C for clearing the DMI, also /DB if you do have dual bios

you could try this bios, it got everything updated (mcode latest with kbl and skl still supported, igpu orom and efirom) except efi for lan, and resizable bar is possible too:
H110MHcfl.rar (5.4 MB)

@Koekieezz Thanks for the link to a pre-made one, but I wish to try on my own instead of going for someone’s work (no offence meant, it might be working/tested), I need to check what I learnt is right…

Can you please load the ROMs in linked in OP and open up in coffeetime to check if I patched it the correct way ? (stock vs mod)

Thanks for your reply…

im not an expert on looking other errors but one thing i noticed is that your modded bios do have an extra GUID below the first 8C8CE578-8A3D-4F1C-9935-896185C32DD3.

original F24 bios and my modded bios doesn’t have extra guid, just extra mcode guid under A8EE1777-A4F5-4345-9DA4-13742084D31E for skylake mcode. wont know if it would work correctly but you could try my bios using qflash or efiflash/intel fpt. if it worked, compare it one by one to see what has been modded in my bios compared to yours (since you want to learn, u know the drill)

1 Like

Would that extra GUID make it unbootable? And is “remove ME recovery” feature required for this board?

wont know till you try :smiley:

@Koekieezz OK, I managed to generate a fresh one from gigabyte official F24 that doesn’t have the duplicate guid as you pointed out.

Just want to confirm if any Coffee Lake CPU with B0 stepping rev. would work on H110M-H with the proper BIOS mods done, without any pinmod. It might be a 8100,8300,9100,9300 or even K/F/T versions of them, right?

(I don’t plan to use any F/K CPU though and prefer using iGPU with lower power envelope)

@agnivo007 Correct, B0 revision does not require pin mod.

Revision B0 (CPUID 906EB):

Celeron [2/2] : G4900 (SR3W4), G4900T (SR3YP), G4920 (SR3YL), G4930 (SR3YN), G4930T (SR3YQ), G4950 (SR3YM)
Pentium [2/4] : G5420 (SR3YH), G5500 (SR3YD), G5500T (SR3YE), G5600 (SR3YB), G5600T (SR3YF), G5600F (SRF7Y), G5620 (SR3YC)
Core i3 [4/4] : 8100 (SR3N5), 8100T (SR3Y8), 8300 (SR3XY), 8300T (SR3Y1), 8350K (SR3N4), 9100 (SRCZV), 9100T (SRCZX), 9100F (SRF7W), 9300 (SRCZU), 9300T (SRCZW), 9320 (SRF7X), 9350K (SRCZT), 9350KF (SRF7V)

[Edit] I have included the S-Spec of each B0 CPU as there are other SKUs that are not B0 die but are dual/quad core and require the pin-mod:

Revision U0 (CPUID 906EA):

Pentium [2/4] : G5400 (SR3X9), G5400T (SR3XB), G5420 (SR3XA), G5420T (SR3XC)
Core i3 [4/4] : 9100F (SRF6N)

1 Like

@chinobino Great, thanks! I’d be probably settling for 8100/9100 as these are easily available as used under $50 here…

Q: Original F24 BIOS doesn’t show ME recovery disabled when loaded in CoffeeTime 0.99, should I keep as it is in modded version?

@agnivo007 I think some Asus boards have the ME recovery jumper but I have yet to see a Gigabyte Z170 / Z270 / H110 / H270 board with it, so yes just keep it as is.

1 Like

@chinobino Some queries if you have time…

Q1. In CoffeeTime app, the microcode section lists various microcodes for skylake, kabylake, coffeelake and the tooltip message shows (ES) for some revisions. Is it “Engineering Sample”?

Given that I would never use or have hands on any engineering sample processor for the lifetime of this board, can I safely discard (unticked) those microcode options in the modded bios?

Q2. Is it safe to use the lastest available internal GOP and VBIOS versions shown in CoffeeTime 0.99 while maintaining compatibility with my existing G4400 and future 8100/9100 ?


@agnivo007 Q1, Correct it does stand for ‘Engineering Sample’ and yes you can remove those ES microcodes as you won’t be needing them.

Q2, You shouldn’t have any issues with the latest GOP and VBIOS used in CoffeTime 0.99 with any Gigabyte H110 / H270 desktop board as they all tend to have very similar configurations (usually 1x HMDI 1.4 and often 1x VGA or Display Port 1.2).

The more expensive Gigabyte Z170 boards that have Thunderbolt 3 (Z170-UD5 TH, Z170X-Gaming 7, Z170X-Gaming G1) and the LSPCON chip (which enables 4K @ 60 Hz over HDMI 2.0) might have issues but I’ve never tested this myself.

It is far more likely to be an issue with laptops and can result in an upside-down display orientation (inverted a full 180°) when the original VBIOS configuration is not copied exactly. In these cases you would need to use Intel’s BMP tool to re-create the correct VBIOS configuration. It appears that the GOP seems to work fine in UEFI mode (CSM disabled) in most scenarios.

1 Like

@chinobino On the modded efiflash topic, all links to download are dead. Can you please give download link to modded lower versions?

I think that is the best way to flash modded bios on this board, right? (qflash will fail)

@agnivo007 Hi, yes I would recommend using the latest modified version of efiflash.

I just checked all the links on the first post of the thread [Tool] EFIFLASH v0.80/v0.85/v0.87 FOR GIGABYTE MOTHERBOARDS and they all appear to be working (the download counters are still increasing)

Maybe your browser or AV program are blocking the download?

@chinobino I was able to flash modded BIOS successfully, booting and working fine with current G4400.

Please confirm if an i3 9350K would be a direct fit now without any pin mod… (getting a sweet deal now)

UPDATE: I hit the order button already, it’s coming!

@agnivo007 Hi, yes 9350K will work without pin-mod, I have tried this myself.

It’s a great chip - can OC to at least 4.9 GHz fairly easily with a decent cooler.

1 Like

@chinobino Installed 9350K, running fine on the board so far, thank you for all the help!

1 Like

@agnivo007 Hi, that’s great to hear!

I am sure it will serve you well, you are very welcome :+1: