After Win8.1 install - disks show as "Incompatible" in Intel RST BIOS

Don’t know where does this post really belong…

I’ve got a fairly old MB, ASUS P5B-E with ICH8R chipset, and Intel option ROM version

For a long time I had 4x500Gb drives configured as Matrix RAID (RAID0 and RAID5), working without any problems under Windows 7, booting from RAID0.

And today I did two things simultaneously:

1. Added a SanDisk Extreme 2 240Gb SSD
2. Installed Windows 8.1 on it

And in the process of installing, Intel ROM on boot started to show RAID disks as “incompatible”, and “No RAID arrays defined”.

Removing SSD does not solve anything.
Another HDD on the same controller is shows as Non-RAID disk, as it should, only those which were in RAID are “Incompatible” - incompatible with what I wonder?

What is surprising, however, is that from Windows 8.1 itself both partitions are seen and working properly - it’s only BIOS which can’t see them, and I cannot therefore boot into old Windows 7 installations.

There are no separate BIOS updates on Intel site, and no BIOS updates on ASUS site for a long time.
Also it seems there were no successful BIOS moddings for my motherboard mentioned, and I’m not that eager to try it myself…

Is there any known way to solve this? What could cause BIOS to stop recognizing the drives?

@ CavalerPk:
Welcome at WinRAID Forum!

1. With which SATA port (Intel or JMicron) did you connect the SSD?
2. If it was one of the Intel SATA2 ports, have all HDDs and the SSD been detected by the Win8.1 Setup?
3. Onto which of your drives (RAID0 or SSD) has the Win8.1 Setup created resp. updated the boot sector (MBR)?

Obviously the BIOS was not able to manage the new boot configuration.

Irrespective of the question, if an update of the Intel RAID ROM is possible, I recommend to try the following:

  1. Restore the original MBR of your RAID0 array by using the tool EasyBCD.
  2. Reconnect your SSD and unplug all your HDDs.
  3. Do a fresh install of Win8.1 onto the SSD.
  4. Once the OS is up, reconnect your HDDs.
After having done that, you will have at least 2 independant MBRs, one on the RAID0 and the other on your SSD. This hopefully will give you the opprtunity to change the boot order within the BIOS (or by hitting F8 or similar) while starting the computer.


  1. SSD is connected to “native” port, Intel one.
    2. Yes, Win8.1 detected both SSD and even properly detected RAID drives - with RAID itself, so I can access it with no problems.
    3. I’m not sure, but I seriously suspect that since I installed it as fresh install, not an upgrade, it shouldn’t have touched drives other than SSD.

    As to your suggested steps, there is something I wanted to clear up first.

    In my view, the function of that option ROM is to present existing RAID arrays as “virtual” hard drives to the main BIOS, via, I guess, Interrupt 13.
    And then it will be a task for main BIOS to analyze MBR or other boot code - which resides, let’s say, “inside” the RAID.
    But it seems that Intel ROM can’t find the RAID array information, which is “outside” the RAID, and I guess is somewhere in the first physical sectors of each drive.

    So I surely can update MBR on RAID, but since main BIOS doesn’t see it as a drive at all - it won’t make any difference.
    It can see even completely unformatted drives with no MBR, no partitions etc.

    What I thought is to backup all data from RAID, delete the array and re-create it from BIOS. But I have to find some extra storage for it.
    Or try to flash updated BIOS, but BIOS modding is one of the things I haven’t tried yet…

You can easily verify, where the MBR of the OS Win8.1 is by temporarily unplugging the power cables of all HDDs and restarting your computer. If you should not be able to boot into Win8.1, the boot sector is outside your SSD.
Another option is to run the Win8.1 Disk Management and to look for the Disk, which contains a volume with the attribute "Boot".

Well, selected boot drive is SSD, so I can boot without RAID drives.

I tried to update to a bit newer Intel BIOS, namely 8.9.1, which is rather old - and it showed RAID disks without any problems.
But then I ran into exactly the same problems as were described on this forum before - Updating Intel Matrix Storage Manager for Asus P5B-E

@ CavelerPk:
You may try the following:
1. Do a backup of your important data.
2. Update the Intel RAID ROM module of your BIOS to v8.9.0.1023 or v8.9.1.1002.
3… Boot into Win8.1, run EasyBCD and let it add the MBR entries for your Win7 partition (which is within your RAID0 array).
If it should work, you wll have a real dual boot system and you will be able to choose the OS while starting your computer.

I updated RAID ROM - and now I cannot boot anything, system is stuck on “Checking NVRAM”.

I’ll try some even older ROMs, like 8.5 or even 7.5 I extracted from BIOS for ICH9R motherboard…

This indicates a memory issue.
Have you re-set the Default BIOS settings after having flashed the modded BIOS?
Have you recently done a memory test?
Did you change anything with your RAM sticks?

At first step you should try to solve the issue regarding the RAM modules.

I flashed Intel ROM version 7.5 (from ICH9R) motherboard, and everything is working properly: ROM shows disks as members of RAID, and I can boot from RAID or from SSD.

Here I attach this ROM file, maybe it could be added to the collection here just in case someone needs it

Here is the file

Intel_MSM_RAID-ROM_v7.5.0.1017.rar (38.7 KB)