Alienware 15 R2 Page Fault in NonPaged Area when either booting Windows 10 or reinstalling Windows 10, PLEASE HELP!

Thanks to anyone who can help. I recently upgraded my Intel Me Firmware using the information on this page. I did all my reading before doing so and did all the proper steps. I utilized the Intel ME system tools before flashing the firmware which was the Intel ME 11.0 Consumer PCH-H Firmware v11.0.18.1002 as my rig has the Intel Skylake Core i7 6700HQ processor. I didn’t get any errors when I flashed and then I rebooted my machine and was greeted with the BSOD for Page Fault in NonPaged Area! I have tried to reinstall Windows 10 but as soon as the USB starts to boot it immediately gives me the same BSOD. I have tried to downgrade my BIOS from within the F12 utility and it does downgrade the firmware but there are 4 sections and the ME section doesn’t get touched, meaning it doesn’t flash anything to that section of the BIOS. I am at my wits end as I have been searching Google everywhere in regards to this but have come up with nothing. I have even tried the reset of the NVRAM which is under the memory chips and you just short the two copper tabs while the power cord is plugged in. Still the same. I have tried to boot to DOS which when it tries to create a Ram drive of 64mb it just gets stuck and tried booting into React OS but it gives me not enough memory, I have 8 gigs of physical memory. So my assumption is that the Intel ME Firmware update did something with how the system see’s the memory? I’ll admit I am a noob when it comes to BIOS modding and such but I have been in the PC repair business for over 17 years. This one has me seriously stumped. Can someone please help me out it would be greatly appreciated. I just hope I can get my baby back up and running to where it was before. I should have never updated the firmware but the curiosity got the best of me. Thanks in advance!


Thank you for reading thoroughly before flashing and for providing a proper even log of what happened and how you tried to resolve it. I don’t think you did anything wrong, it’s the first time I’m hearing of such an issue.

You chose the correct firmware SKU and version for your system. What tool did you use to update the ME firmware?

Is the system stable while at the BIOS/UEFI? Does it mention the amount of RAM detected? It usually does.

Are you able to boot into an EFI Shell instead of DOS?