Alienware 17 R1 "ranger" - BIOS help

hello everyone, hope i can find help here…

I have an Alienware 17 r1 (2014 - "ranger" no internal graphics)
it came originally with a gtx880m which died almost one year ago, so i replaced it with a gtx980m

Everything was working fine until i " accidentally " modified the UEFI options activating legacy mode but my new graphics cards does not boot in legacy, so now my laptop just beeps 7 times, black screen, cant access bios settings, no boot, nothing. Everything was working fine before that and no hardware changes have been made so im sure the screen is fine.

now, getting a new 880m will cost me too much, so doing some research online I was wondering, could i dump my current bios and modify the settings back to UEFI? if so, could someone please send me information about this process.

On the other hand, i have an old bios backup but im not sure how to deal with it, i dont want to make it worse since i have no experience with BIOS modding and i wouldnt be dealing with it if it wasnt extremely necessary… like now =(

My backup dates 2019 and i think i made it just after replacing graphic cards, i used a software called "BACKUP_Tools12_2.exe" and i got 4 .bin files around 4096kb each (x32_bios-region_9.1.2.1000.bin, x32_bios-region_9.5.14.1724.bin, x32_bios-region_9.6.0.1038.bin and x32_bios-region_10.0.30.1072.bin)

I did some research,and following other users I bought a CH341A programmer which i hope its compatible with my laptop.

Any help you guys could provide, will be much appreciated.

Things i already tried and didnt work:

Removing CMOS battery , removing and shorting battery pins
Removing cmos battery and RAM, then reinserting it while reboot (melemory error un-brick method)
BIOS recovery using usb in e-sata port (even if it worked, it would set Legacy as default)
holding keys while reboot

writing this from my emergency-only cracked screen lenovo laptop.


Alienware Beep Codes Table

1 Possible Motherboard (covers BIOS corruption or ROM error)
2 No RAM detected
3 Possible Motherboard Chipset
4 RAM failure (other)
5 CMOS Battery
6 Video card/chip
8 LCD…le/td-p/5588971…up/td-p/5559907

thanks for your answer but im sure the CPU is fine, like i said the problem started when i changed the boot bios settings. In fact, it had happened to other alienware users but my laptop doesnt have an integrated graphics chip so I cant follow their repair methods.

thanks anyways.

You’re neither providing your bios backup files nor the repair methods other users used with integrated graphics, that’s not directly an invitation to take a look into things…

I think im not allowed to post links to other websites yet but if thats not the case please let me know ill post the resources i’ve found.

I’m also attaching the backup files i mentioned earlier, thanks.

Not a complete backup, but the bios region, 4 identical files. You’re not allowed to post complete links as long as you have a certain number of posts (5?).

What bios version are you on now?

I updated to A17 a few months back.

I tried the method posted in comment #3 here (link), but as mentioned in comment #5 it doesnt work for "AW17 (Ranger) with 120Hz 3D display" (which is my case, no internal graphics)

I had to paste the link in the txt file since every time I try to post it here I get an error:


Your posts contains to many links. A maximum of links is allowed."

link.txt (73 Bytes)

Thanks. I read about the method, but it doesn’t seem to help here and it seems not completely clear what that really does. I’m still concerned about tthe beeps.

Is that right that you bought a programmer and a SOIC-8 clip?

Post sharp high resolution pictures of the motherboard and the graphics card, both sides. Chip inscritpions should be readable, so you may have to take only parts of the board at a time.

If this backup of the bios was working properly when made easiest thing would be to flash it back, stock firmware contains FD, ME so one could create a complete firmware image.

But lets identify the bios chip first and read it out!

I treid turning it on again and I noticed I got 8 beeps (not 7 as I wrote in my first post).

yes I have the programmer and the SOIC 8 clip.

Im attaching the images, also, acccording to this, my board have two bios chips(64mb and 8 mb), I tried to magnify both of them marked as winbond 25Q80BVSIG 1344 and winbond 25Q64FVSIQ 1414.

Yes it was working fine, it was just an older bios version.

Thanks! 8 beeps would be a better sign.

U2 25Q80BVSIG 8 Mbit = 1MByte some other firmware

UH14 25Q64FVSIG 64 Mbit = 8 MByte, will probably be the bios chip. Try to read it (pin 1 is the dot). Be careful to attach the clip properly, it’s a pain until you got a little training…

Read it at least twice and save both readings to different files. Compare the files, they should be 100% identical. If identical: Zip and post. If not- try it again.

If you’re looking for software- asprogrammer 1.4.1

Ok i tried all night but finally got them, I dumped it with the software you provided in the link. Both files look the same to me, i compared them with vbindiff.

thanks (3.51 MB) (3.51 MB)

OK, seems to be OK, static bios parts are identical to A16 bios, differences stock to backup are only in NVRAM (VSS-/ FTW- store).


To find the settings in NVRAM will be trying to find a needle in a haystack, so (if there’s not anything else changed outside bios and your old bios backup was made in a working state) simply copying the old bios region into your dump should make your notebook work again.

Try the attached file.

You experiencend already that it’s not too easy to get reading done properly do it the following way:

- Read the content of the bios chip once again, save, compare the freshly read content to read1 or read2, should again be identical. This will confirm properly attached clip.

- Erase, blank check, write, verify the file alw17.bin

- Read the content of the bios chip again, save, compare saved file to alw17.bin, files must be 100% identical.

Clear CMOS, try to boot…

Flash procedure may seem very pedantic to you, but one has to be a 100% sure that the flash was properly done. Good luck!

(I thought maybe it’d be possible to check the bios of the graphics card, but this chip there can’t be read with a SOIC clip. Did you ever try to the read the Nvidia firmware with nvflash?) (3.52 MB)

No I havent used nvflash before, but the good news is that the flashing process went fine and now my laptop is booting again!.

thanks for all your help, I was wondering, if possible, could you explain to me how did you manage to recreate that file( Im not planning to mess with my bios anytime soon, but Im always keen to learn new stuff.

thank you.

Thanks for the feedback!


Complete firmware is in your “read1.bin”, green rectangle is bios region = your old backup (the 4 identical files), orange rectangle is where the relevant settings are / where the difference to a stock bios is. So one might use a hex editor (HcD, …) to just
- take this block from old bios backup and exchange it in read1.bin or
- take the complete old bios backup and replace the complete bios region in read1.bin That’s what I did, meaning you have to update your bios again since the backup was an older version.

This is not advanced ‘surgery’, but finding the corresponding setting/ variable in NVRAM would require that one backups the bios again, just changes to legacy, dumps the bios again and hopes that difference is just one single variable one’s able to identify.

Would reccomend to dump the bios from time to time using the ME System tools corresponding to your ME version (9.x)
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools Section C2

fpt(w(64)) -bios -d biosreg.bin

The first part of your bios can be ‘re-used’, FD is static, ME isn’t, but configuration doesn’t change.