Alienware 17 R5 Engeneering sample need help to mod bios

I agree with LOST. There are many different things which could cause the Production BIOS to not work with PRE hardware of Engine/PMC firmware. Since these tests failed, the last thing to do is try to fix the current BIOS, if possible.

@ Lost:

Ok, I assume you figured out FIT then. It’s very simple and automatic. You load the components (BIOS, EC, Engine etc) and it will automatically figure out the padding. For a ready SPI image it’s even simpler. Just replace the BIOS region and rebuild. You should see at UEFITool that the BIOS is at the end and the Engine region is now larger by one 1MB, in this case.

I figured out what stalled me at first about the BIOS region size and swap with FIT, then few minutes later I realized duh same as swapping out ME . That’s what I did, opened file, saved XML, replaced that region, opened FIT, loaded XML and built.
Yes, all looked correct in UEFITool after that too, I just never did region swap that way so it confused me at first. I was expecting to see and change the BIOS region size at flash layout

You could do it like that but I think you can simply adjust the BIOS location input field at Flash Regions (or whatever it’s called) and end up with the same result, just without the xml hassle.

I’m used to doing the ME process a little bit now, and so that seemed easiest to me, since I don’t play with that tool often enough.
It’s too bad CPU is soldered to PCB in this case, otherwise I’d probably suggest retail CPU at least to try, in case that silicon is part of what’s causing him the issues with the temps/fan speeds, and since it is soldered this is something we can never test to confirm/deny too

Well as I said in my first reply, there are a lot of “mays” and “ifs” when working with PRE hardware and firmware. We can only try but don’t get your hopes up.

Guys! How about thundertbolt? Can it cause an issue? In the production bios there are thunderbolt settings in es there is no thunderbolt settings. also when i try to update TB firmware using dell/intel TBFW tools they both said that there is no TB devices found in the system! Also i have USB C controller error code 43 in device menager and laptop does not recognise USB hub with devices connected to it.There is I think a TB firmware chip near TB controller. May be i should flash there firmware?

Also there is a chip with a (I suggest) with a Alien FX firmware should be or a separate EC firmware like it is on AW 17 r4 and all old AW’s. May be we need to extract it from the factory dell’s bios. Because as far as i know when i was working with dell systems you always had to flash both chips with 16mb and 4mb may be this is an issue?

I mean mean if we swap bios body to dell’s offical bios update may be then EC controller needs a separate firmware on separate chip?

Board chips…iew?usp=sharing

By the way I done clean windows install. And I installed aw command center and it recognized laptop as aw17 using Fn + F12 key I turned off alienfx for good. Now its compleatly dark even when i start laptop. But now alien cc says no alienfx devices detected!

Please use the edit button to add info to your posts within a small time frame before some else replies.

It is very likely that some features don’t work at these Engineering machines because they weren’t ready at the time, their firmware was bugged, old hardware revisions etc. There’s not much one can do without Dell’s internal firmware for that Engineering sample so the goal is to get basic functionality working. TBT is extra at this point and I don’t think its firmware is included in the BIOS region. Explain exactly what important problems you’re facing and provide whatever info LOST requested, just in case something can be done. There is no need to send me the stuff requested by LOST as well.

It doesn’t matter if that can or cannot cause issues, it’s not easily removable from the stock BIOS, so not something we can address.
As for TB and USB, don’t try to flash them, until you first dump them with some programmer or software, they may be fine and have working FW in them now (I suspect they do), you just have to find proper software that will work with them.
Yes, it’s very likely there is a EC chip, this is common with Dell. This would control, or at least help control the lights and fans sometimes too. EC FW is not something I can edit, well I can edit anything, but I mean I have nothing that will break this down into readable settings to change etc (usually)
Dump the EC chip and send me a copy to look at.

EC chip is empty. I checked there is no firmware there.

How do you know? That can’t be right, or it wouldn’t boot. Probably you need to use other software version to dump that chip, or you tried to dump something that is not a flash rom. What is the chip ID?
Is BIOS images what you linked me to in PM? If yes, I’ll go check, if not, please put that link here with explanation of what it is, I can’t keep track of anything in a PM

I dumped that chip and it’s empty. All filled with FF FF FF FF…
The chip is winbond 25x i dont remember exact model. But i know for sure that there is no firmware on it.
Yes i sent you photos of each bios page by pm as you requested.

That does not mean it’s empty, like I said that’s highly unlikely or it wouldn’t boot. This means you need to dump with some other software version until you get a valid dump with data.
That is why I asked you for the chip ID, in case I knew what version or ID you need to use if not exact one. I did not request anything by PM, I’ll see if I can find your message again
* Edit - I checked the images, thanks! I can make full unlocked BIOS for you with this kind of BIOS! Then you can adjust anything you want, in order to try and resolve the fan/heat issues.
Please wait, and I will make you unlocked BIOS. There may be a few BIOS I need you to flash interim and give me answers about, before full unlock BIOS is done. I’ll update soon

I dumped that chip and it’s empty all filled with FF FF FF… I use tl866 programmere with it’s original software it will dump enythig you need . I have AW17R4 dump of two chips and it’s 16 mb and 4 mb but my 17 r5 has nothing on that chip. May be that’s fhy it has 32mb bios dump?

May be there is a posibility to flash that 7mb bios by afudos or some other utility? Or any chance to repair current bios to more stable state?

@code9523 Yes, I will repeat too I guess for the third time, maybe forth, that is not possible or the board wouldn’t boot. Not all programmers automatically can dump everything properly, so you can’t just accept that it’s empty.
Please dump with another programmer or software if you can, if not then nothing we can do until you have another programmer such as CH341A and dump with all software versions so we can confirm.
I can dump any BIOS and use the wrong thing I know doesn’t work and dump will be verified and all FF or 00, so a dump of all FF only means that to me, incompatible programmer/software in many cases.

Does this system have two BIOS chips? If not, then that’s probably also why the stock region wont work for you, it’s setup in a way that BIOS is split, like you’re used to and mentioning.
Anyway, nothing we can do, if you want further help please explain to me your issues with the BIOS from post #4 and I will see if I can address via updating anything and I will unlock the BIOS for you so you can access all settings.

“7MB” HDR stock BIOS region has already been tested by you, in four ways and you said they all failed to boot.

I will repeat the same that chip is empty. Look i downloaded regular bios from winafix for this board. I checked dump from winafix with one i dumped from board and my dump was empty. I’m not sure that dump i downloaded was ok or not so i flashed it on two chips as it signed. And got no boot on that one. Then i flashed back 32mb and the board works fine. So ue2 dump on ES can be emty it’s not doing anything. I attached You those files i downloaded. Here is the link for those files…iew?usp=sharing

My issues in current bios are:
Fans spin from 50% all the time even in idle.
AlienFX lightning is blinking and i’m unable to configure it.
UCB C device controller is in task menager with error code 43. I cant do anything with it i think it’s related to thunderbolt not working.
No Thunderbolt settings in bios / cant flash it / Tb port is not working.

I repeat it’s not, and since you want to argue about this, I will step away from this thread or we can stop that part of the discussion. I know nothing about a winafix BIOS, if you mean vinafix, also not mine or related to anything we’re doing here… EC chip is usually 1MB or so, often less.
Are you saying you erased your EC Chip to try and program in some unknown EC, without confirming your EC chip was actually blank, but now since you erased it then it’s for sure blank? If yes, then nothing we can do there, you erased the EC FW, it’s not blank because it’s unused and was always blank, you erased it.
I do not need to see any vinafix BIOS, often those are stock BIOS anyway. Plus, no need for me to look at those, they do not apply to your board.

Thank you for the issues list! Fan spin at 50% sounds normal, some chips are so hot, or heatsink is so weak, there is no way around that in a laptop.
However, once I unlock BIOS for you then you can tinker with all the related BIOS settings. AlienFX stuff has nothing to do with BIOS, only EC, so nothing I will ever be able to do for you there. Unplug the LED’s if they bother you
USB is not related to thunderbolt, those are two totally different devices. However, both could be failing due to ME FW/settings, which would make them related, or they both may be failed due to some BIOS module I can’t address, or the FW in their chips, hard to say for ES system.
TB settings in BIOS, if there, you will see once I unlock. I’ll work on that now.

I just wanted to say that it may be blank and EC controller can be programed in other way like direct programming. And that ec chip is empty. Because ec controller has a firmware inside. And i dont have any more dumps of that chip to confirm that ec controller will act different with another firmware on that chip. If you have such dump and you can share please i will program it and we will see. I have only dump from 17 r4 of that chip and yes it looks like firmware but i dont think it will work. As it’s different model.

About the heat and chips. I wrote before here. That i can connect 15 inch lcd to this motherboard and then the laptop thinks it’s alienware 15 r4 the gpu changes to Maxq version and then fans spin normally. In idel they are silent and uder load they are loud. The heatsink is giant copper pice here 198wat. It can handle any kind of heat. Any way i repasted it with good thermal compound. In idel temps are 35c on cpu and gpu. But fans keep spinnig if it’s with 17" lcd. If with 15 lcd fans are silent. Also the cpu 0000 is cut by clocks to 3.6 ghz and it’s pretty cold either.

I attach file with dump of aw17r4 fron UE2 chip and it looks like firmware. May be this is an issue that my 17r5 is not working with swaped bios region because it needs also such firmware on that chip to work with?

And if there is 32mb dump it’s configured to work without that chip? (1.39 MB)

You erased it though, so you can’t program anything back, since you did not get a valid dump and then proceeded to erase and try to put in something else, so original contents lost now. And I’m sure right after you did that you noticed fan and LED behavior changed, due to EC Failure/change from previous behavior
You need original ES EC FW that was on there before you did anything, nothing else will match up with this ES BIOS and ME FW etc.

Interesting thing about the LCD, thanks, I didn’t notice you mentioned before, or didn’t realize it was important. Please explain more, how you see this >> The laptop thinks it’s alienware 15 r4 << Where do you see this? And same >> gpu changes to Maxq version << Where do you see this
Are those changes OK for you, I mean you don’t mind if I found the reason for this, and change it to be same for 17" as with 15"? With GPU-z, can you dump the GFX vBIOS? If yes, send me a copy, and I will check on inside the BIOS too.

Before we go any further on BIOS editing, please test this BIOS for me and let me know it’s OK or not, this will be my base moving forward. This is BIOS plutomaniac made for you at post #4, but with updated CPU microcodes only.…112487643193200

* Edit - to your edit - Other system have nothing to do with this system, nothing from other system can be used here. But yes, in general, the now blank EC could have something to do with why all the stock BIOS test I sent you failed, but again nothing we can do… you erased this chips contents.
I did not check above 4MB contents, do not need to, 4MB is not EC that is ME/FD usually for Dell. EC FW is always on a 128KB-1MB chip only usually. OK, I checked, this is FID (Flash ID) and ME FW, along with some other details info, nothing to do with EC FW as I already knew.
Please let me know about above BIOS so I can move forward with editing, thanks

Look at my preveous post i edit it. There was no change in fans or lights i tested all things before any programming and tried to figure out in windows with that aw software to control it.

If i will connect 15’’ lcd it will change the model name to aw 15r4 on first bios page and it will also change gpu to MaxQ in device menager in windows.

I think the missing 4mb firmware for UE2 chip is important in this modding. I know that it can be extracted from dells bios update but i don’t know how to do that i can only write hdr file.
Also i found a thread about similar situation of an engeneering sample here Reviving dead Dell Workstations with bricked BIOS

And all was done by flashing two chips. Like i mentioned before EC controller’s in some casese are soldered to the motherboards with a basic firmware flashed in factory to make the board working. Then ther are couple ways to update it’s firmware:
1. is to use programmer to connect it to keyboard port on motherboard and flash it with the dump. I know russian developer Vertyanow made special programmer for such EC controllers to flash them when they are relpaced
2. Is to flash IC chip by programmer like in this case it’s UE2 chip.

If you can please extract such firmware fro dell bios update and i will flash it and than we will see any changes.

Yes, I saw that, you look at mine, I edited it For your new comments, yes, most Dell have two BIOS chips, yours does not, so nothing you read applies.
EC FW can be directly flashed in with programmer, you do not have ES EC FW, you erased it, thus nothing we can do except forget about that, as mentioned above.
I do not have Dell stock EXE for this system, so I cannot extract the EC FW from it, if it’s even in there. Once you link me to the stock EXE From Dell and I do get you that file, you need to go back and test all four of those BIOS I sent you initially with that EC FW already programmed in.
Then if nothing works still, move along and don’t think about this chip again since you do not have it’s original contents the only way you can fix it is to purchase another EXACT same ES system from that same seller.

Additionally, to help resolve some of your confusion about Dell’s two BIOS system and EC FW/chip. There would be three chips on these boards, two holding the BIOS contents (8MB + 4MB or 8MB + 8MB etc) and then a third much smaller chip, 128KB-1MB, this would be EC FW chip

Please test BIOS I posted above so I can continue here tonight, otherwise I’m going to have to move onto next thread for now.