AMI BIOS issue

Motherboard POST stops at; ‘D5 No Space for Legacy Option ROM’, then repeats cycle.

CPU bad?…7751#post687751


I saw that as well, while searching through many pages on the internet.

However, it does not explain, at least in terms I understand, why the motherboard reaches that POST code, and then starts cycling again, never completing POST, or allowing entry into UEFI.

My question is; what component, e.g. CPU, or combination of components, would likely cause that behavior.

The motherboard is a RMA replacement. It is exhibiting the exact same behavior as the one I sent in for RMA.

System specs below ↓.

Uve got to do trials from basic hw to all ur unknown to us, list of connected HW devices.
Assuming latest bios update and defaults loaded, CPU and 1 stick RAM, then add GPU, then add 1 SSD/HDD and so on… GPU here is the HW to watch as it can be offended/corrupted.
Also since this is an RMA and 2nd time u should really inquire for an explanation on this subject to EVGA.

What I did for troubleshooting:

Installed CPU, GPU, RAM, (and CPU cooling of course), CPU 4+4 and 24 pin power cables, GPU 6+2 power cables.

Power on, POST cycles to D5, no further, starts over, repeats indefinitely.

Removed GPU, same as above.

Removed RAM, POST stops on 53, which it should.

Removed CPU, POST code 00.

Tried all three BIOS switch positions, same result.

Re-flashed BIOS using on-board USB header, all three BIOS switch positions, same result.

Awaiting reply from eVGA, but not hopeful as the only troubleshooting they initially offered was to inspect CPU socket, and when socket pins were OK, to RMA motherboard.

I am asking for advice here because I know there are members who are familiar with the AMI BIOS, and was hoping that someone could provide insight as to what the D5 error code means with regard to possible hardware failure and probable component(s) that is/are responsible.…0_20140410.pdf

Bottom of the page:

Not sure if this helps.
I am seeing the following POST code sequence repeating: 7F, 30, 44, 00, 4C, 3E, 32, 35, 45, 37, 39, D5.

faulty ram or incorrectly configured? this kind of error also appears when the gpu doesn’t communicate with the bios correctly showing the post screens.

Hey buddy… dont try to get an answer where there isnt one, specifically on a remote chat in a forum and not even a valid word from EVGA. I cannot tell u straight away that its a faulty CPU/RAM/etc…
The D5 is an AMI code referenced as No Space for Legacy Option ROM, (Temporary memory allocation for it) where r these Option ROMS? In the motherboard bios and in hw devices.
Example in bios, iGPU, iRST, LAN, in hw devices a dedicated GPU, controller card etc…
This code is during the PEI Phase (Pre-EFI Initialization) generally its CPU, chipset and board initialization HW before loading/pre boot the DXE phase (Device bus, driver).
Im pointing here a motherboard malfunction and i do suggest if possible testing CPU, RAM and GPU in another system, this is only my opinion to the subject but u can wait for another user.

Ull have a better ideia of wot i presented here:…3_boot_sequence

I understand, just looking for advice on where to start. I appreciate you taking time to reply.

So, if only RAM and CPU are installed, would you say it narrows it down to those or the motherboard?
I have three sets of DDR4 that all were previously working in the first motherboard, but now the new motherboard POST error is the same with all three kits.
I will test the GPU in one of my other rigs. And I will try another, known working, GPU in this motherboard.

The motherboard being fresh from RMA, I would like to believe eVGA tested it before sending it.
I will have to buy/try another CPU.
Still waiting on eVGA to respond.

Thanks again.

Lost_N_BIOS where is he now ?

Living his own life.


eVGA replied.

In their opinion, it is either the CPU or PSU.

Tested PSU with my cheap ULTRA ULT31553. Showed correct voltages on 24 pin AND 4+4 CPU connectors, I realize that does not mean proper current in being supplied.

I am guessing CPU died.

Regarding the error codes, it would be great if someone who knows about such things could make a guide that detailed what hardware issues presented which error code(s).

i found this error being thrown up due to bad memory timings/incompatible memory(bug), memory controller hardware fault, cpu not seated correctly, bios battery fault.

you could also have a second bad board.

have you tried downgrading the bios to older releases?

It was the CPU, IMC burnt out would be my guess.

Got a new 9900K, back up and running.