Aorus b550 master f13h bios, possible to increase PBO offset higher than +200 ?

mobo: Aorus master b550
cpu: ryzen 5800x
latest firmware binary:

hi, im trying to figure out if its possible to increase the precision boost overclocking limits. starting on F13* bios they now have a +200 overclock limit, going back to F12 just for this ability to clock higher comes at the cost of usb and lan instability so im hoping this is something that could be done.


i looked through the bios with amibcp5 but nothing about pbo was in there, uefitool shows it and i could probably use something like RUefi to set the value i want but i just want to see if there is a better way

edit: is there a tool for AMI bios similar to h20uve for insyde bios so vars could be used or no?

I have some questions to ask you.

1. You mention "PBO offset "on post ,do you mean option “Max CPU Boost Clock Override”(or Max GPU Boost Clock Override)?
I’ve analyzed bios version with F12 and 13h , i found on f12 the adjustment region of Max CPU Boost Clock Override is from 0MHz ,25MHz , 50MHz… to 500MHz. But on version 13h, i only can see its adjustment region from 0,25,50… to 200MHz.

2. Does this option is exist under Settings > AMD Overclocking ? Could you capture a screenshots ?

3. It seems that there is an hardware bios flashback feature on this motherboard ,it names Q-flash plus ,do you ever through it to re-flash the modified bios? If not ,could you make a test ? Maybe you need this feature to re-flash modified bios.
You could edit official bios anything via amibcp then save ,then use this file to test Q-flash plus.


1. the cpu, on F12 the max overclock for pbo is +500, every bios version after that is +200 max.

2. AMD overclocking > precision boost override > max cpu boost clock override.

3. i tried swapping the pe32 from the f12 bios into the f13h bios but q-flash just refuses it, i could try flashing to the chip itself but i get the feeling i should probably ask someone more familiar with these bios before i go and try it


1. I mentioned Q-flash plus is mean like below.

2. Another method to re-flash mod is use a modified Efiflash ,you should can find out in this forum. The Efiflash.exe for your motherboard is version 0.87.

3. I have two plan to modify this bios.
a) Directly edit the amd overclocking module on version f13h.
b) Applying the amd overclocking configuration from version f12 to version f13h.

Do you wanna take a attempt?

1. i didnt try the q-flash button but im open to trying.

2. i can try this as well if needed.

a. if editing the the existing overclocking module is an option i think that would be best, with amd and all the agesa updates i cant even keep track of what was changed.
b. this is what i attempted to do myself by extracting the pe32 from the AodSetupDxe module from the F12 bios and insert/replace into the F13h bios but i was just guessing this is what needed to be done, on this i know very little.

thanks for your replies and im open to trying whatever to see if i can raise the +200 limit to include 225, 250, 275, and 300 if possible

EDIT: i tried using the q-flash button from usb but i only get the initial slow blinking for 1-2 seconds, its not allowing it. i’ll look into efiflash

EDIT2: efiflash.exe from freedos will work if i pass the /X flag, im currently on the modified f13h bios i made yesterday but unfortunately i still have the +200 limit so i definitely didnt know what i was doing

Here is mods i made.

awesome, thanks. i’ll give them a try right now and let you know how it goes

the first mod flashed and booted fine, i see the added +250 and +300 but selecting either one seems to result in a +0 overclock (being ignored).

i’ll try the second one now

EDIT: mod 2 shows all f12 overclocks up to +500 but selecting anything over +200 is ignored just like with mod 1.

could this be a limit set elsewhere in the bios?


Try this one again .If it still unavailable ,i’m no idea.
Maybe the same as you said , somewhere in bios is limit it only to 200mhz at max.

thanks for trying, that one also boots but anything over +200 just seems to be ignored. if you happen to think of anything that might be the cause of it being blocked i’ll be happy to try it out.

EDIT: from what i’m told this is limited by agesa, could that even be changed?

Sorry , i don’t know how to edit agesa module yet.