ASMedia 106x on-board ISSUE

Hello. sorry for my bad english.

i cant get rid of this issue, my ASMEDIA 1061 onboard SATAIII is not working at all. i tried a lot of drivers, swap cables, hdd, clean windows install, but this isnt working. BIOS settings are OK.
My mobo is an ASRock x79 extreme4-m paired with an i7 3820, and the sata3 port is on board. i tried to modify the mobo bios but i think is not gonna work . Hope @Fernando can help me with this stuff, maybe with the firmware update for the controller, or something similar, i dont know . Thnks you at all

@DonGeg97 :
Welcome to the Win-RAID Forum!
I don’t think, that it is a storage driver issue.
Please give me some additional information:
1. Which OS are you running?
2. Which BIOS modifications have you done? Did the ASMedia SATA ports work with the latest original BIOS?
3. Are you sure, that the on-board ASMedia SATA Controller is enabled within the BIOS and set to “AHCI”?
4. Have you checked, whether the connected SATA disk drives themselves are fine (work, when connected to an Intel SATA port)?
Dieter (alias Fernando)

Im answering in order:
1: I am running win 10 pro 20H2, 64 bit
2: Bios modification i did is only open MMTool with the bios firmware, and replaced 1B21-0611 and 1b21-0612 with the files attached by you in the main thread. but without results. lol ;
No, it wont work since i bought the motherboard (used). I always thought it was like a CD-rom port or something similar, now i bought a third hard drive for storage (unlocked via software 3+TB) and figured out i can run only in sata2. then i noticed that i have a third port (asmedia) and all starts from this .
3) I tried every solution, AHCI, IDE, i only have 2 options in bios : asmedia IDE or AHCI; asmedia Boot drive yes, no. i tried all.
4) Sata disk Work correctly in sata 2, is correctly recognized by windows.
Hope this infos are enough.

I will apprecciate it so much if u can help me.

@DonGeg97 :
Thanks for the quick answers.
According to my own experiences with on-board ASMedia SATA AHCI Controllers here are my advices:

  1. Use the Win10 in-box MS AHCI driver, which is most likely the best choice, when users want/have to use one of the ASMedia SATA ports in AHCI mode. The on-board Intel SATA AHCI Controllers and their Intel drivers are much better.
  2. (Re-)Flash the latest BIOS, which is offered by the maker of your mainboard. Usually the manufacturer tests different ASM 106X Option ROM versions and put the best working one into the BIOS. In most cases an update of the ASM 106X Option ROM makes no sense, the results may even become worse.

Ok, i will do it ASAP. I will thank you and appreciate a lot your work on this stuff. I would ask you a simply question: Is it possible that it is simply broken? Like internal connectors or stuff like that? I bought the mobo used, so maybe it can be like that. Thanks

Yes, it is possible, but my advices are valid nontheless.

Yes Of course! I really thank you you’re Goat! It didnt work, but its not a problem, i resign myself. Thanks

If your motherboard has fast boot disable it and retry.

it’s already disable but i will retry, thanks for the advice

so far i think power comes through the port because i plugged out the hdd and the pc went bsod error. i really dont know how to do it and using sata2 for storage is so bad.