ASMedia drivers for ASM1061+ASM1093 PCI Express cards


I have an ASMedia SATA card that is working fine, but I’m concerned about its
old driver becoming obsolete and there not being a more current driver to replace it.
I haven’t seen any discussion on this. So I’m bring it up here.

In my Windows 10 64 bit update 1909 desktop PC (HP Pavilion p6310y) , I can not use any ASM1061
driver more current than for my PCI Express X1 SATA ASM1061+ASM1093 card.
This card is generally referred to as a SA3004. The PCB is labeled SU-SA3004-V2, SU-SA3004-V2.1,
or in some cases there is no model number on the card. The cards all appear to come from China
and there are many sellers (Amazon, Ebay, …). The ASM1061 firmware version is 4.20.

Trying to use a more current driver found on the internet causes BSOD INTERNAL_POWER_ERROR, with
argument 1 = 608. 608 saying driver has attempted to transition a component to idle without a
preceding active request. ASMedia technical support was contacted, but did not respond.

The BSOD happens using driver versions,,,, and “IF”

an optical drive is plugged into a port,


a plugged-in SATA cable goes to a bracket in the PC back and from there, an ESATA
cable connects to a powered-on externally enclosed hard drive.

The problem does not occur using the provided driver.
Also, the problem does not occur for an ASM1061 card that does not have an
ASM1093 (port multiplier).

Other BSOD diagnostic information referring to the ASMedia driver:

FAILURE_BUCKET_ID: 0xa0_608_asstahci64_nt!PopFxBugCheck
BUCKET_ID: 0xa0_608_asstahci64_nt!PopFxBugCheck
PRIMARY_PROBLEM_CLASS: 0xa0_608_asstahci64_nt!PopFxBugCheck
FAILURE_ID_HASH_STRING: km:0xa0_608_asstahci64_nt!popfxbugcheck
FAILURE_ID_HASH: {d59d2fa8-f4bc-cd7e-c78d-5b97fd68ae6a}

Ironically, the driver (the one sellers are currently providing) has a pre-Windows 10 date of November 23, 2014.

I would like to know if there is a way to upgrade the driver without having to remove the
problem port connections.

Thank you for any comments you might have on this.

@rnthorburn :
Welcome to the Win-RAID Forum!
The latest ASMedia AHCI drivers are the v3.2.3.0 ones and can be found >here<.
You gave a lot of information, but missed to post the HardwareIDs of the ASMedia SATA AHCI Controller. That is the reason why I don’t 100% know, whether these drivers will support the SATA AHCI Controller of your add-on card.
Dieter (alias Fernando)

Thank you for responding to my question.
In addition to the hardware id, here’s other information I need to mention …

I have 2 ASMedia chip set cards:

card 1 - PCI-E X1 ASM1061 (firmware .951) chip card with 2 SATA ports and
hardware id: PCI\VEN_1B21&DEV_0612&SUBSYS_10601B21&REV_02

card 2 - PCI-E X1 ASM1061 (firmware 4.20) and ASM1093 chip card with 4 SATA ports and
and same hardware id: PCI\VEN_1B21&DEV_0612&SUBSYS_10601B21&REV_02

Further testing results:

With just card 1 plugged-in, can use any driver.

With just card 2 plugged-in, can use any driver.

With BOTH cards plugged-in, can use driver, BUT none of the previously
mentioned more current drivers work.

Tried using Microsoft driver for card 1, but still could not use more current
ASMedia driver for card 2 (just tried

The driver failure is a BSOD when trying to using optical or ESATA hard drive.

So based on my testing, I’m stuck at the pre-Windows 10 driver unless I eliminate card 1
or unless ASMedia creates a Windows 10 driver that reestablishes the functionality found
in the driver for multiple ASMedia cards where there’s a port multiplier.

Maybe, the driver will continue to work for as long as I need the cards.

I would still be interested in any other suggestions you think would be worth a try.

Thank you.

@rnthorburn :
Thanks for having posted the results you got after having inserted
a) just 1 of your 2 PCIe SATA add-on cards and
b) both of them.
This verifies, that it is not a good idea to insert more than 1 add-on card, which contans an ASMedia SATA Controller.
I suspect, that this issue hasn’t been detected by ASMedia, because their staff hadn’t tested what happens after the insertion of 2 SATA add-on PCIe cards.

Just for documentation here in the forum … I also updated "both" ASM1061 chips to the 4.27 firmware.
That did not resolve the driver BSOD problem.

@rnthorburn , there is a new beta (non-WHQL) driver v3.3.2.0000, dated Oct 7, 2019:…ileinfo&id=4258

Might worth a try.

I am surprised to find that the driver almost works correctly.
On my Windows 10 Home PC, it almost works as well as the
pre-Windows 10 driver,

Using the driver, there is no longer the BSOD, but at boot time
the driver is unable estabish access to the 2nd and 3rd ports of the ASM1093.
This is what happens when using the Microsoft driver. For me, the main
reason for using an ASMedia driver is to have access to the additional
port-multiplier ports.

For drives connected to the 2nd and 3rd port-multiplier ports, I am
able to establish access to them after boot-up by turning their
power off and then back on. So it appears that whatever negotiation
occurs when powering them on is what is needed by the ASMedia driver
to establish access. Conversely, at boot time the devices are already
powered-on and the interaction needed by the ASMedia driver isn’t there.

I have switched to using the driver by insuring any device I
might boot from is not on the 2nd or 3nd port-multiplier ports.
This may be a somewhat less optimal division of devices across PCI
express slots, but I prefer having the latest Windows 10 driver.

Thank you for letting me know about the driver.


Glad to help.

Unfortunately, manufacturers don’t take in consideration all possible scenarios during driver development.
Having 2 or more cards with same chipset is something they don’t even test, sadly.

What about using an earlier version of the firmware, provided that it is possible to downgrade it? Be careful with this.

I just wanted to update that now my ASM1061 card and ASM1061+ASM1093 card seem to be working perfectly together.
For another reason, I had done a "full" redo of the Windows 10 1909 update and then the December updates occurred.
It was then that I noticed the change for the better.

So if someone has a problem with a like card combination, firmware 4.27 and driver may resolve it.