ASMedia USB ports stopped working on Windows 10


The USB 3.1 ports on my motherboard (Gigabyte GA-Z170-HD3P) stopped working 1-2 months ago and I have been tearing my hair out trying to get them to work again.

For some reason, the ASMedia USB hub (circled in red) shows up as "Generic SuperSpeed USB Hub). There is power going through the ports, but nothing works (i.e. i can charge up a phone, or power up a device, but it will not talk to the PC). I have tried reinstalling drivers from ASMedia, from Gigabyte and 3rd party drivers, but nothing seems to work.

If I’m not mistaken, it stopped working after a windows update, but I’m not entirely sure.

Any guidance at all would be really helpful!

Screenshot 2021-02-03 154112.png

Screenshot 2021-02-03 154112.png

you don’t need any generic/third party drivers.for that you can rely on Win10’s inbox if there are any third party drivers like that uninstall them first.

assuming, if your device (whatever you are connecting) is not having an identity crisis,or if ASM1142 chip is not failing or if the drive (if an external) just not happen to have a corrupted partititon etc,
connect your device,right click on that usb hub and remove the driver,tick the delete software for this device option aswell
now disconnect your device and restart

go in this order,
check for Windows updates
latest bios version is F22g (skip if already applied)
Chipset INF Utility v10.1.18383.8213 (proper identification)
Intel Management Engine Driver v2101.15.0.2080 (should have it anyway)
Asmedia ASM-114x USB 3.1 Firmware v150707_30_02_1B (ASM1142 firmware)
Asmedia ASM-1x4x/2x4x/3x4x/107x Drivers v1.16.61.1 (latest driver)

now plug it back in

Thanks onuracengiz!

I had done most of those steps before but tried again. I get stuck at installing the ASMedia firmware. The error I get is "The target xHCI does not exist!! Please check your xHCI ID or version then try again!!!"

If it helps, when I remove the usb hub in device manager, Windows always brings it back as “Generic SuperSpeed USB Hub”. I’ve tried updating the driver with various ASMedia drivers as well, but none of that has worked.

Its an ASM integrated in motherboard, dont mess too much with it (FW) or may get a bricked board, its different if it was FW flash on a external card.
Simple test is a fresh OS install in another drive, as it seems the ports r powered.
Ull know if its a broken OS or an HW failure on ports


Based on your screenshot It looks to me like you have an Intel xhci controller - where did you get the impression you have an ASMedia one?

Thanks @infuscomus

My motherboard is a GA-Z170-HD3P which comes with a separate ASMedia USB 3.1 controller. The USB 3.0/2.0 ports work fine and those are connected to the Intel controller, but the two ports managed by the USB3.1 controller have not worked for the last month or so.

Thanks @MeatWar
Have tried the fresh OS install and it hasn’t solved the problem unfortunately. Perhaps it is a HW failure. Just trying to see if there’s anything else I can do to confirm it, rule it out or fix it


do you know the hwid of your ASMedia controller?

@infuscomus it shows up as


That ID is a Texas Instruments hub - that seems to be working based on your pic

@infuscomus - you’re right! I’ve been barking up the wrong tree. So it looks like the ASMedia controller is not working at all. I checked the Hardware IDs of all the usb hubs and controllers and none of them have the ASMedia VID.

So either the controller is dead, or the BIOS isn’t setting it up right. There is power to the two physical ports that are meant to be managed by the ASMedia controller, but I I guess that’s just coming off the PCI rail?


If you don’t see an ASMedia VID anywhere then it’s likely that USB hub is dead

bit strange that it still has power though.

Thanks @infuscomus. Very strange indeed. I guess it’s time to give up and move on. Thanks again for all your help!

you’re welcome!

“ or if ASM1142 chip is not failing”
So it was the first part
“ The target xHCI does not exist”
Was just another clue