Asrock P55 Deluxe Bios Chip Reflash

Recently ive tried to update the bios on my Asrock P55 Deluxe, and somehow it got corrupted.

i got one of those eeprom/bios chip reprogrammers, but i dont have the bin file for it.

also erased the chip when following a guide :confused:

any suggestions?

@Dafman31 - Please upload your original dumped BIOS you took from the chip, BEFORE you erased it. If you did not make a backup before you erased it, then you lost your original UUID, serial and new UUID we can get/create from stickers on the board, and LAN MAC ID can be fixed from sticker too.
If you did not make a backup before you erased, please give me a link to this guide, so I can tell that person the guide needs updated since it left out the “backup chip first before you erase” step

For now, to get you booting, what is your BIOS chip ID, so I can tell you if you need to use a specific software version or other than excact BIOS ID
Here is .bin to write to chip, but all write “may” fail until you give me chip ID, if you do have a chip that needs certain version or certain ID used etc.
Please note, this is BIOS for P55 Deluxe only as you have written, I see there is also Deluxe3 (make sure you only have Deluxe before you use this)
asrock.pc.cdn.bitgravity.com/BIOS/1156/P55%20Deluxe(2.10)ROM.zip

Rename to P55DX_2.bin if the software isn’t letting you open as named originally with the .10 extension.

Erase, blank check, then open file and write/verify

Where do i find this Chip ID?

i made sure to check and on the chip was a sticker that said P55 DELUXE p2.00-15A

i also tried to flash like you said but no luck on booting

It’s printed on the chip itself, look with magnifying glass and flashlight if needed. You will need to remove that sticker, that just tells you the model and original BIOS version.

After write of the BIOS did you verify? If yes, and it verfied OK, dump the BIOS from chip and compare in hex editor vs the BIOS you wrote. If they do not match then you have a failed verify / failed write.
What program and version are you using now?

the chip says 25Q168vaig 0942

i verified the bios , and they matched perfectly

im using CH341A ver 1.18


edit: 25Q168vaig

Verified the BIOS does not mean it’s verified always, that’s why I said then to dump and compare in hex. Sometimes if software version is not correct one, or chip ID not correct for it to properly work with that chip it will verify it’s own failed write.

Show me image of the chip, that isn’t a correct ID above. 25Q1 is correct, but 68 is not. It would be 64 or 128, then two more letters after that is all that is important.
Example name >> W25Q128BV or W25Q64FV etc. W will not be there, it’s just name of brand and commonly added so it’s written in discussion this way.

This is Winbond W25Q1xxxx something, still need rest of chip before I can fully advise.

Also, for now, use 1.30 or 1.34 (1.18 is old) - http://s000.tinyupload.com/index.php?fil…695330485827902

W25Q128BV this one has to be it
i compared inside of flexhex if that helps

W25Q16BVAIG could also be possible