ASRock X79 Extreme 6 successfully bricked

Hello, I used to have a working ASRock MB. I started researching to have it optimized since I experienced performance issues. I ended up here reading about all this stuff like MEI update, SATA updates and stuff. I tried many of the tools from here but most of them return with an error message in the command window. I think the only one that came up with some useful answer was some analyzer tool telling me the MEI version on my system. Dont even remember since I tried so many of them.
To make a long story short: another user obviously managed it to successfully upgrade his system. We messaged a bit back and forth. Since he was able to update his system I was kinda motivated to give it another try. I again tried the MEI update but the same result - error message. The tool stopped working, at least thats my impression since there was only a red error message in the DOS command window. I deleted all this useless junk and shut the machine down. Later a buddy gave me a call whether I am up to game a bit. Turned power back on and the only thing I see is a lil white dot in the middle of the screen.
Either a working machine just broke due to some failure that I dont know or some of that intel update crap did something in the background.

Question: Any chance to get it back to life or do I have about 300 Euro of electronic junk in my tower?

Updating Intel Management Engine Firmware on X79 boards, especially ASRock, is a very bad idea.
I have an ASRock X79 Extreme4 and the MEI firmware is, about 1.9 MB big.
And here comes the surprise: the firmware size should be 1.5 MB. They use some special customized firmware.
Standard firmware sizes are 1.5 MB and 5 MB.

You should be able to recover using the ASRock Crashless BIOS feature.
From what I read, you only need an USB flash drive connected to an USB 2.0 port on the ATX panel.
It must be formatted as a FAT drive and only contain the BIOS file.

ASRock BIOS files contain the Intel MEI part, so in theory it should work as long as the BIOS version you want to
flash is newer than the one that is stored in your mainboard.

@ Hr_KaLeu:
Welcome at Win-RAID Forum!

Since your problem is obviously Intel Management Engine related and has nothing to do with the modification of BIOS modules, I have moved your thread into the Windows ME section of the Forum.
I am sure, that our Intel ME expert plutomaniac or someone else will give you some tips about how to get your system working again.
In any case it will be very helpful, if you tell us, what exactly you have done before your system became unaccessable.

Dieter (alias Fernando)

First things first, ASRock does not use any “custom” ME firmware. Only Apple does that for their mobile systems which is irrelevant in this case. For 1.5MB firmware, it’s actual size inside the SPI image is 2MB and that’s normal. After the code ends, it’s filled with padding up until 2MB.

You haven’t mentioned anything specific about your case. What motherboard you have? What ME firmware version did you download? What ME firmware SKU did you download? What version of ME tools did you use? What were the errors you received etc… A lot more information is needed to provide actual support.

ASRock has a MERecovery procedure in case it’s altered which is very aggressive in order to protect the end-user as it restores to default firmware after a reboot in case of an update. But this also means that even if you brick the ME firmware it should try to restore it and recover the system. Without extra information like the ones mentioned above, I can’t know whether you bricked it or not.

Yap, first things first. The MBs name can be found in the header. It says ASRock X79 Extreme 6. I tried to update the MEI from what I have to Intel ME 8 Consumer 1.5MB Firmware v8.1.52.1496. The version I had is 8.1.40 something. I downloaded the newer version from here and as well tried what I got from another guy. The command FWUpdLcl64.exe ME-firmware.BIN in the DOS prompt results to Error 8716: Invalid usage.
fptw64.exe -BIOS und -P filename.bin is resulting to Error 200: Invalid parameter value specified by user. Use -? option to see help. filename.bin is obviously not what I typed in. In this case it was the name of the modded BIOS file I got from another user who has the same MB.
I should mention that I did run the command prompt as an administrator.
FWUpdLcl64.exe and fptw64.exe is stuff that I downloaded from this forum here.
The only tool that seemed to work was the ME Analyzer tool which gave me the same MEI version as I had in my BIOS.
Not sure if this issue can be recovered since I only have a black screen (beside the lil white dot in the middle) and keyboard is dead or locked or whatever to make it into the BIOS. There is not even a summary screen anymore.
Like I said before, I am not sure what really happened. Its hard to believe that my attempt to update MEI or the BIOS broke the board since those magic tools all came back with errors but who knows. Last thing I did was messing around with those before I kinda frustrated turned the machine off.
I already found an online shop that sells BIOS chips with recent BIOS on it. I think I will go down this road first since its only about 10 Euros for the chip. If this will do the trick then I will leave it like that -> lesson learned. Its simply to much hassle just for the sake of having whatever lil performance boost (if there is any)

Your latest BIOS has ME and indeed the latest would be the 1.5MB firmware.



a) You wouldn’t really be able to flash it effectively because ASRock MERecovery would restore it back to after first reboot. User lordkag can bypass this restriction my modding the BIOS slightly.

b) The commands you gave to the tools are wrong, of course they won’t work and show errors. The errors themselves point to “Invalid usage”/“Invalid Parameters”/Wrong commands etc.

As said at the ME thread, the correct FWUpdLcl command is FWUpdLcl -f ME.bin and not FWUpdLcl ME.bin. Similarly for FPTw. If you don’t know the commands, type -? and it will help you out by showing a list and description of them.

FWUpdLcl is a “safe” tool meaning that it only updates the ME firmware after verifying via a lot of checks that everything is alright (ME is responsive, another flash is not already in progress, firmware is newer or older but of the same SVN/VCN, the image is a proper one as far as version, sku, integrity is concerned etc…). So in theory it shouldn’t let you perform something harmful to your system.

FPTw on the other hand is dangerous. Simply because it’s a general-purpose flasher and not ME-specific. If you tell it to do something it won’t warn you or hesitate no matter what you are doing. You could flash a jpeg image on top of your current BIOS and it would go ahead. It’s extremely useful but users who use it must be careful.

I am certain that you bricked your BIOS by using FPTw the wrong way. Some wrong command you used told it to flash your current BIOS with another image. Maybe you overwrote your BIOS with the ME firmware or with any other file that was next to FPTw and was inputted as a command wrongfully.

Regarding recovery procedures, your Flash Descriptor is locked and so the cpu does not have access to the ME firmware but only to BIOS. So, even you wrongfully flashed the SPI image with a wrong image the ME region should have been left untouched. This is good-ish news as a corrupted ME with a locked Flash Descriptor means buying a new SPI chip or using a programmer to flash it again.

My guess is that FPTw flashed over the BIOS region and corrupted it but the ME could not be touched. That hypothesis bundled with the fact that your motherboard seems to have a BIOS recovery utility could recover the system completely. Basically, find out how exactly the Crashless BIOS feature that your motherboard has works and do it. In theory it should be as simple as putting the latest BIOS at the root of a FAT32 usb plugged in at a USB 2.0 port and boot the system. It should start recovering the BIOS region and thus restoring the system to a working condition. Read your motherboard’s manual and online to learn how Crashless BIOS works exactly.

The recovery has already been patched here for the same board, but I’m not sure the user will succeed in updating. From what I see, is the classical case of running the tools with every command but the right one, breaking the system and then blaming the tools. I always wonder when I see such cases if the user is trolling or just had a really bad day.

My take is that he flashed a BIOS with a capsule, given he said he used “… -BIOS …”. I remember there was a problem when using FPT with capsuled files, not sure if this is valid for all FPT versions.

Yes, that’s also a possibility and a great way to brick the BIOS. That’s why CodeRush’s Flash Toolkit (FTK) exists but I don’t remember whether ASRock encapsulates their SPI images. He said that he wanted to update the ME so that never really crossed my mind. But yes, it’s possible. Either way, if the ME is not bricked, there is a high chance that this Crashless BIOS feature that ASRock impletemted can recover the BIOS to normal again.

Any news on this?

the board works with stock bios.

Does that mean, that your problem has been solved?
If yes, how did you succeed?

I asked a friend, who has a programming device, for help, pulled BIOS chip, successfully loaded the stock BIOS, put chip back in, turned computer on, enjoyed a feeling of happiness that is working. I will not touch this again, at least not this mainboard.