ASUS AM1I-A / Athlon 5350 Kabini / Samsung 850 / Win XP AHCI setup

hi, thanks for providing such a wealth of information, i’ve been reading thru the docs here for several hours now.

i’ve got windows xp running, but in ide mode. if i slipstream the driver from the asus site, or the amd v3.3.1540.33 version linked in the ‘general: ahci and raid drivers’ section of this site i get a bluescreen just after the ‘starting windows’ message.

i also get the bluescreen when installing the slipstreamed version while the mobo is configured for ide. if i use the original disk the install proceeds fine.

the asus site specifies win xp support for the board, but amd doesn’t list xp under supported os’s for the chip.

roughly speaking, how much of a performance hit will i take by keeping everything on ide? i’m not running any games, the system is dedicated to running ableton (music production software).

things are running pretty smoothly as is, but before i load up the system with all my stuff i did want to try to get it running with ahci instead.

on one of the intel raid threads, there were instructions on switching to ahci after doing the install on ide. these aren’t working for me, i get the error that the driver doesn’t support my device.

thanks!

@ kimyo:
Welcome at Win-RAID Forum!

Then you may have done something wrong.
Possible reasons:
1. You didn’t use a “clean” (untouched) XP image as source before you integrated the driver.
2. You integrated the wrong or more than 1 textmode driver.
3. You haven’t switched the SATA mode within the BIOS to “AHCI” before starting the XP installation.
4. Maybe the BSOD occured due to a wrong ACPI setting (Solution: Hit F5 while prompted to hit F6 at the beginning of the XP installation.).

This is the default message, when you try to install an AHCI or RAID driver while running the OS in IDE mode.
You have to force the installation of the "wrong" driver by using the "Have Disk" button, to choose to reboot, to enter the BIOS while rebooting and to switch the AMD SATA Controller to "AHCI".

Good luck!
Dieter (alias Fernando)

i tried again tonight, using an original win xp home sp2 disk with hologram, and just the one ahci/raid driver from the asus site, still getting the bluescreen.

sata mode is in ahci. i also tried the f5 option and selected the one choice given (something like c-step). sp3 was slipstreamed.


this is exactly what i’ve done, i click ‘have disk’ and the system says it doesn’t match my hardware. i am not provided with any way to override this.

my main question is: what kind of performance hit am i taking by running in ide mode?

is there an ahci driver you recommend over the one provided by asus? the board doesn’t support raid, only ahci.

Zitat von kimyo im Beitrag #3

this is exactly what i’ve done, i click ‘have disk’ and the system says it doesn’t match my hardware.



This message is correct, because the hardware detection doesn’t find any AHCI Controller at that time, but you have to force the “wrong” driver installation nevertheless.
The driver will be suitable not before the next reboot after having switched the AMD SATA Controller to AHCI mode.

what is the procedure to force the install? can i work from extracted files or do i need a floppy? (at the moment i have no working floppy drive, the one usb 1.44" i have is acting weird).

i click ‘have disk’, point it to the folder containing the inf file, it says ‘no match’ (i don’t have the exact verbiage handy) and offers no option but to click ‘have disk’ again.

You cannot force the driver installation at the beginning of the XP Setup. Either the via F6 offered driver matches or not.
I was talking about the switch from IDE to AHCI mode after having successfully installed the OS in IDE mode.

i understand. i’m also talking about switching to ahci after doing the install on ide.

i go to the controller in the device manager, click on the driver tab, try to install the ahci driver, get a ‘no match’ error.

i understand about switching to ahci after installing the driver, but that’s not the issue here. ‘have disk’ doesn’t work in this situation.

You have to expand the “IDE ATA/ATAPI Controllers” section of the Device Manager, right click onto the listed IDE Controller, where your system drive is connected, and choose the options “Update Driver Software” > “Browse my Computer…” > “Let me pick…” > “Have Disk”. Then you should navigate to the folder with the AMD AHCI driver for XP, click onto the correct INF file and force the installation - despite all warnings you get.
Don’t forget to set the AMD SATA Controller to “AHCI” before you do a reboot.

this is exactly the procedure i’ve followed. after i click ‘have disk’, then point to the inf file, i am returned to the list of available devices (which is blank). my only options are to click ‘have disk’ or ‘cancel’.

there are no warnings.

@ kimyo:

Please post the HardwareIDs of the SATA Controller your system drive is using (right click onto it > "Properties" > "Details" > "Property" > "HardwareIDs").

here’s what i’ve got:

primary ide channel 4&2D77B6DB&0&0
secondary ide channel 4&2D77B6DB&0&1
standard dual channel pci ide controller: pci/ven_1022&DEV_7800&SUBSYS_86231043&REV_40\3&1158a3659&0&88

thanks for all of your efforts.

i did just somehow get a slightly different result: re-downloaded the driver, restarted n-lite directly from a hologram disk, included sp3 and instead of blue-screening immediately after copying files, the system rebooted and got thru the next phase. unfortunately, it bluescreened on the next reboot. still the 0x7 code.

@ kimyo:

Thanks for the HardwareIDs, which verify, that the system drive is actually connected to an AMD IDE Controller.

Does that mean, that your system drive running in AHCI mode has been detected by the XP Setup?

To make sure, that the currently used AMD AHCI driver really supports your AMD AHCI compatible RAID Controller, I need the HardwareIDs of the on-board AHCI Controller.
If you should be able to boot into any other Windows Operating System in AHCI mode, do it and look for the HardwareIDs of the listed AHCI Controller, which is either within the "Storage Controllers" or "IDE ATA/ATAPI Controllers" section of the Device Manager.



prior to that attempt, the system would bluescreen after the cd-based ‘loading files’ portion of the install. this time, files were copied to the drive (with the mobo configured for ahci). however, it does bluescreen after the first reboot, when trying to continue the install from the hd.


here’s the pci info:
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40) (prog-if 01 [AHCI 1.0])
Subsystem: ASUSTeK Computer Inc. Device 8623
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 78
I/O ports at f140 [size=8]
I/O ports at f130 [size=4]
I/O ports at f120 [size=8]
I/O ports at f110 [size=4]
I/O ports at f100 [size=16]
Memory at feb6e000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ahci

This verifies, that the inserted AMD textmode driver was able to detect the target drive, which was running in AHCI compatible mode.

Do you remember the error message?

kimyo, i think you are using the wrong driver - v3.3.1540.33.
ive got a gigabyte ga-f2a88xm-ds2(bolton fch). xp 32bit and running on ahci. the driver is from the gigabyte drivers disk and its called rcxpahci.inf. there are 5 files in the folder,
rcxpahci - file, rcxpahci.cat, rcxpahci.inf, rcxpahci.sys, txtsetup.oem.
[AMD.ntx86]
%rcxpahci_Desc%=rcxpahci_Inst,PCI\VEN_1022&DEV_7801&CC_0106
%rcxpahci_Desc%=rcxpahci_Inst,PCI\VEN_1022&DEV_7804&CC_0106

on the gigabyte page for my board, this is still the current driver. ive checked your asus board page and it doesnt list ahci drivers, but the page for AM1M-A does -
link
both ahci driver packages list this → AMD AHCI driver V6.1.3.35 for Windows XP 32bit—(WHQL). i downloaded it and it is an exact match to my ahci driver on the gigabyte disk.
you say your driver says

pci/ven_1022&DEV_7800&SUBSYS

where mine and the asus driver says

PCI\VEN_1022&DEV_7801&CC_0106
PCI\VEN_1022&DEV_7804&CC_0106

as the asus driver is for another am1 board, give it a try.
ps i tried another amd ahci driver and got a bsod.

if all else fails, stick with the ide driver(i have working amd ide drivers i could pass on to you)

E.

AHCI_XPWin7-8-8-1_VER12001359_13001221_61335.zip (1.95 MB)

ps, i sllipstreamed the rcxpahci V6.1.3.35 with nLite1.4.9.3 along with another ahci driver and windows installed the rcxpahci by default. be careful though, sometimes nlite removes the setup.exe and autorun files, so manually copy them to the xpcd working folder before you create image or direct burn.

for some reason, amd raid expert(direct from amd) doesnt appear to work on my a88x bolton fch. aha, found this online,


link

ive checked XP-13-4_xp32-64_raid.exe and XP-13-4_xp32-64_sb.exe and its not in either of them, looks like its only from your motherboard maker. if you cant find it on your model, check other boards in that series.

will test rcxpahci on xp 64bit pro over the weekend

E.



thanks for uploading those files. i didn’t do a byte by byte check, but the names and filesizes are identical to the set i used. the datestamps as well, although for some weird reason the time stamps are off.

@ EmmaRoyd
Thank you for having attached the AMD AHCI driver v6.1.3.35 for Windows XP.
After having done a deeper look into the files I have realized, that the TEXTSETUP.OEM contains some entries for USB DeviceIDs.
Since I know, that such entries may prevent a proper XP installation onto a HDD/SSD, I have customized the file and will attach the driverpack, which contains the customized TEXTSETUP.OEM.

@ kimyo:
If the driver, which has been uploaded by EmmaRoyd, should not work for you, you may try the attached one.

32bit AMD AHCI driver v6.1.3.35 for WinXP customized by Fernando.rar (222 KB)

fernando - that did the trick. win xp is now successfully installed with the amd ahci controller. it seems quite happy, thanks!

@ kimyo:

Thank for your feedback!
I am glad, that you succeeded at least.