Asus EEE PC 1000h + mod AHCI BIOS = Hangs on reboot + no hibernate

Hello guys !
I have an asus eee pc 1000h(pretty old i know) and i just found out about a mod ahci bios at
After flashing the bios i could see the hidden option to select ahci sata mode instead of ide.
Now the 2 problems:
1st the reboot hangs for sometime with black screen until it finally "resets"
2nd hibernate doesnt work.Just booting like normal from shutdown.

This is Happening on both Linux and Windows (freshly installed and updated after mod bios).
So i suppose there is something with the ahci option rom inside the bios.
Can anyone confirm if there is an updated ahci rom for this bios to see if it solves my problem?
Thanks modded bios attached. (437 KB)

@ektorasdj :
After having done a look into your attached BIOS I found out, that it doesn’t contain any Intel AHCI Option ROM.
Maybe the insertion of a matching Intel AHCI Option ROM will solve your problem, but I need the exact DeviceID of the on-board Intel SATA AHCI Controller.

To find it out, you should have a Windows OS installed and set the Intel SATA Controller to “AHCI” mode. Then you can get the HardwareIDs of the Intel SATA AHCI Controller by running the Device Manager, expanding the “IDE ATA/ATAPI Controllers” section, doing a right click onto the listed AHCI Controller (maybe it is named “Standard Dual Channel AHCI Controller” or similar) and then choosing the options “Properties” > “Details” > “Property” > “HardwareIDs”. I only need the DeviceID (named DEV_XXXX).

By the way - I have moved your support request into the the better matching “BIOS Modules” Sub-Forum.

Hello @Fernando thanks for taking you time to see my bios!.
MY device is:
Intel(R) ICH7M/MDH SATA AHCI Controller

@ektorasdj :
Thanks for finding out and posting the DeviceID of the on-board Intel SATA AHCI Controller.
On the basis of this information I have customized the latest officially released Intel AHCI ROM v1.20E regarding the support of the DeviceID DEV_27C5 and then tried to insert the AHCI Option ROM into your attached BIOS, but the insertion didn’t work for unknown reasons (not enough space?).
So I am probably not able to help you.
Other question: Which OS are you running with your old ASUS PC and which AHCI driver is it currently using?
Maybe a change of the AHCI driver (my tip: Intel RST v11.2.0.1006 WHQL) will solve some of your problems.

@Fernando Thanks for trying to help me. Unfortunatly the drivers didnt make a difference (it was happening on linux also thats why i ruled out the drivers as a culprit).
Can you see the stock bios if it has any room for the rom? (I dont know if something has been added to the mod bios already.) (386 KB)

@ektorasdj :
After having deleted the Intel LAN Option ROM (only required for the Wake-on-LAN feature), I was able to get the customized Intel AHCI Option ROM v1.20E inserted into the BIOS named 1000H-ASUS-2204GT-01.ROM. The result is attached.
Please test this modded BIOS (at own risk) and report, whether it solved your problem or not.
Good luck!

1000h-asus-modbyfern.rar (409 KB)

Thank you for this bios but after flashing it and enabling ahci it goes through the bios normally and then this appears :


Its stuck there without anything but the option to power it down throught the button.
Anyway i flashed the previous bios and i will leave it at that.
Thanks for trying to solve my problem