ASUS G731GW failed programming attempt

Device : Asus ROG G731GW
Motherboard : G531GW rev 1.6
since i have a CH341a around I tried to tinker with my perfectly working device to allow xmp profiles to make ram upgrade

1. i found a chip with 1 MB which was not the bios
but i didn’t edit it though … just a read … it’s next to the gpu …so i think it was vbios or maybe some sort of EC

2. then found the 12 mb bios chip (MX25L12873F) on the back of the motherboard… I took a backup file before doing any thing (bak.bin) the full 16 mb chip and also there is a dump from ami windows program

3. and made an edit with amibcp (mod.bin) … saved it … flashed it
and nothing worked … not even a led when attatching the power cable

4. i said ok … just flash the backup and it will be fine … but it didn’t work either

5. i flashed the capsule file from asus(G731GW-AS.309) after converting it to bin and even with capsule file chosen the neoprogrammer converted it for me

6. the weird thing that out of one from every two flashes the led light turn on when i attatch the power cord … but still no fan no keyboard light … worth mention that it lights orange like it was charging battery … but there is no battery attached … and when i attach the battery it’s the same … and i know the battery was 100%

7. i took the capsule and added other regions from my backup with asus bios after that using hex editor … but no luck … with the same concept i added other regions to the afu (afuwin309.rom) backup i had -which contains bios/uefi img only- and made a perfect 16 mb file that didn’t work either > does that suggest that the problem was with other regions ??
and if it was … wouldn’t flashing the capsule solve something like this ?

8. worth mention that the backup was with the chip soldered on … and the restore with ship soldered and desoldered with the same results

9. also i didn’t mod the ch341a for 3.3v … i just used it at it’s factory state

10. also the backup opens in uefitool fine … ME analyzer said it was fine

am i missing something here ??

bak.part1.rar (5 MB)

bak.part2.rar (3.67 MB)

mod.part1.rar (5 MB)

mod.part2.rar (3.67 MB)

G731GW-AS.part1.rar (5 MB)

G731GW-AS.part2.rar (3.46 MB)

afuwin309.part1.rar (5 MB)

afuwin309.part2.rar (1.85 MB)

The backed up file looks good, bios region despite of NVRAM and board specific data being identical to stock bios.

Possible errors:
- You didn’t flash properly. Read back content of the flashed spi chip and compare it to the original file. “Verify OK” is not always safe…
- Bad values in NVRAM, exchange to stock NVRAM region (not very probable since you already flashed a stock bios and the backup was a working bios)
- Corrupt ME, clean it according to [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization (not very probable either)
- You did something to the other spi chip (often EC firmware, often identical to first padding in bios region- post the content)
- You missed something when reassembling the machine. Some machines might not start when not completely reassembled- everything reconnected

-i read and saved the file > it’s the same in HexCmp app and via hash
-read the 1mb chip and posted it in attachments … noticed that the size of the read doesn’t match the first padding of the bios, not in size , not in data inside
-i tried the reassembly even attached the hdd despite knowing it has nothing to do with it
– will try cleaning the ME and report back < well it seemed complicated (677 KB)

Seems your 1MB chip is really Nvidia firmware/ bios

NVIDIA Firmware Update Utility (Version 5.531.0)
Copyright (C) 1993-2018, NVIDIA Corporation. All rights reserved.

Sign-On Message : E4914 SKU 30 VGA BIOS ASID: N107G731GW.001$
Build GUID : 7F99CC0DE8EC41C684137C1314A4C835
IFR Subsystem ID : 1043-1FFE
Subsystem Vendor ID : 0x1043
Subsystem ID : 0x1FFE
Version : 90.06.2D.40.C1
Image Hash : 3809A8311A78DF20790D4BEA43B506A7
Product Name : GPU Board
Device Name(s) : Graphics Device
Board ID : 0x00E6
Vendor ID : 0x10DE
Device ID : 0x1F10
Hierarchy ID : Normal Board
Chip SKU : 750-0
Project : 4914-0030-P
Build Date : 11/20/18
Modification Date : 04/14/19
UEFI Version : 0x5000A
UEFI Variant ID : 0x0000000000000009 ( Unknown )
UEFI Signer(s) : Microsoft Corporation UEFI CA 2011
XUSB-FW Version ID : 0x70090003
XUSB-FW Build Time : 2018-10-04 18:36:30
InfoROM Version : G001.0000.02.04
InfoROM Backup : Present
License Placeholder : Present
GPU Mode : N/A

Well, had once a notebook that wouldn’t start without the harddisk…

well after cleaning the me region like the guide , still nothing happened
here is the file to check

– noticed that it warned me about disabled boot guard

outimage.part1.rar (5 MB)

outimage.part2.rar (3.47 MB)

Either you bricked ‘something’ while disassembling/ assembling or you did miss to reconnect a connector maybe under the board?

All your firmware was working when you began dumping it, bios backup seems to be OK. Don’t sounds like firmware to me any longer…

now I suspect that programming with the chip soldered fried something
i have a hunch it’s the super I/O because the keyboard is unresponsive to any thing … like i didn’t press the power button
are there any way to check it … it’s pretty close to the bios … the exact name is it8299e120A
and if i’m to replace it … does such a thing need programing or it works as is ?

What’s happening when you put the machine on charger without switching it on? Normal signs for charging/ battery full? Keyboard unresponsive wouldn’t mean too much, there’s got to be something ‘behind’ the keyboard taking the messages…

Firmware for the/one of the EC chip/s (it’s got ITE8226 in it) is the first padding in the bios region. Sometimes EC controller has it’s own separate firmware chip or the chip can be programmed itself. (This EC firmware blocks within the bios region are not to be confounded with an EC bios region defined in FIT)

the charge led turns on orange then a few minutes later turns white which is perfectly normal behavior

strange enough … i can’t find ITE8226 any where on the board

Might be a bios for a family of machines, some of them not using this fw, fw itself might be used for a chip- family…

Did you try to reset CMOS (removing CMOS battery and battery), did you try to start withour the main battery?

also … i don’t have the schematics because they are not available anywhere … but i managed to check all power rails and there is no short of any sort

yes- tried to power drain it multiple times
-power from battery only
-power from charger only
-power with different ram or no ram , with or without wifi cardand nvme drive and the sata

Do you happen to have some detailed and sharp pictures of both board sides?
See hotfix, firmware collection for keyboard controller, also 2 firmwares for G731GW, maybe you can find another SPI chip. Unclear if it’s this keyboard controller that will connect to the power button, too. (ITE8291)

will post some … once i get home