asus gl703gm bricked until ch341a programmer arrives?

Confirm the writes is 100% correct, using method I mentioned (ie you have erase and write again first, since you tried powering on system), nothing more to do before doing that.

write was 100% identical. genius239 said this is “double layer” bios or something don’t remember correctly. (and because this bios is “weird” it’s not like others)
dunno does this help or not but no power nothing. only power led.

@chunnuntai - So you manually confirmed the write how I mentioned?

Sorry, that does not make sense to me as explained. And BIOS looks normal to me, nothing like a dual image or dual system BIOS, I assume maybe he meant something like that, when BIOS may have image for two models etc.
I do know it does not unlock easily, menu-wise, but stuff like that and any discussions related to editing menu are unrelated to what we’re doing here.

Here, please test, this is someone else BIOS region in place of the one I rebuilt for you, this is dumped from working system, so if I fixed the ME correctly from your corrupted one, then system should run unless there is some other issue…179006089930710

@genius239 - Is there something I’m not seeing in BIOS on this model, that would be relevant to fixing a BIOS or recovery image etc?
I only see one VTF at end in 2nd to last volume where expected, before last volume we don’t actually use/include in actual BIOS fixing scenarios.
Do you have a known working dump for this model WITH valid ME FW region? If yes, can you please send me the ME FW region so I can confirm all OK with my rebuild from his corrupted one.
I used the ME recovery image from padding area in first tests, failed, so I rebuilt his corrupted one and that seems to be failing too.


power button is working. when i press the power button i can hear very quiet "sound of electricity"

quiet noise coming from close to bios chip and close to cmos battery… probably shorted somehow, any idea what to try / buy next

@chunnuntai - Do you see any burn marks, lifted traces on the PCB etc? Remove CMOS battery and try to start, then remove all memory and try to start, then put back only one memory stick - any changes during any of that?
The above BIOS at #23 should boot, provided the write went in 100% matching. Dump it and compare in hex to confirm, but ONLY directly after a new fresh write in - you can’t compare after trying to start it

Hello. I’m David and i have laptop repair service in Poland. I have my customer laptop with broken bios. Somebody before us tried to flash bios with programmer and now chip was empty. I repaired your bios :slight_smile: i used dump2.rom and bios_backup.bin that you uploaded and made working one. If you still need it i can send it to you :slight_smile: if you dont need it i have one question. Your bios have a password. Do you remember it and can send it to me? Thanks :slight_smile: