asus gl703gm bricked until ch341a programmer arrives?


Topic says it, custom bios was made by one of the members in this forum and everything worked perfectly until for some reason I wanted to get rid of ThrottleStop and started to undervolt from bios.
(yea my mind in hangover does these kinda things… I should not touch bios or anything delicate while in hangover…)

First I put cpu offset to -150mV (this laptop’s i7-8750h is capable running 3900mhz @ all 6 cores and 12 threads with -190mV so -150mV was "loose start"
after that it booted to windows and it worked, back to bios then.
next I wanted to undervolt cache but probably did something wrong… now the machine is bricked.
I ordered ch341a programmer…353.m2749.l2649

My question is, could the bios be reverted to it’s earlier state with old dump or fat32 “asus crisis flash” using FN + esc and having correct bios file in correct form etc…

If someone knows and can help me to revive this machine today, i’m willing to donate via paypal on Friday!

otherwise I will wait for the programmer to arrive this Friday or next week.

ps. sorry for bad english, it is not my native language.

Edit: Doesnot work: ALT + HOME, CTRL + HOME, CTRL + ALT + DEL

Asus EZ Flash 3 guide PDF

I formated fat32 disk that is 2gigabytes in size.
I put bios file “GL703GM-AS.309” root folder.
Tried all the combinations.

seems like ch341a is 100% necessary?

@chunnuntai - Sorry to hear, probably undervolt issue, below is my now-standard warning for anyone with unlocked laptop BIOS - and sometimes I’ve seen 100mv be too much, so sounds familiar to me
*** WARNING - To ANYONE with laptop and unlocked BIOS!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

Yes, once you have programmer you can fix BIOS back to either original BIOS region dump + rest of BIOS, or you can use the unlocked BIOS region + rest of BIOS, then program it back to chip.
I can help you do that if you need, but first I’ll need dump of your current chip contents and then the unlocked BIOS you received that was OK and you tested working etc

You may be able to get it working by clearing CMOS, or remove one stick of memory and see if that will reset it. If not, if you know a “recovery hotkey combo” for this specific model, and that function works in this state, then yes you may be able to recover with stock BIOS file.
I doubt recovery method will work though, since BIOS is probably not loading at all.

Yes, usually you need to fix with programmer, sorry But don’t worry, we can fix once you have the tools.

I think msi laptops can be reverted to failsafe or defaults by removing the cmos battery, I tried it but it did not work with my asus. (it was off 8 hours while I slept) I tried many methods today with usb sticks (mbr, gpt, different partition sizes, many keycombinations, different usb slots) but I was not able to find a way to asus ez flash v3 recovery.

Some laptops partially clear CMOS if you remove the main battery, CMOS battery, Power cable, and then press and hold power on button for a minute. Some you can’t do anything like this no matter what you do.
And some have a pad on the board that looks like where pins should go, but it’s actually a circled with separated area throu8gh middle and you need to short one side to the other while power is connected.

EZ Flash only works from withing the BIOS while system is running. Anything “Recovery” you’d have to find specific to your model or same model series. Send Asus an email and ask them if there is a recovery method or not, while you wait on programmer to arrive.

any example of the “have a pad on the board that looks like where pins should go, but it’s actually a circled with separated area throu8gh middle and you need to short one side to the other while power is connected.”

programmer arrived.

@chunnuntai - Sorry, no, I don’t know where any example of that is here, it’s somewhere here but I just don’t know where - sorry

What is your BIOS chip ID? This way I can tell you what software version may be best to use, so that you get a good dump and we know writes will work properly.
I will give you guide and files below, but DO NOT use AUTO, erase or write in programmer until we’ve talked again and I’ve confirmed you’ve made a good backup

Here is guide - [GUIDE] Flash BIOS with CH341A programmer
And here is software package -…213094641136166

when i download…213094641136166
it says it’s malicious or dangerous and chorium blocks the file and discards it.

edit: got it.

and there is two chips with 8 "legs"
first one has markings :

this must be gpu’s vBios chip?

second one is marked like this

this one is the motherboards bios right?…iew?usp=sharing



dump2.rom before bios was bricked.…iew?usp=sharing

I haven’t tried to take new dump from bios which is bricked.

hopefully you can comment soon


removed the bios battery.
connected the soic8 clips to the chip with these details:


tried v 1.29 of the software, that one does not find chip 25L12873F

tried v 1.30, same thing

1.34 works and finds the chip '25L12873F’

now reading the chip was successful

but when trying to verify this problem pops up.…iew?usp=sharing

need assistance !

EDIT: saw the .txt file which contains information regarding

For MX25L12873F use CH341A v1.31(1.4) (CH341AFree) (This is the name of the folder), ASProgrammer 1.4 or 1.41, or CH341A v1.1.1.32

trying these now…iew?usp=sharing

uploading the file soon

backup biosfile saved with…iew?usp=sharing

picture of the bios file from asus website and saved file from ch341a programmer CH341A v1.31(1.4) (CH341AFree)


edit 2:

found these posts


now trying the CH341 Programmer v1.1.1.32

edit 3:

saved the file with CH341 Programmer v1.1.1.32

I compared it with file that i got with CH341A v1.31(1.4) (CH341AFree) using hex editor and they were identical.

@chunnuntai - Disable your anti-virus then, it’s false alarm due to these tools access and write BIOS etc.
Wow, please use edit button instead of making multiple posts in a row, thanks.

You may have to dump both chips and let me see contents before I can tell you which is what, since both are much larger than EC/vBIOS etc.
W25Q80EW << This is a 1.8V chip, so you cannot dump without a 1.8v adapter, so hopefully BIOS is not here (unless you already have 1.8v adapter)!
And, this may be graphics vBIOS just on super large chip for some reason, I see SaltInBank writing to this chip for his vBIOS here - [Help] Unlock advanced menu on 2019 Acer Predator Helios 300 PH315-52 (11)

For MX25L12873F use CH341A v1.31(1.4) (CH341AFree) (This is the name of the folder, included in the package I linked for you), ASProgrammer 1.4 or 1.41, or CH341A v1.1.1.32

Your posts are a mess and I have no idea what is what in those links due to the way you linked and described things.
Please upload only your dump BIOS and I will fix for you, I do not need images or multiple BIOS saved from this or that, just the current bricked BIOS dumped with one of the above mentioned tools.

I opened the backup file I got from…iew?usp=sharing

so that confirms the motherboards bios is in this chip.

the 1.8v winbond chip is vBios chip.

can you now check the file I uploaded for you?

@chunnuntai - Your first sentence does not make sense to me, maybe some translation issue? What software version did you use, to make this dump? If you did not use what I mentioned, dump it again using the tool/version I mentioned (or dump may be bad, and or write back may fail too if you don’t use those version)
Ohh, I see what you mean now in the image. This means it may be OK, please answer my question above though ^^
And, give me a link to that file - please don’t say look above, all those links look same and I hate google, no links above are clearly this file, please post link below, thanks

I have 3 backups
2 was made with CH341A v1.31(1.4) (CH341AFree)
and one was made with CH341 Programmer v1.1.1.32

and they are all identical, triple checked with hex editor HxD

Link for the dump…iew?usp=sharing

Thanks, please wait

* Edit - @chunnuntai - Please erase chip, then open this file, write to chip, verify, then run system, enter BIOS and load optimal, then save and reboot back to BIOS to make any stock changes you may need to load windows etc.
Then boot to windows and shut down. Then dump chip again and send to me, so I can put back in your data to NVRAM - This only contains stock NVRAM unpopulated, and once you run system it will repopulate some and then I may need to fill in some blanks (Such as if keyboard LED’s do not work, or ethernet LAN etc)…444472063547612

If this one fails to start, let me know and I will redo without using your messed up ME FW as base to fix ME FW

the laptop won’t power on.
no fans, no lights, nothing. only led on is the battery led when I connect it to the power outlet in the wall.

motherboard bricked or is there something I can do?

dump file size : 16 384 KB

original bios file size : 16 386 KB (from ASUS WEBSITE filename ::: GL703GM-AS.309)

can I try to flash this file with ch341a or is this file only to be used in asus EZ FLash v3

if bios chip is totally “bad” or “corrupted” should the power come back on? because now there is no signs of powering up when I push the power button.

@chunnuntai - So, above BIOS at #13 doesn’t work? If not, then try these two. First do Redux1StockNV, and if it runs, then do as I mentioned above in post #13.
If Redux1StockNV does not work, then try Redux1StockNV-FFSysPad…365275968242838

No, you can’t program BIOS from Asus, it’s only half the BIOS + a volume that does not belong on chip. Don’t worry, I will get it sorted out for you

There is no for sure this or that if/when BIOS is corrupted, all system are different and all broken BIOS issues are unique.

Erase chip, blank check, then open BIOS file and write/verify.…iew?usp=sharing

not booting :frowning:

Then redo it again, and BEFORE you power on the laptop, close the software, open it again and read then verify, then save and compare in hex with what you wrote to confirm 100% write is valid.

Also, find the other 128kb-1MB chip and dump it and send me contents (not the one on or near graphics PCB)

What software/version are you doing the write with? Maybe all can read OK, but not all can write OK. You will know for sure once you dump and compare with what you gave it as source to write.

Also, are you 100% sure this is GL703GM Model?

I used CH341A v1.31(1.4) (CH341AFree) for both
Now I try CH341 Programmer v1.1.1.32
first I try my backup ( with that one atleast machine booted and keyboard lit up.)
then I try to flash Redux1StockNV.bin & Redux1StockNV-FFSysPad.bin

128kbb - 1mb chip, does it have 8 legs and about same size as this chip?

model is GL703GM-EE129T according to the original box

Booting and keyboard lit up means nothing, this was bricked BIOS anyway, don’t waste your time messing with that.

Whatever you write with, once done, close program, reopen and read, verify, save and then manually compare in hex to verify the write yourself, this way you know the write is good and not an invalid verify

Yes, 128KB-1MB chip would look similar to BIOS chip as well. Thanks for confirming model too.

I bet issue with first set I sent you was ME FW region, test last two I sent and if those fail I will send you known working dump from someone else’s machine.
Then if that fails you have a write issue (if not confirmed to be a non-issue already), or EC FW issue, or some hardware issue (something shorted out, or your missing re-connecting something etc)

nothing, not booting with my backup.
any ideas what can I try