ASUS K55N Laptop - Modded BIOS Flashing Problem


I have a couple of questions regarding the flashing of a custom BIOS on my laptop. The main board is a K55DE rev 2.0.

Here’s the situation:

I want to mod the BIOS of my laptop to change the UMA Frame Buffer size, which I was able to do with the help of this post.(>>Thank you, k3nny!<<)

The unmodified BIOS file from ASUS can be found >>here.<< (I chose Windows 8.1 and downloaded BIOS 217)

The problem is when it comes to flashing the modified BIOS. I’ve tried using AFUDOS, ASUS’s WinFlash utility and AFUWINx64, but with no success. AFUDOS gave this error: (46 - Error: Problem getting flash information). I got the same error when attempting to backup the currently flashed BIOS. WinFlash gave a verification error, AFUWINx64 crashes and the laptop’s trackpad, keyboard and USB ports stop functioning when I click any button in the program, requiring a reboot to regain functionality again.

I then tried to remove the header of the .CAP file with both UEFITool and FD44Editor. FD44Editor gave an error when attempting to open the file (picture attached), and the resulting .bin and .rom files from UEFITool did not flash from AFUDOS with the same error code as before.

Now I’m stuck and am not sure exactly what to do. I’m considering buying and using a CH341A-based programmer to flash the BIOS chip, but I’m unsure of how many components along with the programmer I will need to finish the process. I’ve attached a picture of what I believe to be the BIOS chip itself. I intend on following the guide >>here.<<

If I need to acquire the programmer, what other components would I need to flash the chip? I’m not sure if there are any other methods to flash a BIOS out there other than the ones I’ve already tried.

I have a backup laptop just in case I manage to brick the ASUS K55N, so I’m not worried about testing different methods.

Thanks for reading this long post, sorry for the wall of text, any help would be greatly appreciated!

FD44Editor Error.png

BIOS Chip2.jpg

@ BongoBanger:
Welcome at Win-RAID Forum!

Since I have never tried to flash a modded BIOS into an ASUS laptop, I cannot help you myself.
Nevertheless I hope, that you will find someone, who can give you some advices.
Good luck!

Dieter (alias Fernando)

Try using flashrom from linux, AFAIK Winbond W25Q32.V is supported. For use on a notebook you have to use an option -p internal:laptop=force_I_want_a_brick
I have the same chip on my Asus U38N and it works for me

@ Ultra:

Welcome at Win-RAID Forum and thanks for your contribution.
Now I hope, that BongoBanger will succeed with your help.

Dieter (alias Fernando)

@ Fernando
Thanks! Glad I found this forum, it’s a great resource for BIOS modding.

@ Ultra
The option you gave for flashrom worked great! I bricked the board, though. I flashed the modded .bin file with the .CAP header cut off, I’m thinking that I should’ve flashed the modded .CAP file instead.

This chip has 4 mb of memory AFAIK so I think you wont be able to flash .cap file from flashrom (in my case .cap file has size of 4098kb)

I have a laptop with similar spec (Chipset: AMD A70M, CPU: A8-4555M ) and wanted to oc memory and enlarge the UMA frame buffer, but had no success with biosmod throught AMIBCP