Here is my problem I win a laptop from an auction received it and powered it on, laptop was working fine except there was no system installed obviously the seller wiped all the data in the hard drive.the problem starts here I accessed the bios thinking there might be an option to recover the original system(win 8).I checked couldn’t find any recovery options then I went to exit the bios (BTW I had plugged a USB with Linux mint installed on it on that time) before exiting the bios I clicked on (Launch EFI shell from filesystem device) two times and nothing happened then I thought it is better to do Restore Defaults and after that I saved changes and exited and after that the laptop became dead.
when I press the power button on num lock, caps lock and hard drive light flashes then goes off and the power indicator light keeps on and nothing shown in the screen.
BTW I removed CMOS battery, also tried another monitor nothing is being shown in the screen.
I’m guessing I wiped the bios. Guys Please I need help I want to fix it by myself how is it possible to restore the bios again or update it.
Thanks in advance.

Your bios is still there.
The bios does not restore or install oses.
Have you tried to open the bios again?

As far as i know, removing the battery is not enough to reset the bios in a laptop.

I cant access anything the laptop shows nothing on screen.

any one please could help.
I’m trying the ctrl+home( force update ) but i think I’m doing something wrong with renaming the file name the file name from ASUS website called (K55AAS.407), what should I rename it?