Asus M4A87TD Evo Downgrade impossible

Hello there,

i upgraded my bios some days ago, and it had negative side effects on my system.
Since then i can’t start any media with Windows 7 x64 anymore. I get 0xc0000225
so i have to use Linux atm. I tried Afudos, Afuwin and even Afulnx to downgrade
my bios again to the ROM file i saved before i made my upgrade, but it seems that
it is impossible to downgrade this bios to a version below 1005.
My saved rom might be a 902 i think.
Is there any way i can make EZ Flash (or any other tool) accept any older bios
ROM without telling me it is older than the actual mainboard and not letting me
flash it?

I am really desperated. This is really my last Asus board ever, how can they not
warn that downgrade is impossible.

Any help ?

@ Lag_Me:
Welcome at Win-RAID Forum!

1. Did you flash an original ASUS or a modded BIOS?
2. If it was a modded one, which modules were updated?
3. Have you tried to clear CMOS?
4. Why do you want to "downgrade" to the very old BIOS 902? There are some newer BIOS versions available for your mainboard (1005, 1101, 1102, 1202).

Since you obviously tried all possibilities, I din’t know any others.

Only ASUS can answer this question.

Dieter (alias Fernando)

Hello Fernando,

i flashed original Asus Roms, i tried them all which i can flash, but my Windows 7 x64 does not run on any of them.
There seems to have been a change in the versions since 1005 made, which is now the culprit why my system won’t run.

No i did not try to clear the cmos, what can i expect of it ? You mean i have to remove the battery and power ?
I will try that now.

Thx for your tip.

My question, can i modify one old Bios version so the EZ Flash would accept it as a newer version and allow me to downgrade ?

Danke ! Danke ! Danke ! Das cmos resetten hat geholfen !


Thx ! Thx ! Thx ! clearing the cmos helped my system is now running again.
Thank you very much, you are my hero of the day

You are welcome! I am glad, that I could help you.