Asus N550JV shutdown every 30 minutes

Hi guys,
my laptop is shutting down every 30 min exactly and after months of research on what was wrong (started a month after the warranty expired, was quite angry) I finally found this beautiful forum.

Now I know it is linked to IME probably missing after a BIOS update.
So I tried to get MEInfo on my bios file but ASUS doesn’t provide anything on it. I know however that it is IME 9.0.

Then when trying “fptw -d spi.bin” under windows it gives me Error 26.

So I now need your help to know what to do.
Would trying to dump under DOS change anything ?
If not I understood that I need a spi programmer, is there a specific model that I should buy ? Any recommendation on which one is the best/easiest ?

Thank you for your time and I hope we can do something here.

EDIT: tried under DOS and still ERROR 26

There are two things you can try in order to allow read/write access to the ME firmware region of the SPI chip, before resorting into using a programmer.

a) Follow these steps but at step 3 run “setup_var 0x3A5 0x01”.
b) If the above does not help, try this (example picture) which requires shorting two audio chip pins while the system boots.

Hopefully one of the two will allow you to dump/reflash the ME firmware without getting Error 26. Both usually apply for one boot only (definitely the 2nd), so you’ll need to redo them after any reboot.

Thank for your quick answer plutomaniac,

So I tried both methods without success.

a) tells me: “GUID does not match expected GUID taking it nevertheless…”
and then "setting offset 0x3A5 to 0x01"
still got ERROR 26 when trying to dump

b) is really difficult but i tried many times without success, is there a way to see if I short the pins correctly ?
the chip is ALC668 D7G35H1 GD36A3
It also got 12 pins on each sides.
After shorting 1 and 5 like in the picture I still got ERROR 26 but it is so small I’m not sure I am doing this correctly.

Yes it is hard to do the pin shorting as they’re very small. The only solution is to use a programmer. I am not knowledgeable when it comes to programmers so I can’t help you there. You can get a cheap one with a clip (depending on what BIOS chip your system has) and you may need to disolder the SPI chip to reflash and then solder it back.

Thanks, so I will turn to the programmer you linked with a clip.
I think i found the bios chip, could you confirm this is this one ?
It says on it : “Winbond 25064FVS** 1345” can’t read the 2 *
If yes then how do i know if need to disolder it or not ?

EDIT: programmer ordered, should arrive around the 22nd


So I finally receive the programmer and could successfully dump the bios.
Lucky I didn’t have to disolder.

When passing the file though MEAnalyser I got this result

Family: ME
Release: Production
Type: Region, Extracted
SKU: 1.5MB
SVN: 1
VCN: 2
PV: Yes
Date: 2013-04-11
Size: 0x17D000
Platform: LPT
Latest: No

So I am lost now, what I should do ?
Could you point me to the right direction please.

Thank you

EDIT : I will try this (3.33 MB)

Yes you need to follow the CleanUp Guide. Due to the old FITc version that built your dump and ME settings, you’ll see one warning about SMBus Address (ignore) and another setting (BootGuard profile) needs to be set to its default option instead of “Unknown”. Download the attached fixed SPI image and flash it back via the programmer. Once the system boots up, make sure to do a “fptw -greset” as well. After the reboot, everything should be back to normal.

jeanphil_N550JV_fix.rar (3.22 MB)

So I tried flashing your firmware and now the laptop powers on for a second then shutdowns.

Nothing else I can on it apparently.

Will try to clean following the guide myself, I’ll keep updated

Ok so the system is now booting with the spi I cleaned.
I didn’t know what BootGuard Profile I should use so I just put the first one : 0 - No_FVME
Did the fptw -greset and I am now waiting to see if the laptop pass the 30 min deadline.

The spi I cleaned is still shutting down after 30 min so I tried to reflash yours and I still got the shutdown after a second or so.
What are my options now ?

Did you make any hardware change before the problem occurred? I don’t see how my spi would cause such an issue. It’s the same guide and we both set BootGuard to No_FVME. Can you attach your own spi after following the cleanup guide?

Here it is.
I did change the harddrive for a ssd. Shall I put back the old HDD ?
I am now trying to flash with the 1.29 version of the programmer software. (3.33 MB)

Maybe the EOL Anti-Theft Technology kicked in although reflashing the ME firmware should have fixed that, if true. Yes try to put the old HDD back just to see if it turns off after 30 minutes (shouldn’t be the cause but it’s worth a try). Also, make sure that the software you’re using for the programmer works because it seems unlikely that my spi fails in such a way compared to yours. The settings are the same (checked). The only difference is that I also updated the ME firmware to the latest but, once again, that does not merit an unbootable system. For CH341A programmers, you can find a few things in this thread. Make sure to Verify the written data or manually re-dump and compare with the input image.

Can’t find the old disk, I’ll look for it again tomorrow.

The programmer works much better with 1.29, I think it’s all good on this side now.
But it seems that the spi is changing after being flashed, looking with WinMerge there is many parts differents, being data, I don’t know what they are.
The dump attached is after flashing with your image and trying to turn on.

When plugged after a bios flash the computer get a light on for a second (it’s not really turning on just the power button lights up) then it’s turns off. I then need to push the button for it to really turn on for a secon like i said.
When flashing with the non updated meFW image the light turn on for a few seconds more then turn off. Then when I push the power button the laptop can run for 30min.

I also tried without the battery and cmos battery without success.

More backstory:
If I recall well it started happen after a Linux installation, the ssd was added after that, thinking it would change something.
I also tried at the time to unplugged everything and keep only the motherboard running and staying in the bios and it still shuts down after 30min

EDIT : Using MEanalyser I see that you have updated the firmware to whereas the original was Is there no problem updating from 9.0 to 9.1 ? (3.35 MB)

ME 9.1 firmware supersedes 9.0. It is normal for the Engine region to have different data after the first system boot because its DATA section is now initialized, as explained at Section A of the CleanUp Guide. Also, make sure that you disable any Anti-Theft option at the BIOS, if such a thing exists of course.

Indeed the best way to check if the problem is ME/Firmware/Hardware-related is to stay at the BIOS (no OS) and wait. The 30-minute shutdown is known to happen when a) the ME firmware is corrupted, b) Anti-Theft (EOL) has detected a “stolen” platform or c) the CPU got replaced with one not supported by the PCH. Since you only changed the HDD and HM86 PCH does not have CPU restrictions either way, I believe it’s either a or b. We can certainly fix both of these via the CleanUp Guide. Attached is a “conservative” cleaned-up SPI image in which I used 1.5MB RGN and the equivalent old FITC v9.0.3.1347 with only Anti-Theft disabled.

jeanphil_N550JV_fix_v2.rar (3.09 MB)

Thank you, but unfortunately this v2 still shuts down after a second.
In the BIOS, Anti Theft and Intel AT suspend Mode are Disabled.

Other question, cause I installed windows when the bios was still corrupted. Is windows updating automatically the ME driver ? Cause I can’t see it in the Device Manager.
Don’t know if related but trying to explore every option.

The ME driver is not shown when the ME firmware cannot initialize so that’s normal. The SPI image is built properly so there are four possible cases. From most to least probable these are a) Reset is needed after reflashing (remove all power for a few minutes, remove memory DIMMs and re-insert one of them or try the other), b) Problem is not at ME firmware but at corrupt BIOS, c) Programmer does not write properly (verify the data after flashing are the same - before first boot), d) Problem is hardware related.

So I tried removing all power and booting with only one memory DIMM and still shutting off after a second.
However I tried the other one right after (no reflash) and the laptop would stay on but showing nothing on screen.
That was a strange and unusual behaviour.
So I reflashed and tried this DIMM but it shuts down after a second again.

b) Is it possible to include the BIOS in the FITc to build the image ?

c) I am following the guide and always verify the write. It says chip and buffer are same.

d) Hardware related would be the motherboard then I guess. I still find it strange that it’s working perfectly for 30min to the second.

Yes, the 30 minutes are certainly ME related. Theoretically it could be a bad PCH (where the ME is) but I’ve never personally seen such a hardware issue. The fact that the system behaved differently after switching RAM and shutting down shows that the issue is not ME firmware. Alright, at this point we can exclude the programmer, the ME firmware and let’s also exclude the PCH as being problematic. That leaves the BIOS and its settings (prime candidate) or the rest of the hardware (bad RAM?). Bad RAM could be the cause as the ME uses a small part of RAM (UMA) for its operations and when that fails to be allocated it probably enters recovery mode with the shutdown counter. Let’s exclude the BIOS first. Attached is the previous SPI (“conservative”, v2) but now with the stock ASUS BIOS replaced via UEFITool. You’ll lose some serial numbers but for now we just need to get it to work and work from there. By the way, once you flash a SPI image, there is no point in re-flashing it when you do other tests such as RAM switching and so on. The goal is to keep the SPI healthy/steady and then mess with the rest to see if they get the system to work.

Edit: The RAM being faulty could actually explain a lot. Maybe sometimes the system can’t even boot (quick shutdown) and other times it boots but the ME cannot allocate its UMA and thus enters recovery mode and gives the 30 minute window for servicing purposes. Do you have other RAM to test? Maybe one of the modules by itself works?

jeanphil_N550JV_fix_v3.rar (3.08 MB)

Nice !!

After flashing with your v3 (still have battery and cmos battery removed) first boot was failed (one second) but worked on second try.
Windows also installed IME driver !
Only got one DIMM inside and waiting the usual 30 min but it looks like a win.

I’ll keep you updated.