Asus P5Q Deluxe Intel O Rom Newer than 10.1

Hello, is there a way to get a newer option rom than 10.1 on that mainboard?
I tried to remove some (in my opinion unneded things) from the rom with MMTOOL but it still doesn’t work.
i have 3 3TB WD HDD’s and a modded BIOS with 10.1. But the Option rom doesnt recognise the HDD’s to make a raid volume. In RST Software they are shown properly but there i also can’t create a raid volume. when i connect other hdd’s(in my test 3 500GB Hdd’s) i can create a raid volume.
i tried to mod the bios with a newer version. then he recognizes the 3TB disks in O Rom but hangs after it.
or is there a way to get it on ver 10.1?

Hello Remedin,
welcome at Win-RAID Forum!

AFAIK the only way is to ask ASUS for a new BIOS with more space for Option ROM modules.


thanks for your answer.
is it normal that the Version 10.1 doesn’t support raid with 3 TB Drives?`
did some funy test and it seems to work:
when the newer version was on BIOS i was able to create the raid in the option rom.
then i flashed back the working bios version with v 10.1
the raid still exists and seems to work.
it’s just initalizing at the moment :wink:
but that can’t be the right way :stuck_out_tongue:

Yes, only Intel RAID ROM versions from 10.5 up do support >2 TB sized HDDs.