ASUS P7Q57-M DO with i7 870 completely freezes when booting Windows 10, i5 660 works fine

Hi there, I recently got my hands on this old system which I want to upgrade and give to a family member. It originally came with an i5 660 and I want to put an old i7 870 I had lying around in it. The i7 is known good, I tested it on another board.

Now, when I put the i7 on the board and try to boot Windows 10, the system will completely lock up 9/10 times during the spinny dots screen. The CPU fan ramps up to 100% and not even the reset button or holding the power button will shut down the system. In the 1/10 chance it manages to boot into Windows, the system runs absolutely stable. When I put the i5 back on the board it boots fine every time.

I ran memtest with the i7 installed and it didn’t find any problems. I also tried reinstalling Windows but it just hangs again after the installer reboots to the SSD the first time. BIOS is updated to the latest version. Linux seems to boot fine.

Some ASUS boards from that era had a strange bug that causes that behavior if VT-d is enabled and a recent windows 10 build is used.
Disable VT-d on the bios and see if it helps (you can leave intel virtualization technology enabled).

VT-d is disabled. I also tried disabling virtualization alltogether but that didn’t help.

By now I’ve tried swapping PSU, RAM, boot drive and GPU, I also tried an i5 750 on the board which boots fine every time as well.

I’ve tested the i7 on a different board again, and it works fine there. Boots fine and runs stable, also tested 2 hours with Prime 95 blend without errors.

As I’ve said this problem only occurs with Windows 10. Linux boots fine.

Windows will also boot when I shut it down, since fast startup is enabled. When I select restart it will hang on the next boot and I have to cut power, wait for residual power to drain and can then boot once again. If I con’t cut power long enough it will also hang on the next boot.