Hello. Please assist. My old pc recently broke down and as cash is an issue right now, I went back to using another old pc I had in the cupboard. The motherboard is an Asus P8Z68-V LX with Bios information as follows = Bios version - - 4105 x64, Build date - 07/01/2013, EC version - MBECD-0006a, ME version -, Southbridge stepping - B3. Now here is the issue, I have a sata 500gb drive I can use as my primary boot drive or a 256gb SSD drive which was the bootable drive in the pc that broke down. However neither are being detected in bios, along with 5 or 6 other drives I have tried. it tell me to look for CSM but there is none nor is there UEFI. The only thing i have seen is EFI compatibilty mode and when i turn it on the pc wont boot. I have to remove the battery and reset cmos. Any help please would be appreciated

I looked at the BIOS version 4105 via UBU & there are no UEFI components evident.
In short, UEFI was contemplated but not executed. Thus doing an NVMe insertion is not going to work.
Your motherboard is likely not seeing any of the drives as they are formatted in the GPT (Gui Partition Table) method. As your motherboard BIOS has no UEFI environment, you need to format your drives using the MBR (Master Boot Record) method. Hopefully you’ve backed up your data. When you format under MBR you are limited to 2TB maximum size.

Hope that helps.


Hi Hans. Will that apply to a standard Western Digital 500GB drive too? The bios
image, this is what mine looks like and says UEFI at the top, so are you saying they didnt stick it in?

Thank you


The picture you’re showing indicates BIOS v3203 for the motherboard P8Z68-V PRO
This is not the same motherboard you indicated in your first post.

Try updating to BIOS v3603 which is the latest and see how that goes! :crazy_face: :rofl:

P8Z68-V PRO BIOS 3603(for Win7 & Win8) Version 3603(Only for Win7 & Win8) 16.64 MB 2012/11/27

This would be the correct updated BIOS for the board pictured

Now I’m going to cut my lawn while you do the proper update to your board! :sleeping: :disguised_face: :face_with_monocle:



You can find the modded BIOS to your pictured motherboard at the link below.

This is direct from the mobo now. I took the sata hdd and deleted all partitions in disk management then reformatted in NTFS. and am still not seeing the drive in Bios.

Well, mods aside, you now need some knowledge, so start reading the guide from point #4
Step 4 - Installation of Win10/11 onto the NVMe SSD

Hello. I see you are running the same MOBO as me.

The motherboard is an Asus P8Z68-V LX with Bios information as follows =
Bios version - 4105 x64
Build date - 07/01/2013
EC version - MBECD-0006a
ME version -
Southbridge stepping - B3.

Now here is the issue, I have a SATA Western Digital 500GB drive and I have a DM LIFE 256GB SSD. Both drives are 100 percent working and I have tested them in another PC. My SATA cable is also 100 percent working and has been tested. Neither of these two drives are being detected in bios. The internet says to look for CSM mode and enable it but it is not visible in BIOS. I have reformatted drives from GUI to MBR. If I boot the mobo from a flash drive through to the windows install page, it works and at the windows install page when you select the drive to install to, there is no drive. Any help please

Keep it calm if you please and stop jumping around and posting everywhere.
Is any NVMe mod flashed right now in the motherboard?
You asked for an NVMe mod for your motherboard model… you’re not mention here any NVMe disks… so those 2 SATA disks were working before flashing the mod file? Was is set AHCI in bios?
That DM disk is SATA 2.5" or an M.2 NVMe disk? We usually dont call SSD to an NVMe disk…
Did you read the guide i linked? ITS FOR READING!!!
The setting CSM, can be ENABLE, OFF or AUTO, this all depends on the method the user wants to install the OS.
Meaning, for an OS x64 on an NVMe (UEFI) or simply the user wants an OS as UEFI in regular SATA disks, the setting is CSM OFF/DISABLE, selecting this method the system disk it automatically set as GPT/NTFS upon windows setup.
Legacy OS setup means CSM to AUTO/ENABLE, the disk is set as MBR/NTFS.
Finally to setup a system as UEFI the USB OS setup must also be configured as UEFI boot and an UEFI enable x64 OS.
Legacy OS setup doesn’t need an USB UEFI boot OS, it can use x86 or x64 OS.

EDIT: Thank you, I really can’t figure it out… if his talking of an NVMe from here or outside the forum here or what the hell is going on with his disks… or Win SETUP method he wants…

@Meatwar @Corrado

NVMe insert

NVMe detect

ROM EFI stock

ROM EFI update

Modded BIOS UEFI version 4103 below

So the NVMe insert is done, BIOS/UEFI CSM switch is Enabled
Check your BOOT Tab.

As a alternative, you can try to source out a Samsung 950 Pro SSD 256GB or 512GB as this has the ROM embedded in the controller. Thus the BIOS should recognize it and thus should boot up when OS is installed.

Good luck.


P8Z68-V-LX-ASUS-4105.rar (4.0 MB)

1 Like