Asus P9D-M Intel ME stuck in Recovery

I received an Asus P9D-M and it’s only running 1 core and Intel status says ME is in recovery.

I have tried updating BIOS with ME jumper on recovery, but when I move it back it still says it’s in recovery. I power off and clear CMOS and leave it unplugged but it never clears out. Sometimes the status says Hard-M Disabled after flashing on the very first boot. Then next reboot it says Recovery.

There is an AMT enabled/disabled jumper as well, AMT is disabled and doesn’t seem to matter if I put it to enabled.

I have 2 bios chips and a USB ch314a flash tool that I’m getting comfortable with, I was able to unbrick the one bios chip. But no matter what I flash Intel ME stays in recovery and only 1 core gets used by the processor. I tried cleaning the motherboard too with a brush and IPA but no change. I don’t think the jumper is shorting but can’t confirm.

I tried starting at oldest bios and stepping up but this didn’t work either.

Is there anything I can do to try and reflash ME or upgrade it etc? Thank you


Could you dump your full bios image?

Asus provides full (capsuled) firmware images. Remove capsule, write the image on an empty chip, check if the content is properly flashed, keep the original bios, put the newly programmed chip in.

The board has a ME recovery jumper that will put ME in recovery and it has a FD01 jumper that will allow flashing the ME region by software, read the pdf in bios update 706 for the procedure. (And it has possibly some undocumented jumpers, too, where it might be worth checking against the pictures on ASUS website)

The board doesn’t have AMT, the ME is SPS, it has an AST2300 on board, but to enable the BMC function an ASMB7-iKVM module is needed.

If you never set the the FD01 jumper in correct position when software flashing, your ME never got overwritten/updated.

I have written the full firmware to a chip with the capsule file (using the USB writer and then swapping that chip in)… it still is in recovery mode that’s why I’m here now…do I need to set fd01 still?

I have the ikvm module it seems to work fine.

I’ll get a dump of my bios soon as I can here

Edit: I can’t find the fd01 jumper in the manual I have been using for the last week…I’ll inspect the board and see if I can find it

Edit 57: sorry I just woke up and didn’t process your reply fully. Reading the bios update pdf now.

FDO1 is on 2-3 not sure where it should be


Should be on 1-2

Good lord I have 4 cores…I can’t believe I have been beating my head against the wall for over a week on this.

I think original owner got confused on the Asus ikvm jumper and this board has likely been running 1 core forever.

You are amazing sir…thank you, thanks everyone, so much

Thanks for the feedback! Always good with an easy solution.