ASUS Prime B450M-A/CSM BIOS Help

Hi, I had recently got a modded BIOS for my ASUS Prime B450M-A/CSM motherboard and had tried everything to get Windows 7 on the computer, but every single time I change an option in the BIOS, Windows 7 blue screens like it did without changing the options or having the stock BIOS. I also have a AMD Ryzen 3 2200g With Radeon Vega Graphics, which I also heard that it might be the problem with installing Windows 7. I also have pictures of the modded BIOS so maybe it could help you determine what option I would need to set on the modded BIOS. I also tried to get all the menus that’d be relevant to change to stop Windows 7 from blue screening with the motherboard and processor.

@SamsungASUS - This is not my arena, but I looked around in google about this for you a little bit, and see it could be USB Driver issue and you need to edit your ISO
And or you also need to slipstream proper chipset drivers to your ISO too, this is most likely what’s causing the BSOD - What is the BSOD code, looks like >> 0x00000000…n-windows-7-x64
^^ Here, I considered same as “Potential Install Solution 1.3” myself when you first mentioned to me, but was not sure if move from Intel to AMD would be OK, or if you had second lesser AMD system to use, so I never mentioned…n-b450.3418455/…on-tool.249384/…ows_7_on_ryzen/

You were right all along. It wasn’t the CPU, motherboard, or BIOS, it was the USB drivers. Thank you very much for your help, man.

@SamsungASUS - Awesome, so you got it installed finally then, correct? If yes, great to hear
And you’re welcome of course, hopefully I actually helped you figure it out and you’re up and running in win7 now

Sorry for the late reply, but yes, I did get Windows 7 installed.