Asus Prime Z270-A UEFI problems

Please guys help me, I can’t anymore!

I try to made a modded BIOS with the last original version PRIME-Z270-A-ASUS-1203 with your guide and all of the UBU stuff. I updated everything into the BIOS without problems and the the problems begins… every tool I try say you can’t flash that! Than I find a way to flash it in recovery mode but something goes seems to did go wrong, the UEFI doesn’t show anymore all information like the Intel Raid version or the Intel Lan version and every time I boot before the boot screen shows two extra screens shows too, something with Raid and my Marvell card.

I tried and successful flash the original version for the Asus page but the problems are already there, I flash a old version of a BIOS but it does nothing change on the problem, I tried to clear the CMOS and remove the battery with no success. At the Asus UEFI I only can load optimised settings, but there is no way to reset everything to default.

My PC boots and “works” but after some time it crashs and shut down without any reason. I don’t know what to do, please help me! :frowning:

You can!! Don’t give up!

Before anyone can try to help, you need to better explain or show images, of these RAID/Marvell screens you mentioned. Do you use RAID, or Marvell device? If not, don’t update them with UBU, that solves those problems.
Disable full screen logo in your BIOS settings, will show more info during Post, maybe that is what you are missing from before? RAID version stuff will only be shown if you are using RAID, and if you are, only if full screen logo is disabled and or UI banner is enabled (Hidden BIOS setting most likely)
Also, you say problem with it showing “Something with RAID” and then after that say “it’s not showing RAID” clarification is needed there too.

Loading optimized defaults is setting everything to default, especially if you are using stock BIOS.

Were you using all the latest versions of the tools with UBU (Latest UBU, latest MMTool in folder etc)? If not, make a new BIOS again, this time only update exact things you know you use

I have a Marvell PCI express controller for more HDD drives, but this doesn’t boot anything, it’s just for more SATA ports for my old HDDs and the current modded Bios does not updated anything with Marvell.

Okay, let’s make it step one by one, maybe you or someone can say that’s the problem is or what I did wrong.

Use: [Tool Guide+News] “UEFI BIOS Updater” (UBU)

1. Download the latest version of the “UBU” tool for dev website and create a folder on my C: drive, use the MMTool.exe not patched into the folder and copy the original latest PRIME-Z270-A-ASUS-1302.CAP into the folder.
2.Currently the original Bios use RST which is a bit outdated, so I can update my RST too, the Bios runs also on RST because I sometimes use Raid (not currently). So I want to update it to (8086-2822_v15913271.bin rename to SataOrom.bin) at Files folder RSTe) to (8086-2822_v15913271.bin to RaidDriver.efi) both files from - AHCI & RAID ROM Modules and Intel EFI “RaidDriver” and “GopDriver” BIOS Modules
3. “Binary Modification Program” (BMP)
6. Tried to update RST files, UBU say, no files to update in the file folder, so it seems to be in the RST, not the RSTe, move the file and try again.
7. Works now Updated OROM IRST RAID for SATA to, but it did not update the EFI file…
8. Updated EFI GOP Driver SKL-KBL 0.9.1051 to 0.9.1080
9. Updated EFI Intel Gigabit UNDI from 0.0.13 to 0.0.19 and OROM Intel Boot Agent CL 0.1.10 to 0.1.13
10. At Point 4 “Other SATA Controller” nothing happens
11. CPU MicroCodes: Asus seems not to do very much to fix any issues with the problems, I already tried both ways, do nothing with the Microcodes and patch the issues, nothing has helped me the last days with my Bios problems so it seems not important. In this case I will patch it and choise “c” the UBU recommend me MMTool, so I will use it.
12. The guide say nothing about “AMI Setup IFR Extractor” I did it last times, but not this time. Maybe it change something.

If I did everything right my modded Bios is ready to flash? Ok, now I try it. I also check [Guide] How to flash a modded AMI UEFI BIOS, but the “AMIBIOS and Aptio AMI Firmware Update Utility” isn’t available anymore to download and I tried the ASUS AI Suite but no one works with Bios Update…

It’s not about what’s wrong, more I was trying to get you to avoid updating things you are not using (especially since they are what you are having issue with right now).
Do you use RAID? If not, don’t update. Sometimes RAID? Hmmm, well then I suppose update it [;augh]
Marvell is only used for storage, and your off-board PCIE Marvell controller does not apply to any BIOS changes/updates = don’t update this either. Now, both of the main issues you mention are solved

These UBU questions will have to be asked at SoniX and in the UBU thread, I don’t use the program for updating often so am not familiar with what files need to go where in regards to SATA/RAID and what formats those files need to be in (With headers, without, etc)
I can say you shouldn’t be renaming a bin to efi likely that is not correct file or it would already be the extension you need to use.

Step 12 is for flashing mod BIOS, if you can’t, which you already can do, so you do not need this.

I cannot follow along, too many links/images and some do not work. On your last sentence, you said in your first post you already flashed modified BIOS once before, correct? Or have you never flashed modified BIOS?
If you have never been able to flash modified BIOS, then how did you get “New errors” you mentioned with RAID/Marvell?

Please explain at the end of your next post, in few short sentences, your main issue here. Do you need mod BIOS made, seems lots of errors mentioned so likely, or do you need to know how to flash mod BIOS?

For me it was the first time trying to work with a custom Bios at UEFI/Motherbords on Windows. But after the last days now it’s gone for me and I can say, it was enough fun for me.

I reset everything, flash older original Bios versions, clear CMOS, clear battery and than I flash the latest original Bios back. But that was not enough fun…

Changing back from the RST Raid Driver to AHCI was not so easy. It runs now as “Intel(R) 300 Series Chipset Family SATA AHCI Controller” with

But then there was my OS SSD (Samsung 860 Evo), it drives me crazy, something change the cluster_size and I had to rechange it without losing data.
My OS SSD has now:
500MB Recovery OEM (Cluster_Size 512B recommended)
100MB EFI OEM (Cluster_Size 512B recommended)
16 MB Hidden (Cluster_Size 512B recommended)
460GB OS (Cluster_Size 4k recommended) was wrong set to 512B

So, my Bios runs at the moment without any problem, I don’t try to made a new modded one, I will wait for a original new one or if there is no one there is time to update the hardware anyway.

This should help next time you switch RAID/AHCI - Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0


Good you are back in running order!