Asus Q470 & Q570 WiFi issues after CSME update

hi, i install 14.1.65 1969 COR H A firmware and have problem with wifi in AMT (radio state is unknown allways) and MEinfo64 tell “wireless micro-code mismatch - yes”

motherboard Asus Q470M

This is an ENGLISH forum ONLY.

CSME System Tools v14.0.11- r1.rar
CSME System Tools v14.0.20+ r20.rar (This one should be the version to use with your 14.0.60)
CSME System Tools v14.5 r7.rar

We dont know the ASUS model… if the bios of the system has by default in latest bios FW15 you will not use any 14 to clear ou build with FIT.

CSME System Tools v15.0 r15.rar (For the provided ASUS 15.41.2142)
CSME System Tools v15.40 r3.rar

Procedures MUST be read on the top of the thread, no reading no learning, fail is a sucess then…

FPT -greset as an optional to see if the FW gets re-initialized.
If not use MEinfo to check status and paste here.

So you have an issue in WiFi with the Asus Q570 after Asus provided you with the latest FW file… and of course, this is because you explained all this to Asus support.

Again… use the MEinfo tool to get detailed info on the ME FW status (Sry you already posted it)
or do as you want…want to clean it? Clean it then: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization - #434 by thanhluan119

Or wait for another user opinion or thread owner (plutomaniac AKA The Boss)

Still as we dont know the CORRECT motherboard model…does it have USB BFB option?
A last resource option is re-programm the SPI and incremental bios update to the last one as a possible way to go back in FW version…some bios versions are advertised to NOT going to old versions…

You asked ASUS for an ME region for your system…they answered NO, …expected.
As ME region usually on desktop boards, are included in bios update files and they dont do remote support service… Oh i want to fix it… no no no, return the product.

Good luck.

We would need the files to have a look into the configuration- since ME 14 can’t read the config from ME region only it’d have to be the complete firmware images!

Then we need the hardware- processor, board (Asus Pro Q470M-C/CSM??), lan card, wlan card (chipset, vendor, model).

And in addition to your own english text you might write the text in your own language and run it through google translate and copy it into your thread in addition.

Asus Pro Q470M-C/CSM (vPRO)
10500 i5 (vPRO)
ax210 m2 999lwx (vPRO)

Im go back in shop for rollback firmware in service center… (14.1.65 AMT not show Wireless settings in web :16992 and after perform official update i have this “wireless code mismatch-yes”. reset bios and reset amt not help me).

if i verbose update - have error 0x00, but success update, screenshot not have sorry.

Well, vpro isn’t enough for WLAN Cards- it has to be the right model since there’s a µcode in the ME- firmware that has to support the WIFI adapter and it might be that AX210 is too new…

Both Q470 and Q570 product brief mention only AX200 and AX201:

AX210 / AX211 are mentioned for Q670:

no way man, i know on 100% is 14.1.53 COR H work is fine in this build (pc)…

Which 14.1.53- there are at least 3 different? And that’s not very likely- WIFI firmware version seems to be the same at least from 14.1.53 to 14.1.67.

But anyway- this board has socketed SPI chips, FD, ME and start of bios region on 16 MB chip, rest of bios region on 8 MB chip. Would be easy to restore to a working version? Latest stock bios is still on and is a complete image.

i dont know how…

Download the CSME System Tools v14.0.20+ from
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)
(You probably still have them since you used MEInfo)

Run …\Intel CSME System Tools v14.0.20+ r20\Flash Programming Tool\WIN64\FPTW64.exe -d spi.bin
That will give you a complete backup of the current firmware (24MB) without programmer.

Check the type of the two bios chips, especially if they’re 1.8V or 3.3 V type

Buy a CH341 programmer and a 1.8V adapter if those chips are 1.8V type

Buy an extra set of these chips, they’re normally cheap on bay. This way you could leave the original chips untouched.
If you don’t care use the original chips after having dumped the original firmware with ftpw!!

Take a stock bios, cut the capsule 0x0 - 0x1000, resulting file is exactly 24 MB 0x0 - 0x17FFFFF

Flash 0x0 to 0xFFFFFF on the 16 MB chip, flash 0x1000000 to 0x17FFFFF on the 8 MB chip.

If you may be ready to simply continue with the ‘new’ firmware you might transfer the board specific data:

  • MAC Adress and some settings for the LAN card are in GbE region

Serial, UUID, MAC in bios region:

  • ASUSBKP 0x964000 in padding
  • 8C8CE578-8A3D-4F1C-9935-896185C32DD3 - SMBiosFlashData - Raw section

If you’re not sure if you prepared the stock bios correctly attach the files here.

oldest 14.1.53 have support wcod ax210, after not (14.1.65+)

1 Like

on Q570 ax210 worked fine… and in firmware have wcod 0x2725, but Q470 worked only on 14.1.53 firmware, after not work (14.1.65+) screens above.

Nice find!

So either Intel excluded some firmware from later updates or it made a newer firmware that no longer supports older devices.

The CSME firmware files do have one firmware set in the WCOD partition and as set of firmwares after the last partition. But structure is unknown to me and even if one could transfer an older WLAN firmware to a newer CSME firmware file the results would be unpredictable. In addition the fixes for later versions might include firmware fixes, too.

Q570 is ME 15, Intel may or may not continue to have this firmware in coming CSME updates.

Since all this is within specs- they never promised these devices to work with Q470/Q570- there’s not much one can do…

Try the attached file for the 16 MB chip. The 8 MB chip doesn’t need to get updated- static bios region only. (8.0 MB)

Thank You Bro, i restored all my boards (Q470 and Q570) with ch341a from Your guide :slight_smile: .