ASUS R500VD shutdowns every 30 min and BIOS entering problem

My laptop is an ASUS R500VD, is shutting down every 30 min exactly since fews days ago, and it won’t boot to BIOS (I tried both methods: by windows or keyboard at start).

Motherboard: ASUS K55VD
Intel HM76 (Panther Point)
BIOS: K55VD.305 - 06/13/2012
CPU: Intel Core i7 - 3610QE
ME version:

I am now under Windows 10 (originally Windows 7).

I tried to follow this guide, to re-initialize the ME data, but I was unable to achieve it.

I don’t know how to be able to flash the dumpted ME image because the command FPT -f give the error: “could not communicate with the HECI”. (I was able to dump it without error).

MEinfo gives me an error too. I send you the result of FPT -i command.

I don’t know if I have to update the BIOS first, or if there is an other way to fix this problem.

Thanks for the help!

Were you able to get a complete dump of your firmware? What did you use as a base for the cleaning process?

Yes, I think so.
I use this dumped image as a based for the cleaning process.
I send you what I obtained in the cmd board:

I obtained the same when I dump the full firmware.

I’d recommend working on a full spi dump (fpt(w(64)) -d spi.bin instead of working with a region for the cleaning process. Anyway I recommend to dump the complete bios to have a backup- Asus bios update does only contain the bios region.

Your flash descriptor seems to be unlocked, so that shouldn’t be a problem. Create a DOS USB stick and try the dos version of fpt, it’s independent of the Windows driver installation.

Thanks for the answer.
I’am now working with a full spi dump (it includes GbE Region, is it normal?)

I tried to run the dos version o f FPT, but I got the same, when I try to flash the spi image:

PDR Region does not exist
Could not communicate with the HECI

Might be possible to use the standard flashing tools, they might have a switch to overwrite ME, but it’s unpredictable hoe they will work.

I’d recommend a CH341 hardware flasher.

Regions of the firmware you’ve seen in one of the pictures: FD, GbE, ME, Bios


Thank you very much for your help.

My problem was solved, although I didn’t understand exactly how.

After trying to run FPT under DOS, my computer worked normally again, and in fact, the FPT -f command under windows did not return the same error as before.

I don’t really understand what happened because it happened before I could flash the reinicialized BIOS image (and I didn’t do it, since everything was back to normal).

The only change was to disable the fast startup of the computer, to be able to enter the BIOS, and even after re-enabling the option, the system is still stable and now works properly.

Maybe it was a ME driver startup failure because when I had this problem, I didn’t see “Intel Management Engine Interface” in the device manager, nor in the HWinFO64 program.

Anyway, I’m glad that my computer is back to normal.