ASUS Rampage V Extreme - Corrupted ME

Hello and a Happy New Year to all. I came across this interesting forum, since I have an unsolved and longterm problem with my hibernation. As a last attempt I have performed the upgrade oft he IME firmware that is described in this thread. However, something must gone wrong while the update.

I started with: Windows 10, ASUS original BIOS 1701 and IME FW version H
1) I have updated the ASUS BIOS with the firmware file from SoniX in post # 73 - no problems have occurred and continued with the BIOS defaults
2) I used “Intel ME 9.1 Consumer 1.5 MB Firmware v9.1.37.1002” and “Intel ME System Tools v9.1 r7” to update the IME. FWUpdLcl reported a successful run. The problem began with the reboot.

1. System wont boot, after switching on a black screen with error code 79 occurred
2. I was lucky to get the system up with multiple CMOS resets and a removed CMOS battery
3. Windows 10 started, but IME device disappeared, AI Suite did not start, because there is no IME device
4. BIOS reported FW Version: N/A

I copied BIOS2 to BIOS1 - because I thought it is my insurance. Since then, the system seems to operate normally. But MEManuf reports some errors. (see attached file).
I’ve tried every consideration from this thread / board, which gave me a hint to try. I extracted the ME region of the original firmware from ASUS to do an upgrade with the same firmware build. But, I could not believe:


Tried serveral times, but FWUpdLcl crashes ervery time.

I need help now and I am grateful for any assistance in order to solve the problem.
Thank you in advance,

MEManuf-output.txt (2.55 KB)


You’ve a corrupted bios on both chips. The copy BIOS function is buggy and I had a similar issues few months ago and I fixed everything reprogramming the bios chips
with an eeprom USB programmer (like the EZP2010) and the ME FW appeared again in bios info and no more qcode 79 or similar errors.

Where are you from ?

@ Themot63:

As seen by the MEManuf report, the ME is corrupted. The whole ME Region needs to be replaced. FWUpdate only deals with the CODE (core, “version”) and not DATA (oem/user settings) sections of the ME firmware so it’s useless now. Extracting the ME firmware from the latest Asus SPI image is correct but you need to flash it via Flash Programming Tool (with a special parameter when the flash descriptor is unlocked, more info later) and not FWUpdate. To possibly avoid using a hardware programmer or the almost-impossible-to-perform “pinmod”, first check if your flash descriptor is locked. Use Flash Programming Tool with the command fptw -duplock and post a screenshot or alternatively fpt -d spi.bin which should not show a “cpu access” or similar error but rather produce a full 16MB file called spi.bin.

By the way, I moved your post at the correct subforum and renamed it as this is basically ME and not BIOS related.

I am from Germany.

Can’t get a dump from fptw64 -D SPI.BIN.



Thank you for any help.

EDIT: I also followed the recommendation of Sylar76 and have read through this thread (Help Wrong version update of Intel ME need to update back the good one (2)). I do not have any experience to perform a flash programming with a SPI programmer. I’m not sure that I get it to work. Hope we find an easier way to recover the ME. I found at a BIOS-chip for the Rampage V Extreme. That could be the last option.

The Flash Descriptor is locked so you cannot normally use software flashers to fix the ME problem. Your last resort before using a programmer or replacing the chip is to try the “pinmod”, instructions for which can be found here but the success depends on how easy it is to perform the sorting at the sound card chip of your board. Try it first and test with -d spi.bin command. If you are able to dump a full 16MB image you are good to go. Extract the ME region from the latest Asus BIOS with UEFITool (name it for example ME.bin) and flash via Flash Programming Tool using the command fptw64 -rewrite -me -f ME.bin followed by the command fptw64 -greset.


if I am right, the pinmod is not so easy to do. The EMI protection covers the audio chip and is soldered to the mainboard. Before I damage something on the mainboard, I ordered two new pre-programmed bios chips and to be sure for the future the hardware programmer mentioned by Sylar76, too. This is much cheaper compared to a new Rampage V.

I will not give up to try it with a newer ME firmware. To learn from my mistake, what have I done wrong? Your support has helped me. Thank you.


Ah, if your sound chip has an electromagnetic protection cover then you shouldn’t mess with it and performing the pinmod is not possible. Maybe ASUS placed a jumper somewhere else at the board to transition the ME into Recovery mode or a BIOS option so that their field technicians can fix such issues but I doubt it’s there on Consumer boards. Anyway, replacing the chip (or reprogramming it with a cheap hardware programmer) is the only way to repair the ME. Based on what you said, you didn’t do something wrong. Maybe you were unlucky of FWUpdate encountered some issues. Does it crash if you try a “safe” command such as -save me.bin for example? It may be that some Windows program/process is interfering with it. By the way, this board has 2 BIOS chips. You can switch to the other one in the meantime to avoid any issues due to the corrupted ME firmware inside the 1st chip.

You’re right. There is something suspicious. “FWUpdLcl64.exe -SAVE test.bin” freezes and do nothing. After 15 minutes I cancelled the operation with Ctrl-C. My next try will be with a DOS bootable USB-Stick. I did not touch the 2nd BIOS, but MEManuf reports me the same error. It is like Sylar76 mentioned in post #3.

I don’t know what this “copy” mechanism that ASUS has is exactly but it shouldn’t matter either way. The ME Region is different from the BIOS one. The SPI chip has separate regions for Flash Descriptor, GbE, ME, BIOS etc and the ME region is usually locked as far as reading and writing is concerned for security purposes. Copying the one chip’s BIOS Region to the other chip’s BIOS Region won’t move and thus fix the corrupted ME region of the former based on the equivalent ME region of the latter. If you try to switch to the 2nd SPI chip, you should have a fully operational system with MEInfo & MEManuf reporting ok. Either way, as you said it’s best if you use the EFI or DOS tools for now since there may be something interfering at Windows. Prime candidates are overclocking, hardware info and similar utilities. These usually communicate with the ME to get the info or adjust clocks so if they are running at the same time as the ME tools there may be severe consequences. Now that I think about it, you asked what you did wrong. If you had any Windows overclocking or hardware monitoring programs running at the same time as the ME firmware flashing, there is a high chance that’s what caused the corruption. Make sure you have closed any background programs next time or update via an EFI or DOS environment.

I currently boot with the second and unchanged BIOS. But the problem with MEManuf is the same. Also under DOS and since the beginning with BIOS default settings. This suggests a guess that even before my attempt something has not been correct. The computer behaves with BIOS2 now as usual, including my hibernation problem, which I really want to eliminate. The hardware programmer and the new chips come tomorrow hopefully. Then I will go ahead.


I am glad to tell you that everything is fine. Rampage V runs with SoniX Mod and the ME version H. I have programmed both chips with an external programmer. The hibernation problem is also solved. Thank you for your great help.
Greeting from germany