Gday, folks! Fighting with my laptop for a quite long time so, this forum is last instance for me. The story started after I did an m.2 ssd card upgrade in my laptop (there was an 128G SanDisk in stock). I’ve got an 256G XPG SX6000PNP drive, and it worked properly for about a month. After I’ve found out my laptop battery is dying and I’ve decided to remove it to prevent damage can be done by improperly working li-po battery. So I’ve removed a batteryback and made some playing with bios setup on a matter of secure boot disable to check some OS drivers working or not. After reboot the NVMe item disappeared from BIOS setup and was no boot option concerning NVMe drive. I’ve set options back, made an bios updates, settings reset - nothing helped, so I thought SSD drive is broken somehow. After putting it to a desktop PC it was successfully recognized and working properly. So I took another SSD drive an 128G XPG SX6000PN and it recognizes by a laptop properly. Again I thought an 256G drive is damaged, so I took the same 256G XPG SX6000PNP from another working PC and installed into a laptop, and again no drive recognized. I’ve checked a connector, since sometimes bios showed the drive up (very rare), but after reboot the story repeated. So I’ve tried the NVMe driver injection into a bios as was mentioned in this forum and tried to boot with UEFI-prepared Windows10 USB stick, and again no luck. I hv no other options to investigate, so asking for help.

@elected :
Welcome to the Win-RAID Forum!
If the NVMe SSD worked with the original BIOS, it was not a good idea to integrate an additional NVMe module and to flash that modded BIOS.
Since you obviously played with different BIOS variants and BIOS settings, I suspect a not correctly working BIOS variant or a wrong BIOS setting as reason for your troubles.
This is what I recommend to do:
1. Flash the latest original BIOS (provided it natively supports booting off an NVMe SSD).
2. Enter the BIOS and set everything to “DEFAULT”.
3. Disable the “Secure BOOT” and “Fast Boot” options and make sure, that the BIOS supports booting in UEFI mode.
4. Try to boot your PC.
If this should fail, boot in UEFI mode off an USB Flash Drive containing your Win10 Image and choose the “Repair” option. If this should fail as well, try to install Win10 from scratch.

Good luck!
Dieter (alias Fernando)

I’ve tried a lot of options, flashed older BIOS, the same as was, made loading defaults, made ssd secure erase on other PC which recognizes it’s properly, left no options to try

In this case it is not easy to give any advice.
Have you already tried to remove/unplug all other disk drives except the NVMe SSD?

Yep, the thing is that other XPG SX6000NP works properly, and XPG SX6000NPN - is not, and there is no way to get an drive firmware updated from ADATA (I’ve requested via support ticket). Hd some thoughts, can’t it be concerned with NVMe versions, or maybe some PCIe options disabled