Asus Rog Zephyrus M16 GU603HE BIOS Reprograming

Hello, I have Asus Rog Zephyrus M16 2021 GU603HE.
I usually left open my laptop. Last month when I entered the room, I noticed computer was in bios and will be upgrading it bios version in 30 second.
I rushed it and held the power button because I don’t want it to be updated. After 5 seconds bios update started and in the 6. second computer shotted down.
After this moment nothing comes the screen. Keyboard lights are on and fans are spinning.

I bought CH341A and manage to read the bios chip. Made few changes, tried different things and reprogrammed it but nothing’s changed.

Can someone fix the corrupted bios image?

It was upgrading from version 315 to 317.




Try: (8.5 MB)

Didn’t worked.

Is this dump from your first post the first one you saved or did you work on it?

I didn’t work on it. But I noticed something strange.
I compared that person’s bios with my bios. That has total of 10 serial number but I have 22. I don’t know If this makes any difference.
Note: My model number is GU603HE, that guy has GU603HM and has different configuration.

Your corrupted firmware on the left, the HM firmware on the right just for comparison. The part between the ‘315 OK’- parts is messed up in a funny way:

Look at the structure. Unfortunately the update files contain different versions of the EFI volumes:

The end of the volume 3DA4… and the volumes thereafter are identical to the first set of volumes in the firmware update.

I’ll have a look into it tomorrow.

Thank you for your efforts. I will be waiting.
I am hoping that you’ll find a way to fix it.

You wrote that you didn’t work on it but I see that the serials are replaced with the same pattern ‘that person’ used??

I only changed the serial number and short serial number with that pattern. Because I didn’t want to share it on the Internet.
So my serial number is 1F 2F 3F 4F 5F 6F 7F 8F 9F 1F 2F 3F 4F 5F 6F and short serial number is 6F 6F 6F 6F 6F 6F 6F 6F 6F 6F
Except that I didn’t change anything.

Well, that’s not “I didn’t work on it” What do I know about your editing skills and in addition how this firmware might react to these changes?

You might want to try this image- make sure the flash is valid by double checking the content of the chip after flashing and comparing it to the original file! Flash the file without any changes. (8.3 MB)

I did edit like this.
You did say don’t make any changes but where should I put the serial number? I couldn’t find the correct place.

I managed to fix it thanks to this video.
I did what the guy did. And it came back to life.

Can you upload the final version of the working BIOS gu603he ? I have the same problem. Thanks .

Hello, It was one time account. So I created new account to help you.

Send your BIOS and I will try to fix it.

First of all I do not guarantee anything. I am not an expert. Try this at your own risk.
If it does work or doesn’t work please come back here and tell me.

OK, I’ll try, thanks.

Unfortunately, the firmware did not help. The black screen is also turned on. Maybe the problem is that my BIOS was gu603he.30a , but on the ASUS website , only the 15th and 17th versions are updated ! It has already been sewn before me , perhaps on the contrary , you need to sew up the 13th version of the bios, it is 2021 .
You can share your BIOS dump, you can do it without a serial number, which is working, with a clean ME region, I’ll try it.


Your dump:

  • NVRAM corrupted- data in padding, upper lines (3) from guid store in padding:

    (This should be fixed with replacing the bios- region with a stock bios- region as done by cansu1)

  • Possible corruption in ME- region, FIT doesn’t open the image.

Static areas in your bios- region are 100% identical to 317 stock bios.

Machine specific data are in the padding after NVRAM (0x560000 to 0x56FFFF)

Try (8.3 MB)

This is GU603HE.315.rom from my last post but with the mentioned padding with your machine specific data copied in. Stock bios- region 315 with a cleaned/ re-initialized ME (version from 315 update). Machine should boot with this image or the one from the earlier post (machine specific data aren’t needed for booting).