Asus Sabertooth Z-97 Mark 2 RST setup

Now that this site has helped me so much to get RAID set up on my spare computer, it’s time to get a few things fixed up on my main machine.

Since I performed the Win10 upgrade last year, the Intel RST application has never performed as it used to (RAID1). While both HDDs appear in the Storage System View, the main screen reports "Your system is reporting one or more events, and data may be at risk."

I’ve gone back to BIOS several times and tried combinations of AHCI and RAID. Additionally there is a setting for this Asus MOBO that appears to invoke RST, but any changes that I make only prevent a proper boot-up to occur. Usually I get the Win10 :frowning: BSOD, and I go back to the original BIOS settings to overcome it.

I’m left to wonder if there is an incorrect driver, since RST drivers appear to have been at the root of my problems on the other computer. Any help is appreciated.

Which Intel RAID driver version is your on-board Intel SATA RAID Controller currently using and which Intel RAID module versions are within the BIOS?

The device manager reports "Intel(R) 9 series Chipset Family SATA AHCI Controller", and the driver version is

Is anybody able to tell me more about this predicament? I guess the question is whether there are better drivers or RST applications for my system that would overcome the problem I’ve described. Many thanks if you can help.

@Guswah :
Since your Intel SATA Controller is currently running in AHCI mode, I recommend to do the following:

  1. Run the “Add/Remove Software” section of the Control Panel and look, whether the software named “Intel Rapid Storage Technology” is currently installed. If yes, uninstall it.
  2. Download the 32bit resp. 64bit Intel RST(e) AHCI/RAID drivers v14.8.12.1059 WHQL from >here (section I. B.)< and manually install them from within the Device Manager by doing a right click onto the listed Intel SATA AHCI Controller and choosing the options “Update Driver Software…” > “Browse my computer …”, then click onto the “Browse” button and navigate to the unzipped downloaded driver > “OK”.

I generally do not recommend to install the Intel RST Software for users, who are running their Intel SATA Controller in AHCI mode.

I absolutely want to run it in the proper mode. If the AHCI mode is not where I should be, then I will try again to change it. I only pointed out that when I made this change on an earlier try I got a Win10 BSOD. If there is something else that I should try to overcome this and get me into the proper RAID mode, then I’d be happy to try. Suggestions?