Asus Transformer T101HA bricked - Preparing to flash CH341a

Hello Win-Raid Forum. I love your forum and the amount of useful information available at all times.
Unfortunately I bricked my Asus Transformer Book when trying to modify it to boot from the SD-Card. Now it is stuck on the Asus logo and have tried everything from holding volume buttons while powering it on, ctrl-home with an USB with different names of the latest Asus bios, with no luck.
So I am getting ready to flash the Bios. I already purchased the CH341a programmer (on its way) and the heat gun, in case I need to de-solder the chip.

My chip is a Windbond 25Q64FWIG which is unfortunately a WSON8 6x5, so I hope I will be able to use the clipper that comes with the CH341a. I also purchased an adapter for WSON8 (also on its way) eventually.

In any case, I hope you guys can help me proceed in the right way, so have some questions:
- is the latest BIOS file (from Asus website) enough to flash the chip? (before I bricked the notebook I had disabled the SecureBoot and was in Legacy mode, in order to boot from USB or the SD card)
- otherwise, do I need to modify it in any way? UEFI or similar?
- is there anything else that I could do to make sure that the flashing runs smoothly?

Any kind of help and suggestions will be highly appreciated!

I can only help with the 1st question. Unfortunately, no, ASUS provides an encapsulated BIOS region only, not full SPI image. You’ll have to dump your own when you’re able to use the programmer.

Does that mean that I need to read it and save it in order to modify it before writing it back?

Yes exactly. Either way though, as a rule of thumb, you should always keep a backup of your current SPI firmware before performing any changes. If the problem is at the BIOS region only, it might be as easy as replacing your own BIOS region with the stock one from ASUS (after removing the AMI Capsule) but you’ll know only after having access to the in-chip firmware.

Thanks for replying plutomaniac. I am still waiting for my purchased WSON8 adapter to arrive, so haven’t had the opportunity to dump my BIOS. I unsoldered the chip with my heat gun, but without it I cannot read it on my programmer.

In the meantime I found this, which seems to be a reconstructed full SPI image (attached).
Can I eventually use this image if for some reason I cannot get a full one from my original chip?

If so, which information needs to be replaced in order to use this image?

Thanks again!


Hello, I finally received the adapter and could read my BIOS. Here attached is the dump file. I saved it with CH341a Version 1.18.
I have extracted the Bios Region from the Asus stock and replaced it in my dump file. The result is the xxxx.rom file attached.
Can you please help me to understand if this could work after reflashing my chip?
Is there anything else that I should check?

Thanks sooo much for your help!

Asus T101HA Original BIOS CH341a (3.79 MB) (3.79 MB)

Ok, the xxxx image is what I was talking about, meaning your SPI dump with only the BIOS region replaced with the stock ASUS one. I suggest you also unlock the Flash Descriptor (read/write access to all SPI chip regions) so that you can use software flashers (i.e. Flash Programming Tool) in case you need to re-flash something while this issue is being resolved without being forced to de-solder again and use the programmer. To unlock the FD, change the bytes starting at offset 0x60 as such:


Thanks a lot for the advice!
Unfortunately I haven’t been able to solder back the chip on the motherboard. For some reason the central pad under the chip has been extremely difficult to solder with my heat gun. After some minutes of hot air (with the nozzle, different temperatures) there is no way to solder it and it comes off by barely touching it after it is cold. Have tried EVERYTHING; with flux, refreshing with new tin, different temperatures, etc.
Amazingly, when I soldered it on my WSON8 adapter it was extremely easy with the heat gun. Instead, on the motherboard …no way. It may be the motherboard probably dissipating too much heat (??)
BUT, for my extreme frustration, some components (I believe diodes) on 4 of the pins have de-soldered and got lost without me noticing it!!!
Now I have no choice than to scrap the complete tablet!!

They are so minuscule that I didn’t realize it was happening. Even while using my magnifying glass.
Hate to abandon the project so easily, but I believe I have no way to replace the components missing.

Love your forum and the availability of information it provides, and specially your availability to help.
Thank you!

It’s unfortunate this happened. Second such case (user has everything ready, soldering back fails though) this week. At least you tried though and learned a thing or two in the process. Maybe someone at a specialized repair shop can fix it now but I doubt it would be worth the effort and cost. Either way, thank you for your kind words. :slight_smile: