Asus X99 Deluxe Bricked in an act of stupidity


I was messing around with my asus x99 deluxe, to exploit the haswell microcode glitch. In my search for different microcode versions for ES Xeons i downloaded alot of different Bioses from multiple boards. After extracting the bios from the .cap files i didn’t really kept stuff organized and ended up flashing a Asus Maximus V bios to my chip (via spi flasher).

Well the board booted up to a “updating bios” screen and rebooted to a black screen… Never had this kind of behavior before so i checked my files and noticed where i messed up. After flashing the X99 Deluxe bios again the board only posts back to the “updating bios” screen and is stuck there. I pulled data from all the chips on the board i could access with my flasher and noticed the firmware chip from the 2nd Lan controller was empty (the maximus board only has one lan controller). So i guess i have a whole lot of wrong firmware on a lot of different chips and bricked the board to a point of no return. I feel really stupid right now… Also i didn’t knew a Bios update would have an impact on onboard controller firmware outside of the bios chip itself. Don’t be as stupid as i was, keep your stuff organized.

It could be the LAN Chip dump was empty due to wrong version of software used to dump it, or simply not compatible with that chip using any version, I’ve seen plenty of empty dumps when users try to find correct software or chip ID to get a dump (FF’s or 00’s both)
So like you, I don’t expect a BIOS update/reprogram would affect some other chip, and think this one is probably fine. Even if it’s not, it should not cause a non-boot situation, only failed LAN

Do you not have an original dump from before you started with the programmer? If yes, program that back on and you should be fine. For programmer, make sure you are not programming an encapsulated file, even if named .bin.
I’m sure you know that, but mentioning just in case you overlooked it in a rush sometimes and for anyone reading later. BIOS downloaded from Asus is not a programmable BIOS, even after you remove body/bin from the capsule, this is incomplete partial BIOS update only from Asus (Missing FD, ME, GbE (If used))

If you do not have an original dump, I’m sure I can find one for you. In this situation, you will need to gather your board details from the stickers on the board for serial, UUID and LAN MAC ID (DTS Key will probably not be on the board stickers but maybe we can re-create it)
Be sure to look on sides of 24 pin, and top/bottom of PCI/PCIE slots for stickers too.

There are 2 LAN-controllers on the board, near the controllers are 2x p25ld512, i got the dump from the first chip which had firmware on it the 2nd chip was blank. Also there’s a chip for the build in Flashback function, this one seemed unaltered because it still had the backup filename as X99D.CAP (name for the deluxe rescue .cap) written in it. The Flashback button has no function anymore, no matter which bios is flashed.

I have an original bios dump but it doesn’t change anything on the behavior either. Also i forgot to mention: the board doesn’t post at all if i just press power on, i have to mash the memory try and the cmos clear button to get it to post. If i don’t do this it’s just stuck at error code 76 and has a red CPU LED. Other people with the same problem (due to other reasons of course) only found the solution to RMA their boards.

When the board posts to the bios is updating screen the error LED-panel shows A2 (which is normal when it’s running) and after a few minutes switches to 70 (PCH DXE Initialization started) and from there on it’s stuck (keyboard num, caps and ctrl+alt+del is working so it’s not frozen).

So you got valid dump from same chip that gave empty dump? Did you confirm it’s empty by re-dumping, in case of loose cable or other glitch during first dump attempt?

Does this board have dual BIOS, and a switch to make single? If yes, program main and backup with same original dump, then put switch on single and see if that helps for now. Are you sure your main backup image is OK? If you are not certain, upload and link I’ll take a look and see if it looks OK at a quick glance.
When you can get into the BIOS, or can you (?), does ME show up as a version number, or N/A or

On the current LAN situation, have you tested programming the blank chip with FW from the first? If they are both same controller type this should be OK, but you may need to fix the LAN MAC ID first or afterwards.

You may have to try and find a dead/damaged board on ebay to copy/find original chips data from, that might be only way to fix this. Were you only writing to the BIOS roms, never to the others?

Yes they are the same chips, i checked the 2nd chip multiple times and took a few looks that i really identified pin1 correctly but it was empty. I flashed the LAN firmware to the other empty chip but that didnt get me any further. I don’t think thats my problem, but i do think it’s proof that the bios flash altered the other firmware on the mainboard.

My X99 Deluxe doens’t have a dual bios. The Maximus V, where the wrong bios came from, does have one. This is currently my explanation for the weird method to get it to post.

I can’t get into the bios, the screen with “press del to enter setup” comes up, but i can’t enter the bios because it switches to the updating screen immediately afterwards.

If i grab a dead board from ebay and the problem is some firmware issue outside of the bios chip, it’s not much of a help either i think.

You can grab my save file here…x99sav.bin/file if you want to take a quick look over it.

And thanks for your help!

BIOS flash shouldn’t have done that, but since you cross-flashed I suppose maybe it’s possible it erased it trying to do something (it wasn’t trying to write in FW, since that would not be part of a BIOS image)
I doubt it’s anything other than these FW causing the issue, so I think if you can find a damaged one cheap it should help you get sorted back out.

BIOS looks OK at a quick glance, checked ME FW with ME Analyzer, and compared to stock in UEFITool NE and all parsing looks the same.

Can you show me some images of your board up close? I see some reports questioning why there is two BIOS chips on this board, one removable and one not, maybe we need to identify the other backup BIOS soldered to the board and update it too

You’re taking my only explanation why my board is messed up after that stupid flash. If it’s not any FW outside of the chip i’m completly clueless.

There is a 2nd Chip is near a pcie connector, i thought it could have something todo with it too, but it’s a 24c02 holding only 256 bytes. It’s responsible for the bios flashback. I had to desolder and resolder it to read it (couldn’t get a soic8 clip on it because of the pcie slot). I read the same Post and started searching for any other chip may containing a 2nd bios (or parts of it).

this is the content:


I’m only offering my thoughts, and yes I considered what you think too, only trying to help. Are you sure you got all desoldered chips back on fully?

Did you lookup that chip ID with the 256byte dump, was that it’s full size?
The “Second” BIOS I was mentioning would look like your normal Winbond or MCIX SOIC8 chip, if there is one (Maybe only some early revisions of the board had this, I could not find in reviews)


I know, i’m not trying to lose the only help i got, it’s just the only explanation i’ve got for the problem. Yes the flashback chip is fully soldered on again, flashback didn’t work before un-/resoldering and doesn’t work now.

I searched the whole board for flash chips and i only found like 5 flash chips (without the removable bios chip i flashed a bunch of times), 2 were from the LAN controllers, 1 from the flashback and 2 preflashed chips for RGB control (didn’t even dump these after looking up the datasheet). I unscrewed every heatspreader and plastic shield, nothing hidden unveiled itself.

What is that flashback chip ID, 256bytes doesn’t seem like it would be the entire chip, and even if only that much data on it dump would be total overall size.

Maybe best bet, I see some sometimes sell for 5-10 less, but this seems average price (around $35 shipped) -
PSU killed it, probably only VRM/Voltage controller, or really probably only overvoltage protection blown out since that’s it’s designed purpose to protect everything else in those situations.

One year later and i took the board of the shelf and gave it a shot again.

The Problem is the Asus embedded Controller Firmware, which is updated after first start from the UEFI (ECUpdateFramework module name). The Chip is a MCU with firmware probably saved internally, theres zero documentation for these chips whatsoever. They’re probably accessible via i2c, but i’m most likely not able to reflash them. I’ll try to find the firmware in the bios and look again for EEPROMs or SPI chips that might contain it, since the ECUpdateFramework contains a list with chips.

If i’m not able to find reflash the MCU firmware i’ll try to kill the ECUpdateFramework in the UEFI and test if the board works with bricked MCUs (not even sure if they’re bricked or just have the wrong firmware now).

The 2 EEPROMs near the bios (one at the back) have the Boardname, recovery .cap name and bios ID saved, this is just a security check for the Flashback function.

Just thought i leave some info here since this problem seems to occurs more often, even now on asus X399 boards.…IOS-is-updating

If that is the problem (MCU FW), and it is on another chip, then the problem should be OK if you find the right BIOS that works with that FW on those chips at the time (unless they are blanked, which I would doubt)
From the thread you linked, last post, it looks like he found solution by using the older BIOS, in his case it was the one on DVD, but in any case I would assume it simply needs to be the matching BIOS that updated the MCU FW (like some EC FW only work with certain BIOS version)

I think it’s probably a version mismatch with the x99 deluxe MCU firmware in the bios vs the one currently on the MCU, since those guys didn’t flash a wrong rom they got it working again using the right bios. Sadly there are no external chips containing firmware.

I just ordered 2 new blank MCU chips now (these are like 2€/piece), seemed like an easier way than accessing the old ones. Maybe it would work with the rampage bios, but i don’t really want to that bios as a permanent solution.

Well that’s what I mean, you program in older BIOS one by one until you find the one that works with the MCU FW as it is now, then problem solved and you should then be able to update properly again.
If BIOS mis-match, we can force/mod USB Flashback stuff via FPT, to get you back onto the proper BIOS, then dump and put files back to original state and reflash, so proper USB Flashback for this model works for future updates.

I tried flashing back to the rampage rom before, didn’t work…

I straight up deleted the ECUpdateFramework from a deluxe rom and here we go, i can post to bios again. The issue can be seen in the main section where the MCU firmware is displayed.

EC1: RGE1-X99-0509
EC2: RGE2-X99-0204

IDK what firmware i have on there but something isn’t right. I’ll keep this thread updated with my findings and hopefully a fix.

Hope you can sort it out Nice find deleting that module and getting back into BIOS

So i made myself this problem again. On the backside of the board is a atmel eeprom (atmlh410) which i had to desolder to read (write/read protect pin tied to grnd). I tested the mainboard before without this chip which worked fine (i was just to lazy to resolder, no intentions). As soon as i put the chip back it’s stuck on 76 again, although the chip contains correct info about the X99 deluxe.

I also got some info about the MCUs, but my mainboard is lacking the headers to access them easily.