Asus X99 Deluxe II - unable to install any version of iRST

Hi there guys

I’ve been always a fan of write-back caching, since it could really boost up my write speeds, and also read speeds [for some reasons], but on my X99 I’m unable to install this great piece of software. I tried all the versions out there, either from these forums, or official and I always get the system is not supported, or unsupported platform, or some other error.

I’m running Windows 10 x64, freshly updated, all runs clean, no sfc errors, nor dism errors. Tried reinstalling .NET in many ways, still have the same issue.

This is my current performance. I’m also unable to turn on write caching via system policy, it says the drives do not support it. Any clue in what I do wrong?

Thank You!

best and kind regards


P.S.: Here’s the beast :smiley:

EDIT by Fernando: Length of the thread title drastically reduced (for a better readability). The hardware configuration should be mentioned within the post resp. in the signature and not within the thread title.

@uplink :
Welcome at Win-RAID Forum!

If you want answers to your questions, you should give some additional informations (pictures from your “beast” don’t help analyzing the reasons for your problem).
Please let me know

  1. the sort (HDD/SSD) and model name of your system drive,
  2. the SATA/M.2/PCIe port, where your system drive is connected to,
  3. the data transfer mode (AHCI/RAID/NVMe) your system drive is running,
  4. the HardwareIDs of your 2 on-board Intel SATA Controllers
    (you get them by expanding the “IDE ATA/ATAPI Controllers” and “Storage Controllers” sections of the Device Manager, doing a right-click onto the listed Controllers and choosing the options “Properties” > “Details” > “Property” > “HardwareIDs”),
  5. the exact name and version of the Intel RST/RSTe drivers you have currently installed or tried to install
    (you get them by doing a right click onto the above mentioned Controllers and choosing the options “Properties” > “Driver” > “Driver details”) and
  6. the Intel RST/RSTe Software version you have currently installed.

Dieter (alias Fernando)

Hey there Fernando,

Thank You for Your fast reply! Well, I didn’t post the photos of my beast to brag, bot to help You analzye the reasons of my problem.

From the picture, one can see that I use PCi-e port 3 on Asus X99 Deluxe II, and I use 2 SFF SSD drives on the back of my PC, which are connected to [the only logical option] U.2 port. Since it’s Intel 750 1.2 TB, they’re not being made in SATA, nor SATA Express versions. They only exist in two variants, AiC and SFF [small form factor connector, and some proprietary numbers, SFF-8639, or so].

Regardless of my situation and clearing up the reason for my photos:

1. There are 3 Intel 750 1.2 TB SSD drives in my system, just as I already posted in the first post. One is in AiC [add in card] format, in PCi-e port #3, two are SFF and thus in U.2 ports.
2. I use 1 x PCi-e port #3, and 1 x PCi-e port #1 for graphics card [GTX 1080]
3. Since I use drives in software raid0 [X99 doesn’t support RST, thus no motherboard raid support for NVMe drives] I have all SATA/SATA Express functions disabled and I only use native NVMe.
4. I don’t use SATA controllers, and they’re not even part of NVMe controller, everything is being taken care of by CPU [6850K @ 4.7 GHz] since one is directly in PCi-e and U.2 is connected directly via PCi lanes to CPU too.
5. I don’t have any, I wasn’t able to install any version [I tried all the official + all versions from Your forums, literally all posted in this topic <a href=“”>Intel RST/RSTe Drivers (newest: v15.2.5.1035 WHQL/v4.5.6.1004 WHQL)</a>]
6. I don’t have any, I’m unable install any at all.
7. also tried clean Windows install, ended up with the same result.
8. AiC is being used for system, SW Windows raid0 is being used for storage

Thank You for Your time and patience Fernando!

humble regards