Asus X99-Pro Issues in Raid mode. Someone Please send me a suggestion.

This build is really frustrating me I contacted Asus support and they told me to ask Amazon to send me another board but I want to make sure that it is the motheboard’s raid controller failing and not some other thing.

I am currently running this stuff attached to the board: (Asus X99-Pro)
Intel i7 5820k
4gb DDR4 2666 from corsair on the D1 Slot
Two Intel 520 120gb SSDs

This is what was happening:

I set up the raid and everything seemed fine but every time I try to format, the raid it would fail and upon a system reboot (pressing reboot button not power down) I would no longer see one drive and the raid would fail until I completely shut down the mobo and turn it on
I managed to successfully after replacing a SATA cable to install windows on RAID0 after a few uses the system went caput. Blue screens, then the system never booted completely unstable, back to the original issue where one drive would completely disappear.

Here is what I found out so far:
- Tried other ports and raid still fails
- Drives work fine hooked up on another computer but I do not have a free computer to try to raid them.
- On ACHI mode I can format and install OS on each drive fine and send files between them no problems.
- On RAID mode one drive ALWAYS fails, even if they are not in RAID. It doesn’t matter I can only format one drive and then the other fails and if I reboot then the drive does not appear anymore in the BIOS even is if hooked up.

I am wondering if someone else have experienced something similar it doesn’t matter if it wasn’t a X99 platform. I am convinced that the mobo’s raid controller is broken… Any suggestions?

It possibly could be a bug or something with the BIOS or issue relating to the Intel RAID Option ROM or the motherboard itself.

I also get occasionally on my Asus Rampage V Extreme X99 the RAID fail message from the RAID bios display on boot up
on my drives even though there is nothing wrong with my drives and resetting the computer via the reset button or
shutdown the computer and power back on again normally fixes the problem for me.

@ Cmldexter:
Welcome at Win-RAID Forum!

1. Which Intel RAID driver and RAID ROM/EFI RaidDriver version are you using?
2. Has the RAID array been freshly created by using your new X99 system?
3. Did you check the SATA cables?

Dieter (alias Fernando)

All the X99 boards come with the Intel RST(e) RAID ROM v13.1.0.2126.

Thanks You!
1. I believe it has been answered before. Is the Intel Rapid Storage chipset for raid.
2. The raid is a fresh new raid for the purposes of installing the OS on there.
3. At this point, I tried all the cables that came with the motherboard as well as some cables that were working on my old computer. I also checked trying it on other ports and nothing. It is very weird. I already ordered a replacement board from Amazon

My question was: Which Intel RST RAID driver version did you install?

So you will see very soon, if it was a hardware (RAID Controller) problem or not.

I didn’t install any raid driver just the one automatically recognized by the windows installation but it has to be a hardware issue because why does the drive magically disappear even if its formatted previously not even from windows but from the bios every time I accessed an arbitrary drive that is not even raided just because I enabled raid mode?

Ok, so your RAID array was using the generic Intel RAID driver, which came with the OS. Since the actual Windows Operating Systems Win8/10 are using another generic Intel RAID driver than Vista and Win7, it would be interesting to know, which OS you are running.

Yes, I suspect a defective Intel RAID Controller as well as the source of your issues.

What I’m trying to say is that it couldn’t be a software issue because the drive disappears from the bios when a drive access is attempted by windows. It it was a software issue then the drive would only fail on windows but it would still be accessible by the bios upon a reboot which is not the case in my system build. For the drive to reappear I have to completely shut down the computer and turn it back on.

I only sucesfully installed windows 8.1 on the new computer that only lasted for like 5 reboots. In my uncountable attempts I managed to get windows installed just once.