ASUS XG-C100C 10GbE device and vendor ID

Cheers guys!

I’m pretty new to the topic of eeprom manipulation and want to change the vendor and device id of my ASUS XG-C100C 10GbE ethernet controller with the Aquantia AQC107 chip. Goal is to use it on a classic Mac Pro 5.1. I know, there is way to install a certain combo update, but i’d rather use this approach.
Anyway: I bought the black CH341A spi programmer and tried to read the eeprom via flashrom. Unfortunatly, I get this message:

Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI) on ch341a_spi.
This flash part has status NOT WORKING for operations: PROBE READ ERASE WRITE

Google tells me to reduce the spispeed, but ch341a_spi does not support a change in speed.
Some people say the black ch341a programmer is dangerous because of its 5v voltage. I could mod the programmer, but will change anything? The card is still working, so the eeprom is not fried...

How do I proceed?

Thanks a lot,

EDIT: The chip is a MXIC 25L3233F

@Citroen - Black/Gold CH341A does not put out 5V to chip, so you are fine, mod would only change internal used voltage. Some systems need the power cable removed, some need it plugged in, same with main battery.
You may need to try 10+ times with clip too before you get it on there perfectly. Here is a guide with lots of images, to be sure you have it all correctly setup (make sure jumper is in correct position too) - [GUIDE] Flash BIOS with CH341A programmer

For MX25L3233F - Try software 1.34 from this package -…213094641136166
Also, make dump with included ASProgrammer 1.41, then compare all three in hex or send to me to compare.

Hey @Lost_N_BIOS !

Thank you for your support. I managed to read the data from the eeprom.
EDIT: I just noted: all my bins differ. Seems my connection is bad. Will look into it :slight_smile:
EDIT2: I tried to reapply the clamp a couple of time. Right now, the status LED constantly on. But detecting the chip always results in different values.

Thanks a lot :slight_smile:

You’re welcome! It may be software compatibility issue too, that is why I mentioned to use those two different programs, then compare. One may work and other may fail, if both always give different results for themselves, then compatibility issue
You can try windows Flashrom GUI version here too - [Guide] Using CH341A-based programmer to flash SPI EEPROM (34)

I tried it but it does not work. Will test with another chip. In a couple of days. Thanks for your support!

One more question: Is it be possible to remove the 25L3233F, buy a better chip, flash the newest software and add it to the NIC? Which chip would you suggest?

@Citroen - What do you mean it did not work? Sometimes it may take 10+ tries to get clip on perfectly too, so it may take you a while to get it working no matter if you have new $3 clip or $15 Pomona one.

Link me to the stock BIOS, if there is such a thing, and I will tell you what chips are also compatible by default. If there is not, then we can maybe only possibly tell what else might be compatible once you dump this chips contents.
Yes, if you know how to solder well, then you can remove this and replace with another, but you’ll need to dump this one edit and then directly program into new chip etc.
There is no “better” chip, only different chip, all will be same/same when it comes to clipping on a programmer, but yes, some might work easier with certain software, but software compatibility does not have anything to do with making a good connection.
And, it may be easier to read/write to chip once it’s removed and you connect it to the clip or put in a spring-loaded adapter.

W25Q32 or W25Q64 may be easier to work with software-wise

Hey @Lost_N_BIOS

Again, thank you for your great answer!
I tried to reattach the clamp at least 50 times. Sometimes the software does not find the chip, sometimes the software reads some junk from the chip. But I never got anything close to the original firmware. I don’t have my version for the reasons I just said. But there is a newer version (no direct download possible):
Platform: Windows 10 64bit
Part Number: AQN-107
File: Marvell AQtion Firmware Updater Utility

I think I can manage to remove the old and solder a new chip to the board. Maybe I’ll manage to read the code when the chip is directly attached.
Do W25Q32 or W25Q64 work with this firmware?

Thank you!

Hey @Lost_N_BIOS

Did you find time to have a look at the bios file? I checked the SPI programmer a couple of weeks ago and it works pretty fine. Updated the thunderbolt chip of my mainboard without a problem. So I’d like to order some other chip to use it with my XG-C100C. Thank you very much for your time!


@Citroen - Often dumped contents may not look like, or even similar to original FW (do you even have that?)
Plus, if your chip is corrupted, or your tried to erase or write to it, then contents may never look proper due to corruption, so your reads that do give you data may be proper read off the chip.

What BIOS file are you wanting me to look at, and what do you want me to look for in it? If you’re talking about the file at post #8, what one of the three inside applies to your device, and what do you want me to look at it about?
You cannot directly program those files, they need to be used with the updater and configured for your system. For that, I have no clue how you’d do this manually/directly.
You’ll have to check in the other “Marvell” threads and see which users are most knowledgeable with Marvell FW and ask them if they can help

Winbond is most commonly used BIOS chip, so yes I assume it’s OK to use. You do not need 64, 32 will more than suffice

August moment…