Asus Z490 Prime Bricked

Hi, sorry I’m new here hopefully this is in the correct place.

I need some assistance restoring the bios on my board.

I’ve purchased a ch341a programmer and I’ve read the tutorials and I’ve been trying to flash the bios chip however I’ve been getting a verification error at x800000
All the flashing programs ch341 programmer, asprogrammer etc detects the chip as 25q64b/f etc at 8MB. The asus Flashfile is 16MB.
I’m not sure if the programming software is reading the Chip incorrectly?
I’ve tried changing the size manually to 16777216 and this is where I get the error.

What am I doing wrong?

I tried to backup the chip however It was only able to read the 8MB cannot read beyond that.

My full IC model is 25Q64JVSIQ

Try version 1.30/34 with W25Q64BV or ASprogrammer with same spi model selection.
If the dump is all FF/00 is bad dump.
Also some motherboards need or not, cmos battery in or NOT at all. This is different in every machine and ull have to test yourself, or search for some user related experience based on ur HW model.

EDIT: Is this the location of the SPI…seems W25Q128JY (BV/FV variant)


The dump had data it just stops at 8mb. If
I manually select different chip size manually that’s when I get the error.
I’m setting up a win7 machine now to try again

Thanks for your reply so, I’m still stuck.
Upon continuity testing the both ic’s the one on the right was the one I got connection to the spi header. So I automatically assumed that was the main bios chip.
On my board the chip is GD25B127DSIG

I can successfully read and write to this chip.

I restored the winbond chip as well with the original dump from earlier.

However board is still dead does not even attempt to turn on…


Hi guys hoping someone can help or point me in the right direction.
I have an Asus Prime Z490-A board.
Which died due to a corrupt flash.
Eventually I was able to use a ch341a to get the board back on however it does not have nic detected anymore.
If I flash firmware from similar board the Nic is detected but shows up as i219 not i225.

Is there anyway I can recover this?

I still have warranty so thats a last resort. I just don’t mind experimenting to figure this out.

Based on how I got the board back to life I suspect a backup from an Identical Prime z490-a would work as this board uses two bios chips (24MB total) Asus flash files are only 16MB.

Is there someway I can inject the full and proper GBE Region ??