Asus Z97-Pro (WiFi ac) not see my M.2 SSD drive

Guys and gals (?), I would certaily use some help / advices, on how to make my M.2 SSD device visible in bios of my new Asus Z97-Pro (WiFi ac) mainboard.

I bought this one recently, to get a new -QUIET- build for gaming and apart from 1T WD HDD I get a 128G Samsung SM951 M.2 SSD drive. Upon inserting it into the mainboard:

…it is getting reasonably hot (especially the first chip - controller), so it should work, yet it fail to show up in the Z97-Pro bios at all. So I cannot partition the SSD, nor start installing Win7 on it.

I tried to set the setting in Advanced / PCH Storage Configuration - SATA Express(SATAEXPRESS) and M.2 Configuration to directly M.2 instead of Auto, but still no help. SATA is in AHCI mode.

Then I on youtube looked at this video:

…but altrought it surely help people with the Z97 Maximus VII mainboard to make the SSD visible in bios:
Advanced / Onboard Devices Configuration and change the setting of PCI Express X4_3 Slot (Black) Bandwitch from Auto Mode to M.2 Mode. However I did not find such option in my bios…

Also I noticed this thread:…nstallation-FAQ

…but this is, once again, about different mainboard - about Rampage V Extreme :frowning:

So, a little help would go a long way there… Thanks!

And looks like I’m not alone:…boot,+any+ideas

I also tried this:

As this method looks very promising, however it fail to work on Asus Z97-Pro (WiFi ac)/usb 3.1 - with Samsung SM951 M.2 SSD. Rufus easily create the USB boot install Win7 Pro drive, no problemo there. However when I use the recommended bios setup, it ALWAYS reset the computer right after the “Starting Windows” message on screen appears. After that, the Asus board tell me, that it adjusted my bios settings to make the problem “go away” (it re-enable the CSM!) and then the install works, however it did not see single drive :frowning: (all except M.2 are unpluged)

Latest bios are now used. Asked Asus support and get funny message, that basically says, that Asus only support following M.2 SSD drives it list there:
And the best part of the message is: “Asus do not guarantee functionality of this manboard with other that listed M.2 SSD drives.” WTF …

Any help will be greatly appreciated.

I tried different bios settings regarding the CSM, but the rule seems to be that disabled CSM lead to reboot :frowning:

The guide is basically about that for the first part of Win install on M.2 SSD drive, you need to:
- completely disable CSM (Boot/CSM)
- select Secure Boot to “Other OS”
- select Key Management to “Clear Secure Bootkeys”

…install Win thru first reboot, then…

Secure Boot: Windows UEFI Mode (instead of completely disabling CSM)
Key Management: Install Default Secure Boot Keys

So it was sound reasonable, however it failed completely :frowning:

Asus support tell me, that they ONLY support the M.2 SSDs, mentioned in this pdf:…ices_Report.pdf

Therefore only supported (according to Asus) M.2 SSDs in Asus Z97-Pro(WiFi ac/USB 3.1 mainboard are:

Apacer: T60 A200-M 128G
Intel: 530 SSDSCKGW080A401 80GB
Liteon: LITEON-LGT-256M6G-2280-256GB
Kingston: RBU-SNS6100S3/128GC-2260-128GB and RBU-SNS6100S3/256GC-2260-256GB
Sandisk: X110-2260-128GB and X110-2260-256GB
Samsung: MZ-NPD1280-2280-128GB (Support on ISRT 13.1)

None of these SSDs are particulary interesting in terms of speed…

Even the “new” list of “supported” by Asus SSDs did not say a thing about M.2 SSD devices:

OCZ: VTR150-25SAT3-240G and VTX460-25SAT3-240G and VTX460A-25SAT3-240G and ARC100-25SAT3-240G and RADEON-R7SSD-240G
Crucial: CT256MX100SSD1
Kingston: HYPERX FURY-240G
Panasonic: RP-SSB240GAK
Plextor: PX-256M6S and PX-256M6PRO
Samsung: MZ-75E1T0
Transcend: TS256GSSD320

Win 7 will not have the required drivers to see the HDD, you can either add those drivers or go to Win 8.1/10, at least, use media creation tool, download win8.1 or win10 iso and create a bootable pen and see if it works with those.