Attempting to mod splash logo on Supermicro C7Z87

Hi guys

The last couple of days I’ve been trying to change the boot logo on a Supermicro C7Z87 motherboard.

I’m able to extract the logo, edit it and save a new BIOS. However no matter what program I use, the flashing process stops just before it is completed.
Screen shot available here

When the motherboard is rebooted the logo is updated, however I do not trust that the entire BIOS have been updated.

I have tried with the follow programs:

ChangeLogo version
ChangeLogo version 5 ( file is just called ChangeLogo_v5.exe)
MMTool version

With all programs I’m able to replace the Logo in the BIOS, but they all hang when trying to flash.

I have also tried using different programs to edit the logo, but it does not change anything.
Programs i have tried:
MS paint
Printshop Pro X8

I have tried with both 800 x 600, 640 x 480 resolutions in both 16 & 256 colors.

I have contacted Supermicro, but they cannot send me the ChangeLogo version 5.00.0006 they use, as it is a licensed program.

Can anyone help? Can someone try to mod the BIOS for me? (So that if that works, I know I’m doing something wrong)

Link til orginal BIOS here
Link to logo here



I trust you modified the right file, based on your answer. There is one file with images:


In order to avoid any other issues, you should start with an image similar to the one inside. The original image is BMP with 640 x 480 x 8 BPP, yours is JPG with 800 x 600 x 32 BPP. I’m not saying that this was your error, but something to consider. I have attached a fixed image, just in case. My guess is that the real issue was with flashing ME. Open flash.bat and remove /ME, by changing 5th line to “AFUDOS.EXE %1 /P /B /N /K /R”. Your ME is probably already updated to that version and even if it isn’t, this is an entire separate issue, which you must tackle in ME thread.

bboxnetserv logo black background_640pix.rar (30.1 KB)