BIOS cannot be modified

I tried (how to get full NVMe support for AMI-UEFI-BIOS)

Load the BIOS image with MMtool, insert the NvmExpressDxe_4 module into CSMCORE,
Save image but firmware write error

Try different way UEFITool v0.27.0
DXE driver CSMCORE was found, but there is nothing under it PcieLaneDXE
After this i don’t know what to do
help me

PC: HP elite 8300 SFF
BIOS: SP95971 (American Megatrends, Inc. BIOS)
Extension: bIN file (K01_0308.BIN)
Chipset: Q77
CPU: i7 3770 Ivy Bridg
M.2 NVME PCIe SSD Adapter + ELECOM SSD 512GB M.2 2280 PCIe3.0 × 4 NVMe1.3
Memory: 16GB
OS: win10 PRO 64

Edit by Fernando: Thread title specified and customized

Oh,you could try SPI programmer!

No wonder, if you really have inserted the NVMe module into the CSMCORE module.

I encountered the same problem.
I followed instructions from thread on ami-uefi bios nvme support (the MMTool route) and inserted the small version of module (option “Insert Compressed”) in the same volume as CSMCORE is listed in. That was successfull.
However, saving the image generates a “Firmware write Error”. I’ve tried inserting the module using the other option under “Insert FFS Options” and encountered the Error too.

I’m going the MMTool route, because using EUFITool generates extra pad file and I haven’t found any fix to that.
I would post my bios file but I’m yet to figure out how to do so.
Bios: B75MD3H (F15)


MMtool 4.x NOT 5.x

EDIT: No error on saving, here.

Thank you for quick reply.
MMTool’s version that i use is as is suggested on the original thread.