bios chip located

hi i m trying to flash the bios on an old toshiba l305 with motherboard 6050A2175001-MB-A02. I think i found the bios chip that is MX25L8005M2C it has 2 red dot on it in the upper side of motherboard. i have tried both ch431 severel versions and asprogramer but they dont detect the chip they read it and finds empty in detect it says manuf unown etc, cant program always reports error and one other thing when i connect the usb/clamp with the chip one light of the motherboard goes on (even when i dont plug the motherboard with ac adaptor) ??? the connection are ok i have tryied many times and always come up with the same result, any ideas

Can’t say for sure because I’m new to this. I’ve read about power backfeeding into the motherboard and the ch134 not being able to supply enough current. I modified my programmer to use the 3.3v rail of a spare psu I had. I used this to read and write the bios to my dell precision tower. I also had my pc disconnected from power,psu removed and cmos battery removed.

i have all components disconenct except cpu, i dont have it on power but when i put the clamp on bios chip and conenct it to usb programmer a




light of the motherboard lights up and goes green, is this the right chip?

Does the chip size correspond to stock bios size?

If yes- read the chip and check if the content does look like a bios and can be opened in the correspondig programs… Read content at least twice and compare results so that you don’t overlook some accidental read errors…

I second what lfb6 said above^^.
The light on the motherboard going green does not indicate that it’s the right chip; it maybe a sign that you might have a voltage drop on pins 4-8 connected to your ch341a. I would first obtain the datasheet for MX25L8005M2C to see what voltage it needs (3.3V ?). Then, while you have everything connected, confirm you indeed have the right voltage. If you are powering some components on the motherboard, there may be a drop and reading from the chip will be unreliable.

Also, I would make sure I had the chip read correctly with at least two different programs (veified in hex-editor) before erasing or writing on it.

The clamp size is correct all the pins of the chip connects to the pins of the clamp thats not the problem. is that the correct bios chip or i m trying with a wrong chip? i think thats the right one because i search the net and some people point that one, also has 2 pink dots on it. When i connect it, i tryied many times and ways and while ch341 and asprogramer says it connects when i read it both find nothing as if it is blank, the light goes green as i said like when you connect it to the power and i cant verify or progamm anything. i tryied with power adapter and without it and the light still remains on