BIOS Data Intel DH67BL erased

Hi guys,

my name is Daniel and I’m from Germany. I’m new in here and having an issue with my second hand Intel DH67BL. It crashed during the bios update. The previous owner erased the spi flash chip not knowing that there are no .rom, .bin files for intel bioses. So I startet searching for a .bin file and I found a working bios someone dumped from his board. But when I try to update this working one I get a not working one again and I have to programm the spi flash chip again. I think there is something missing oder corrupted in the bios I got. Is there a chance to get a fully working mainboard, which is able to perform a bios update? Where can I find the mac adress? Is it just stored in the original bios? There isn’t any sticker on the board regarding to the mac adress.

Best regards

PS: This is the bios I got: BIOS DH67BL

PPS: I think there is a mismatch betwenn bios version 0156 and Intel Management Engine Version!

ME and NVRAM must be cleaned, last 0x400 of this files removed, as they don’t belong to any region (it’s 4 pages of SPI chip data read by good SPI programmer).
MAC is stored at the beginning of GbE regions, offset 0x1000, is 70:71:BC:F8:31:3E in that file.
I will try to make you a clean file tomorrow, if @plutomaniac doesn’t want to make it today. :slight_smile:

Now I managed to update to the latest version 0160. Also the Intel Management Engine is updatet to version 8.x. May I give you the correct serial number, revision etc, that you can include these in the file? Maybe you can tell me in short steps how to edit this file? Is that possible?

In short steps? UEFITool and hex editor. Please also provide current incorrect ones so it will be easier for me to search and replace.

Try out this file: or from attachement. (1.79 MB)

Thank you very much. I will tell you if it worked or not.


sorry for the late replay, but I had to wait for my bios programmer. Your file worked! Thank you very much.


Hi, my name is Vicente (I’m from Spain) and I have the same problem as you after a bad update of my DH67BL badge.
I can not recover the BIOS in any way.
I think the solution is to reprogram the BIOS.
Is it necessary to remove the chip to reprogram?
Thank you

Thank you very much. This is work

I think you only have to flash it by SPI programmer,and remember:updating the latest bios by recovery mode next time is a good way.


I have the same issue with my motherboard Intel dh67bl. Tried updateing from 0076 to 0163 and everything looked fine. But when the computer boots up it goes go a black screen and nothing Else happens. I’ve pulled out a dump of the bios but i dont really know what to do with it. If there is someome here who can guide me or put me on the rigth track it would be much appreciated.

Reviving and old thread.

Is this the file we need to use the programmer and clip with or can this just be put on USB and flashed in bios?

My issue is that I went straight from bios 128 to 162 and failed to do the transition bios 132 in between so am getting the black screen issue with most CPU’s and PCI-e isn’t working.

Is this file later than 138 and if so has it solved the black screen issue?

If ur referring to the file in post #5 by CodeRush, its the 0156 and seems ready to program as reported success by users Schorsch2510, punkt87.
Like the user gloobox recommends, its advisable that after use the standard procedure F7 and apply again the same 0156.BIO, then procede to the last 0163.


Yes that’s correct post 5. Do I need to flash using the programmer or can I used F7 to do that one? Note that I didn’t flash 132 as required, with this 156 fix it?

After reading a few times it appears as though the others used the programmer. Unfortunately I can’t find the original 156 bios anywhere.

Edit -Can now see that its a .bin file so needs to be flashed using the programmer I take it.

Would like a bin file for a pre 132 bios as not sure if the 156 will work with Ivy bridge without having first done the 132 bios update.

Theres something here that is not right… checking the Bios revision updates PDF (Check it in files attached), there is no 0138 bios version. The so called transition (3rd Gen 22nm/ME8) bios for this motherboard
is the version 0151. So please provide me that 0138 that u flashed to identify it.
Now ill provide u the bios files for F7 procedure, 0132 (last with ME7), then 0151(2nm/new ME8), and last one 0163, this is the upgrade path/order, all Original stock files.
All this will work if SPI is not corrupted and preventing the Intel F7 normal update procedure.
If its not ur case then u must use an SPI programmer, but urs is booting but no display/post.

That previous file, i believe was used for SPI programming recover, the post r back from 2016 and was not a case i followed.

DH67BL Intel Files


Really appreiciate the reply. Please bear with me.

This is the whole story. Firstly I checked the BIOS update to 3rd gen pdf which you have included in the pack.
My board version is AAG10189-210
My Intel Managment Engine Firmware is

Originally my bios was Version 128

After looking at the PFD I assessed that my motherboard is compatible, though looking now at the list, it only says AAG10189-206, not…and later. Maybe my board isn’t compatible but I’d still think it is. Why would it miss 207-210.

Once I worked out it was, I then proceeded to flash bios 162 which now the PCI-e slot and also i5-2500k and i5-3570k won’t work. My i5-2320 that I did the update with still works, albiet with no PCI-e.

After much reading I discovered that the correct process according to the PDF is to firstly flash the transitional bios 132 and then another one after that. Unfortunately, despite me having 132, the F7 bios flash won’t allow me to downgrade to that version due to structural changes made when flashing a higher version. Pretty sure I could do 151.

I’m able to do F7 bios updates and my i5-2320 is still working fine and I can see the screen.

If I were able to I’d do 132, 151, 163 but can’t get back to 132. I’m assuming I can do 132 or lower with SPI programmer however the files I have are .bio files and larger than the 4mb chip size. I’ve been searching for a pre-150 .bin file less than 4mb but can’t find one. My skills aren’t good enough to get into a hex reader and make the adjustments needed.

Any thoughts?

So… no word of that 0138 u flashed???
Regression on Intel motherboards are always a big risk, but yes only with a SPI programmer.
So now the motherboard has the 0132 or 0162? With witch u can boot/post and access UEFI bios with the i5-2320?
Wots ur current ME version?

Sorry was a typo. I had 128 and went to 162. The transition bios is 132. There is no 138. Having said that, the version list didn’t say anything about 128 either but I’ve got a photo which I checked.

My current ME is the one listed.

I’m on bios 162 which works with my i5-2320.

How do I convert the 132 to a .bin file under 4mb. Is this getting in the too hard category now?

So ur on the 0162 with ME, but no boot with a 3rd Gen and no PCIex16 slot 1 function…

I can only deduce that all the standard update path is broken in the UEFI structure… i would use an SPI to fallback to 1rst release bios of the motherboard.
No more miracles here for this situation…followed know solutions.

I tried the extraction but seems not valid, ignore that Intel image i linked, u can try the 0156 linked before by CodeRush, good luck.

EDIT: See… ur on the 0162 but its not correct because the board still has ME7…thats why its broken…
At ur own risk u can try to manual update the Intel ME to 8 using the FWUpdLcl64.exe tool from ME8 package here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
Post a request for another user more expert in Intel bios, asking a 0132 image as u need.
Sry, still dont get it… below 4Mb…

I’m on 162 with My Intel Managment Engine Firmware is

No boot with i5-2500k or 3570k. No pci-e with anything.

I’d flash the original but need to convert to a bin file and reduce below 4mb.