BIOS File version?

This may be a stupid question, but I want to make sure.

I have been updating my OROM’s and I came across this for a system. It is an AsRock H77M board; the original BIOS has UEFI with OROM 11.2.1527. So did the steps on how to extract to find out the version; no problem.

So inserted the new OROM (12.7.0.1936) and saved the new BIOS. I extracted via the process outlined and it now has 12.7.0.1936. But I saw something I have not seen before. For this one the original BIOS name was H77M1.60 and the “Type” description in Windows says 60 File.
But at the end of the new one I did it ends with .fd so it looks like this; H77M1.60.fd and the “Type” description in Windows says FD File.

So I want to make sure that I did not do anything wrong so I did the process again and when I got to the steps about saving the new BIOS, I tried to use the dropdown menu in MMTools to see if I need to select ROM, but the only option is this fd.

Do I just use the file as is or did I do something wrong still? I read the UEFI steps and I see no mention of this so I am not sure.

@ denaba:

The .fd extension is wrong. I don’t know what exactly you have done while modding the ASRock BIOS file named H77M1.60 to get at the end a BIOS file named H77L1.60.fd (maybe a mistake, when you saved it?).
If you are unsure, please repeat the modding procedure.
Anyway you have to rename the modded BIOS file the usual way you did, before you flashed a modded BIOS into an ASRock mainboard BIOS chip.

OK, this is what I did;
Run the MMTool for UEFI as Admin
Load Image, find original BIOS; in this case version 1.60, change dropdown to All files so it can see the original BIOS
Find and highlight CSMCORE, click replace tab, browse for OROM, check link present and use dropdown and locate 8086. Option is 282a. Does this matter? It is a motherboard, not laptop?
Anyways selected 282a. Click replace and wait till done. When done click “Save image as” and this is where the only option to the Save as type is “Aptio Files (*.fd)”. Here I just give it the name, but I cannot change the ending of .fd since that’s what MMTools is only offering.

On the modded BIOS, if I get rid of the ending (.fd), then it looks like it is suppose to be and the Type file name and size match the original.

But that’s it, that what I did.

UPDATE: Using MMTools version 4.50.0.23
FYI

You are right, but it doesn’t matter, because both DeviceIDs (2822 and 282A) are using the same Intel RAID ROM module. That may be the reason why all manufacturers of Z77 mainboards insert the Intel RAID ROM module into the BIOS as “8086, 282a”, which is not correct for desktop systems.

You can change the BIOS file name inclusive the extension once the MMTool has saved the modded file. It would have been easier, if you had chosen just the "Save" option instead of the "Save as…".

You can give the BIOS file any name (inclusive the extension), unless there are restrictions regarding the BIOS file name by the flash utility.

Conclusion: You can delete the “.fd” extension without any problems. After having done that, the modded BIOS file has exactly the same name as the original one (don’t mix them afterwards!).

All done, thanks

Another you can add to the list

AsRock H77M
MB
Intel H77
Intel RST RAID ROM v12.7.0.1936
Success
No issues

Done! Thanks for the report.