Bios Gigabyte z390 Gaming X HPET

Can u btw unlock me that option in any bios ? for visible and switchable in bios hpet and PCH config?

@265055 - No, that’s not possible in this BIOS, Well I mean not like you think of with “old PC”. I can make visible for you if I spend many hours of work, but it will be same as I gave you above.
Win10 does not act like Win7 (I assume your old PC you mean, where you disable in BIOS then it’s gone from device manager)

If you want it gone from device manager you can run this command (but it’s better you leave default “True”, otherwise timers are worse with it disabled in BIOS - that I sent you) >> bcdedit /set useplatformclock False

Good afternoon! I ask you to help unlock the HPET function in the BIOS, thank you in advance.
GIGABYTE Z390 GAMING X motherboard
BIOS is F10c

Dear Lost_N_BIOS, please, could you modify the BIOS ver. F10c for z390 gaming X to disable HPET? I am experiencing terrible micro-stuttering in games and tired of trying to resolve this problem - looks like my last hope is this thread and your help…

@Shedpwnz @zxr - I made F10c edit before and posted somewhere here, but now I can’t find the thread or post
Here is previous edited BIOS from June -

Merging to other same board/request thread, moving main thread to requests

Dear @Lost_N_BIOS , please, may I ask you to modify the BIOS ver. F10i for Gigabyte Z390 gaming X to disable HPET and enable "Writes to SMBus addresses 50h - 57h"?
Thank you very much for considering this request.

@Lost_N_BIOS , you are my hope for the request listed above! Please-please…

Could someone help with this request, guys?


If no one can help you here.
I thought i can help you out to edit bios in this mainboard ,first make a bios dump with this tool and capture screenshots under Settings => IO PORT and under Settings => Miscellaneous then attach them.

hey there, im on z390 gaming x aswell, on F10 bios version. Can you please make me a modded bios with the HPET disabled ?