Bios Gigabyte z390 Gaming X HPET

I need help make a mod for z390 gaming x bios for Hpet < High precision event timer no in bios.

Someone can help me to make it switchable enable/disable? i wanna disable it in bios and inside system.

@2625055 - Can you see PCH-IO Configuration page in BIOS already? If not, show me an image of the BIOS advanced view (So I can see all visible sections)
Or, if you just want to disable that is much easier for you, no testing needed etc, I just disable and you flash and we’re done.

So i have to send u bios and u will disable it inside the file and i reflash it? That will be great i gonna send u that ok? Or if u can make it like visible to change on or off in bios if that problem just off this shit forever please
------------------ this is the new bios for my gaming x z390 gigabyte. Pls make it hpet disable if u can

ps. Sorry man i dont use froums normaly. Btw i will editing post, so can u help me some way with this file here? my english is so bad ;/ sorry

Please edit your posts if you need to add more info, questions, or thoughts and no one has replied yet

No, I do not need you to send me BIOS, I already downloaded latest one from Gigabyte. Do you simply want it disabled (not visible)? If yes, I can do that, and it’s much easier for you.
That way you don’t have to answer my questions, which you did not already, and you wont have to send me BIOS images, or possibly have to test a few BIOS before final.
So, do you just want it disabled?

Yes i want to disable hpet in bios. It can be not visible not problem just disable. Rlly thanks

OK, thanks! Give me a little bit to edit it

* edit @2625055 - Wait, please confirm latest F10a OK for you, or you want some other version?

Im using now F9 so it can be F9 but i wanna update to 10 because it make my memory more stable update. So i think it’s no problem any of this version it can be F10a. I hope it will be ok because i not tested it ;( if u dont have much time, just do it on 9 for sure bios will work for me normal like now. But if u think it will be no problem u can modify F10a first. BIG THANKS

@2625055 - OK, I would suggest using F10a anyway, it would have more fixes/improvements over F9 than what is shown at the change log anyway. If you end up hating it, I can do F9 for you later.
Before flash, enter BIOS and load optimized defaults, then reboot back to BIOS to flash via Qflash. Then after flash, be sure you enter BIOS and load optimized defaults and then save and reboot back to BIOS, then make all changes you need.…951661078495277

Im in work right now when i back home i will test it. Ur best, big thanks

You’re welcome! Yes, please let me know after you test, thanks

I updated it and the question is if u disable bios how it can be still visible in Device Meneger ? It’s disabled for sure?

Yes, I disabled in all possible BIOS locations. However, it’s possible Qflash didn’t clear and re-write NVRAM.

Please send me FPT BIOS dump and I can check, if we find it’s still there then I will show you how to re-write with FPT and clear it out

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

Ok so i can see, i will not that good to understand that ;( btw tell me how i can show u fpt bios dump ?

Btw im using windows 7

ME Firmware Version Consumer SKU

Intel ME Version: v12.0, Build 1310, Hotfix 22
?? it is thaT?

Trying to use the comand and i see some like this error

Sorry, I gave you instruction above how to make and give me FPT BIOS dump.

So, you need ME System Tools V12 package from section “C” in this thread
Intel Management Engine: Drivers, Firmware & System Tools

I can’t tell from your images, but maybe you have correct package of ME System Tools already? If yes, I can see from your image that is NOT Admin CMD Prompt, it MUST be Admin CMD Prompt as shown above
Select that “Win32” folder, hold shift and press right click, choose “Open command window here as Administrator”, then run commands shown in post #13

Hello :wink: Yes i know but i made same what u reply in last post and i got this error btw when i trying to put command in cmd. Btw i use v12 and next thing is that maybe i see hpet in device meneger but it’s now more responsive pc so u rlly disabled that i think some way. I feel lighter moves in games

@2625055 - Yes, I understood you, and see the issue. I explained above why you get that error (your CMD prompt is not Admin CMD Prompt), and explained how to properly get Admin CMD Prompt so you don’t get the error.
If you see HPET in device manager it’s not disabled I think. Please do as I mentioned above and get FPT BIOS dump so we can check. Or, maybe you can also save BIOS copy from Qflash in BIOS, I forget?
Go to Qflash, and see if there is a save or backup function, if there is save and send me to check. Or, you can make backup from DOS with EFIFlash included in stock BIOS package >> efiflash.exe backup.bin /S

Hey i just go back to that because i need how i said hpet switchable in bios for completly turn it off if u can just make me that way i will be rlly happy. Before when i got normal hpet in bios in old pc i just make it switch to off and it’s no more in devices in windows. Now with ur bios it’s still there. Can u modify bios for me that way i can turn it of like in a original bios in first pc?

@2625055 - Still waiting on backup from you to check, I already hard disabled HPET and this works for everyone, so something didn’t flash in and we need to check what and why, and if needed flash BIOS another way.
I gave you two methods to dump current BIOS so we can check, so waiting on you for that

Here u are i make save under qflash from bios.

@2625055 - Looks good, same as BIOS I sent you (all is disabled) You probably need to disable HPET in Windows run the command if you want it removed from device manager >> bcdedit /deletevalue useplatformclock
Here is opposite - To enable HPET as the only timer run the command bcdedit /set useplatformclock true

In my testing for Gigabyte Z390, shown below change log area here, I found it’s best to leave enabled for lowest timer results (see test image x4) - None of this applies to “If you can see in deceive manger” or not, I did not look at that, at all
[OFFER] Gigabyte Z390 M Gaming UPD + Completely Revised Blue Theme