Bios mod for Sony Vaio Pro13 - add NVME, repair ME

Hello, I’ve backup my old BIOS with Winflash, added NVME with MMtool and then flash it from bootable DOS. But it ended with error message - there were something about that it was not able to do secure flash. And computer was bricked. It was more than month ago. So I’ve buyed CH341a programmer and programmed backup from WinFlash back. Computer returned back to life, but in BIOS there is ME version 0.0.0 written. So i’ve updated BIOS from original package - but with no effect to ME version.
And if I add NVME module from Fernando’s manual, it is successfully written, but computer does not start. No picture on screen, no logo, no BIOS.
Can you please somebody help me to make it functional. I will write then all you need to know, or attach here backupped BIOS.

Well, you made an error while inserting the NVME module but you got it fixed since you had a programmer and a working backup. Provide your backup and stock bios, maybe someone will look into it

What went wrong can’t be said with the sparse information we have, the ME thing may not be a problem, but with flashing a stock bios you probably lost machine specific data like serial number, maybe Windows license information, maybe MAC address. .

Hello, in,this is backupped bios from winflash. If I flash it with programmer, notebook will boot up, but in BIOS, there is 0.0.0 in ME version. In bios_NVME_mod attachement I"ve added NVME module. But after flash, notebook won’t boot. And V720920B is latest original BIOS downloaded from Sony website. (2.75 MB) (2.22 MB) (3.04 MB)

Thanks. Your own ‘modded’ bios is ‘missing’ a large block of it’s original code and both modded and backuped file don’t contain any traces of a ME region. Look what’s following on USBInt13.dxe on the non- modded and modded bios:


How did you mod your bios?

How did you flash the files?

And Sony bios seems not to be original. Please give the link to the download page or the exact type of the notebook?

Hello, I’ve backupped bios.rom with Winflash. Then I’ve edited it with MMtool ver. 5.02. And tried to flash back with Winflash. With no luck. So i’ve tried to flash it from DOS. But it ended with Secure flash error. And it was bricked. So I’ve ordered CH431A programmer and flash back bios.rom. Maybe I’ve done some mistake with adding NVME driver.
Notebook type is SVP1322V8EBI and latest BIOS can be found at www. (R2092V7) instead of mine R2070V7.
File bios.rom is only one backupped file which I have before bricking.
I will be glad if somebody can help me with that. Thanks

Winflash doesn’t backup ME region, sometimes not even Flash Descriptor. In latter case you’d had a completely unbootable system even when restoring your backup.

Procedure for restoring would be:

Open the unchanged Sony bios you linked in UEFIToolNE
Extract ME region ‘as is’, save
Open ‘working’ backup in UEFITool 025, replace ‘as is’ ME region with ME region you extracted from Sony stock bios, save file as bios_me.rom
=> bios_me.rom is your own bios with working ME

Open bios_me.rom in MMTool
Select last entry in volume 4
Insert module - NvmExpressDxe_4.ffs - link present UNchecked - Insert compressed - save as bios_NVME_me.rom
=> bios_NVME_me.rom is your own bios with working ME and inserted NVME module

Since your bios does contain Win license and machine specific data I’d recommend updating your machine before modding. Don’t flash unchanged stock bios with programmer!

3 files attached- you might work it out yourself and use the for comparison or just try to flash these files:
bios_me- your backup restored with working ME from stock bios
bios_NVME_me- your backup restored with working ME from stock bios and inserted NVME module

V720920B_own_NVMEsmall latest bios with machine specific info transfered and NVME small module inserted
Latest Sony bios doesn’t have enough space, need to use NVME small module
Tranfer of own settings is always a little tricky, there’s one block that might be relevant or just be settings. Kept NVRAM, too, that might as well work or not. You might try the latest file first or play safe and first restore your working bios, then update to latest version, dump/ backup again and mod a copy of the dump

And: Not all models of this notebook were equipped with a NVME M2 slot, some were just SATA M2! (3.85 MB) (3.84 MB) (3.85 MB)

@lfb6 Many thanks. I will try it to “cook” it by myself and compare this two files. Last file works perfectly. Many thanks. Pcie NVME SSD was visible in Windows install, not in BIOS, now it works like a charm.
You helped me a lot.
I have one question - i’ve bougth same motherboard, but BIOS is password locked. Can be a password resetted/ cleared by programmer in some way?¨Thanks

Thanks for the feedback Good to hear that it also the last version worked.

Regarding password- sometimes it’s in NVRAM so you could simply start with stock NVRAM. But I’m sorry, that’s an item I don’t know anything about.