Bios mod MSI Z390 MEG ACE (Enable integrate graphic)

Gentlemens, can anyone help with the modification of the BIOS for the MSI Z390 ACE? Having bought this motherboard, I was surprised at the lack of settings to enable integrated graphics, I need it not for image output (there is no video output here), but for use with Quick Sync codec.
So, I ask you to help with the inclusion of the IGD Enable and IGD Multi monitor parameters, well, or at least tell me if I edit the BIOS through AMIBCP and turn on these parameters, will this work, provided that in AMIBCP a huge number of parameters and folders are displayed how is undefined?

Edit by Fernando: Thread title customized and shortened

I found here on the forum a modified BIOS with the Chipset menu unlocked, but the inclusion of Integrate Graphics causes the system to hang on Post code 71. After contacting the MSI support, I was informed that the integrated graphics would not work, because They did not add VBIOS. Gentlemen, please help add VBIOS that the integrated graphics worked to use encoding / decoding with intel Quick Sync codec

@ma3uk - If true, they must add a vBIOS, they have to configure it for this boards graphical outputs. HOW in the world can they put out a board with onboard graphics OUT ports with no vBIOS, this makes no sense and is surely not true!
And yep, I thought that made no sense! I just checked this BIOS, it contains GOP (for onboard graphics when UEFI boot), and vBIOS (for onboard graphics when Legacy Boot)
EFI GOP Driver SKL-CML - 9.0.1098
RAW GOP VBT SKYLAKE - 228
OROM VBIOS CoffeeLake - 1024

What CPU do you have? Integrated graphics should work, by default, always with this board, unless your CPU does not have integrated graphics

I have 9700K with IGD
According to HWinfo64 monitoring, a voltage of ~ 0.8V is supplied to the iGPU, the monitoring also reports that there is iGPU heating, but any attempts to install the driver for the built-in driver are accompanied by the error "Your system does not meet the minimum requirements", and when you try to manually turn on iGPU in the section System Agent BIOS lead to post code 71


This motherboard hasn’t “onboard graphics OUT ports”.

Wow, thanks @DeathBringer , I didn’t look and just assumed it would be there since this is top end “Gaming board” Marketing guys !
Good thing, he doesn’t need graphics out anyway, and vBIOS is there too, so he just needs to solve the driver issue (Maybe due to BIOS Internal GFX Disabled!)
Do you have coffee BSF for 1024 or 1025, so I can look at the current vBIOS settings for him?

I can only check VBT, and I see KVMR Session / Fake DVI Display = Disabled, seems like something he’d want enabled. The rest, from what I can see there, does not look like anything is disabled that would stop functionality.
But, I’m not great at working with GOP/VBT and would prefer to be able to fix this at legacy/BIOS side, especially since the BIOS is setup for that as default.

Maybe @Sylar76 can help here - Do you know how to open Coffee Lake vBIOS 1024 or 1025 in BMP, we have no BSF?

@ma3uk - I assumed you used the BIOS I made with chipset menu visible, (MSI Z390 MEG ACE-7B12v17-HPET-ChipsetMod). Did you enable Integrated Graphics at >> Chipset >> System Agent (SA) Configuration >> Internal Graphics?
If yes, did you test this w/ CSM enabled? Because default of this setting is Legacy >> If not, try that, or change Advanced >> CSM >> Launch Video OpROM policy >> UEFI

When you get 71, did you try clear CMOS, then set again Internal graphics enabled?

I’d like to know on which bios help is needed.

@Lost_N_BIOS Yes, I am using your BIOS mod MSI Z390 MEG ACE-7B12v17-HPET-ChipsetMod. And you say correctly, I tried to turn on Integrated Graphics in the System Agent menu with switching CSM to UEFI mode. After CMOS Clear Integrated Graphics is set to Disable
-----------------

@Sylar76 Here I posted a ROM (I updated the microcodes CPU) https://yadi.sk/d/INqefJnPR-MWBw

@ma3uk

Thus, I assume you won’t see any video output if you connect the hdmi port to motherboard and select integrated graphics inside UEFI Bios. Is it correct ?

If yes, did you try the original (not modded) bios to see if integrated graphics works or not ?

@Sylar76 This motherboard does not have ports video outputs, and in the original BIOS there are no options to enable integrated graphics. But we tried to enable Integrate Graphic with @DeathBringer through EFI GRUB, the result is the same -
boot post code 71.

I need enable Integrate Graphic for use with Intel Media SDK (encode/decode/video streaming with Intel Quick Sync codec)

@Sylar76 - Thanks for hopping in here! vBIOS edit (of some kind) is needed here I think, but I can’t edit vBIOS 1024 due to no BSF, same for GOP (only BSF for VBT)

I’ve tried to see to add vbios but I’ve same @Lost_N_BIOS issues. :frowning:



plutomaniac Do you have BSF for Coffee 1024-1025?

Dear Sir, good day!
Kindly ask you to help. I have Asus GX502LWS and have bricked laptop. I meen even now stiwch on. After service they disable GPU RTX 2070 Super. Removed PWM controller and bios for this GPU from motherboard. After that laptop is start switch on only on integrated video Intel UHD graphics. GPU RTX 2070 disapear from Windows. So laptop was working until kids not put the icon to switch on Gsync. After that laptop was restarted and no any Display showing (working) even from HDMI. I am think laptop was restart and during restart set parameter to the bios for loading again on GPU RTX 2070 which already removed. Laptop now working but no any dispaly showing. How i can mod bios for loading only on Integarted Intel UHD graphics. Many thanks for any answers.

So what was done back by the supposed “service” here: Asus GX502LWS laptop bios request

They repaired it fully or just disable the burned controller? What was done and reported to the customer (You) by them? What service did you paid after all?
There is no bios mod to enable a disable card on hw level… are you kidding with us?
We dont know whats the HDMI circuit connected to… and if its connected to the disabled card on hw level you cant re-routed by soft-mod or bios mods.
Thats an question to put to whoever repaired the laptop and knows the board schematic…

Burned PWM controller was removed from motherboard together with Vbios chip and one resistor (5018SG). After that Laptop was switch on and working only with integrated Intel UHD graphics card when i am get laptop from service. Ofcause windows not show RTX 2070 anymore. Programm Armory Crate for Asus have one icon to switch between dedicated graphics and integrated. (RTX 2070 or Intel UHD - Optimus mode). After switch on dedicated graphics Display is coming black after restart. Laptop working but black display. Even i didnt see Asus Logo and cant enter to the bios menu. But i am hear that windows started due sounding some notification and when insert some flashdrive.