Bios Mod to run 9900k on MSI Z170A-G45 Gaming (20E Paypal)


I tried to mod my Bios via CoffeeTime but it says: This MSI motherboard can’t works with Coffee CPUs rev. U0/P0 without changing BIOS region from compatible Z370 donor (if it exists).

Board: MSI Z170A-G45 Gaming

Current Bios version: 2.B0
ME Version: 11.6, Build 1142, Hot Fix 1

Can someone help me out? I pay you 20 Euro for a working bios.

I tried it out myself and now i flashed this bios to my mainboard. on the 6700k it will post but the 9900k gets stuck on code b2. any sugesstions?…977IMS.rar.html

@Vincemaan - I thought someone else replied on this to help you already, I must be dreaming

I think @dsanke or @chinobino may have BIOS for you to use on this board.

I think this Mainboard wasnt verry popular. A workmate suggested that Maybe i have the wrong stepping. So i will check my cpu tonight and check if this was the error.

@Vincemaan - 9900K has the following steppings, you can tell which is which by the SSPEC printed on CPU, in parenthesis below
P0 = (SRELS) >> Needs 906EC microcode >> your mod BIOS contains this
R0 = (SRG19) >> Needs 906ED microcode >> your mod BIOS does NOT contain this

This should only matter if you need to put in correct microcode for the revision CPU you have, if it’s missing in BIOS you are trying now (ie if you have SRG19 CPU, then you need to edit microcodes to add 906ED and then fix FIT table once you are done, I can do this for you if needed )
Otherwise there is some other issue you have, such as you need flash programmer to program in mod FD and or ME region. Or the BIOS mod is not proper etc.
Or you may need to connect and or isolate CPU pads if you have not already.

It would be verry kind of you if you could put the 906ED microcode in the bios. :slight_smile:
If its possible it would be good if you can leave the 6600k in the bios so i can install my old cpu to reach the bios if something does not work.

@Vincemaan - Sure, no problem! But, before I do anything here, please link me to the “Donor” BIOS you used so I can look at something, microcode volumes look “Off” in the BIOS you posted (Did you touch them?)
Note to self - if some uCode needs removed, be sure to leave 506E3

Thank you verry much.
The bios i used was this one: This is the origial bios for my Z170 Board.
Then i downloaded: [TOOL] Easy automated Mod tool for Coffee Lake bios and then i pressed the right number for r0 stepping and it did what it did. there were no errors in the command window.
then i changed the type of the file from .bin to .2b0 by renaming it because the .bin file wasnt showing in the flash utiliy of the bios.
Its the first time i do anything with a bios so i didnt really have any clue what i am doing. Sorry for that.

Edit 1:
@Lost_N_BIOS could you figure something out?

Edit 2: I think i nearly got it. i tried a newer version and added the r0 microcode.
now it goes as far as: new cpu or ram detected but then i cant press F1 to change anything.
i tried usb and and ps2 keyboard cleared cmos and i flashed one time with the me hap bit enabled and one thime like this. Ether it crashes or i have no io?
This is my mess and the untouched bios:…977IMS.rar.html

Can someone look over this?

@Vincemaan - So the answer to my question is Yes, via Revelaays’ tool, correct?
Please link me to the BIOS Download page for the “Donor” model you are using.
I have to run, but I will try to look into this to help as soon as I can.

[GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards (76)

@DeathBringer @Lost_N_BIOS Thank you verry verry much for your help. I think the Donor Bios thing is verry much impossible.

@dsanke @chinobino - does that table still hold true now for MSI Z170? If yes, why so many "NO" in that list, only for MSI Z170?

This is 16MB BIOS, so B0 only, no matter what? Sounds like it

Afraid so.